Word ei tallenna muutoksia tai näyttöön tulee Office-ohjelmassa virhesanoma Adobe Acrobat 7.0:n asentamisen jälkeen


Tärkeää Tässä artikkelissa käsitellään rekisterin muokkaamista. Muista varmuuskopioida rekisteri ennen sen muokkaamista. Varmista, että osaat palauttaa rekisterin, jos ongelmia ilmenee. Lisätietoja rekisterin varmuuskopioimisesta, palauttamisesta ja muokkaamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
256986 Microsoft Windowsin rekisterin kuvaus

Oire


Kun käytät jotakin tämän artikkelin alussa luetelluista Microsoft Office -ohjelmista, saattaa ilmetä vähintään yksi seuraavista ongelmista:
  • Kun vaihdat työtilaa Microsoft Wordissa, tekemiäsi muutoksia ei tallenneta, kun suljet Wordin. Näitä työtilaan tehtyjä muutoksia ovat esimerkiksi seuraavat:
    • makron luominen
    • oletusfontin vaihtaminen
    • automaattisen tekstin lisääminen
    • työkalurivin lisääminen.
    Kun käynnistät Wordin uudelleen, muuttamasi tai lisäämäsi kohteet eivät ole käytettävissä.

    Huomautus Tämä ongelma ilmenee, vaikka Kysy Normal-mallin tallennus -valintaruutu olisi valittuna.
  • Kun yrität käynnistää jonkin Office-ohjelman, näyttöön tulee virhesanoma, joka muistuttaa jotakin seuraavista:
    Suorituksenaikainen Visual C++ -virhe
    Microsoft Visual C++ Runtime Library

    Program files\Microsoft office\office10\tuotteen nimi.exe

    Sovellus on pyytänyt suorituksenaikaisuutta lopettamaan epätavallisella tavalla.
  • Kun avaat Word-asiakirjan, näyttöön tulee seuraava virhesanoma:
    Muisti ei riitä valitun fontin näyttämiseen.

Syy


Näitä ongelmia saattaa ilmetä sen jälkeen, kun olet asentanut Adobe Acrobat 7.0 Professionalin, Adobe Acrobat 7.0 Standardin tai Adobe Acrobat 7.0 Elementsin.

Acrobat 7.0 asentaa COM-apuohjelman seuraavaan kansioon:
\Acrobat 7.0\PDFMaker\Office
Tämä COM-apuohjelma antaa PDFMaker-kuvakkeet ja -valikkokomennot Office-ohjelmille.

Workaround


Voit kiertää ongelman jollakin seuraavista tavoista tilanteesi mukaisesti. Jos muutoksia ei tallenneta, kun suljet Wordin, käytä tapaa 1 tai 2. Jos näyttöön tulee virhesanoma, kun yrität käynnistää Office-ohjelman tai avata Word-asiakirjan, käytä tapaa 3 tai 4.

Tapa 1: Tallenna makrot, määritykset ja mukautetut asetukset Wordissa Tiedosto-valikon Tallenna kaikki -komennon avulla

Voit tallentaa makrot, määritykset ja mukautetut asetukset Wordissa seuraavasti:
  1. Paina VAIHTONÄPPÄINTÄ ja pidä sitä painettuna.
  2. Valitse Tiedosto-valikosta Tallenna kaikki.
Muutokset tallennetaan. Lisäksi muutokset ovat käytettävissä kaikissa muissa Word-asiakirjoissa.

Tapa 2: Mukauta Tiedosto-valikkoa lisäämällä siihen Tallenna kaikki -komento

Lisää Wordissa Tiedosto-valikkoon Tallenna kaikki -komento. Käytä tämän jälkeen Tallenna kaikki -komentoa aina, kun luot makron, määrityksen tai mukautetun asetuksen.

Voit lisätä Tiedosto-valikkoon Tallenna kaikki -komennon Wordissa seuraavasti:

  1. Valitse Työkalut-valikosta Mukauta.
  2. Valitse Komennot-välilehdessä Luokat-kohdasta Tiedosto.
  3. Vedä Komennot-kohdassa Tallenna kaikki -vaihtoehto Tiedosto-valikkoon. Kun Tiedosto-valikko avautuu, sijoita Tallenna kaikki -komento haluamaasi kohtaan.
  4. Sulje Mukauttaminen-valintaikkuna.

Tapa 3: Ota yhteyttä Adobeen

Ota yhteyttä Adobe Systems Incorporatediin ja selvitä, onko Acrobat 7.0:lle saatavana päivitys.
Saat Adobe Systems Incorporatedin yhteystiedot napsauttamalla jotakin artikkelin numeroa seuraavassa luettelossa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
65416 Laitteiston ja ohjelmiston jälleenmyyjien yhteystietoluettelo A - K (tämä artikkeli saattaa olla englanninkielinen)

60781 Laitteiston ja ohjelmiston jälleenmyyjien yhteystietoluettelo L - P (tämä artikkeli saattaa olla englanninkielinen)

60782 Laitteiston ja ohjelmiston jälleenmyyjien yhteystietoluettelo Q - Z (tämä artikkeli saattaa olla englanninkielinen)
Microsoft antaa kolmannen osapuolen yhteystiedot, jotta asiakas voi hankkia teknistä tukea. Nämä yhteystiedot voivat muuttua ilman ennakkoilmoitusta. Microsoft ei takaa kolmannen osapuolen yhteystietojen paikkansapitävyyttä.

Tapa 4: Poista Adobe-apuohjelma Officesta

Jos poistat Adobe-apuohjelman, et pysty tallentamaan tiedostoa PDF (Portable Document File) -tiedostona Office-ohjelmissa.

Voit poistaa Adobe-apuohjelman seuraavasti.

Huomautus Koska Microsoft Windowsista on useita versioita, seuraavat vaiheet saattavat olla erilaiset tietokoneellesi. Jos ohjeet eivät sovellu tietokoneellesi, lue tuotteen mukana toimitetuista ohjeista lisätietoja näiden vaiheiden tekemisestä.
  1. Sulje kaikki ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Asetukset ja valitse sitten Ohjauspaneeli.
  3. Kaksoisnapsauta Lisää tai poista sovellus -kuvaketta.
  4. Valitse Nykyiset asennetut ohjelmat -kohdassa Adobe Acrobat Professional 7.0 ja valitse sitten Muuta.
  5. Valitse Muokkaa ja valitse sitten Seuraava.
  6. Laajenna Create Adobe PDF.
  7. Laajenna Acrobat PDFMaker.
  8. Napsauta Microsoft Office -kohdanvieressä olevaa nuolta ja valitse sitten Not installed.
  9. Valitse ohjatussa Adobe Acrobat Professional 7.0 Setup Wizard -toiminnossa OK.
  10. Sulje Lisää tai poista sovellus -valintaikkuna.
Jos aiemmin tässä artikkelissa mainitut ongelmat ilmenevät yhä näiden toimien tekemisen jälkeen, poista Adobe-apuohjelma rekisteristä manuaalisesti.

Tärkeää Ennen kuin poistat Adobe-apuohjelman manuaalisesti, ota Adobeen yhteyttä ja kysy lisätietoja.

Varoitus Vakavia ongelmia saattaa ilmetä, jos muokkaat rekisteriä virheellisesti Rekisterieditorilla tai jollakin muulla tavalla. Näiden ongelmien ilmetessä saatat joutua asentamaan käyttöjärjestelmäsi uudelleen. Microsoft ei takaa, että nämä ongelmat voidaan ratkaista. Muokkaat rekisteriä omalla vastuulla.
Voit poistaa Adobe-apuohjelman manuaalisesti seuraavasti:
  1. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  2. Etsi seuraava rekisterin aliavain ja napsauta sitä:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
  3. Valitse Tiedosto-valikosta Vie, kirjoita tiedostonimi ja valitse sitten Tallenna.
  4. Napsauta PDFMaker.OfficeAddin-rekisterimerkintää hiiren kakkospainikkeella ja valitse sitten Poista.
  5. Poista apuohjelman rekisterimerkinnät seuraavista rekisterin aliavaimista tekemällä vaiheet 3 ja 4:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin



    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
  6. Sulje Rekisterieditori.

Enemmän tietoa


Normal.dot-tiedosto on Wordin käyttämä oletusmalli. Oletusarvon mukaan kaikkiin uusiin asiakirjoihin vaikuttavat muutokset on tallennettu Normal.dot-tiedostoon. Tämä ongelma ilmenee, jos et määritä toista mallia muutosten tallentamisen yhteydessä. Acrobat 7.0 voi estää Wordia tallentamasta muutoksia automaattisesti Normal.dot-tiedostoon.

Lisätietoja tästä ongelmasta saat seuraavasta Adoben Web-sivustosta: