Olet tällä hetkellä offline-tilassa. Internet-yhteyden muodostamista uudelleen odotetaan

.NET Framework-version ja käyttöympäristön tuki korjaus virheet

HUOMIO: Tämä artikkeli on käännetty Microsoft kielenkäännös-ohjelmistolla kielenkääntäjän sijaan. Microsoft tarjoaa sekä kielenkäännös-ohjelmistolla että kielenkääntäjällä käännettyjä artikkeleita jotta kaikki Knowledge Base- artikkelit ovat tarjolla paikallisessa kielellä. Huomioittehan että kielenkäännös-ohjelmistolla käännetyt artikkelit eivät aina ole täydellisiä. Kielenkäännös-ohjelmistolla käännetyssä artikkelissa voi olla kielioppi-, sanasto- tai sanamuotovirheitä. Microsoft ei ole vastuussa käännösvirheiden mahdollisesti aihettamista vahingoista. Microsoft myös päivittää usein kielenkäännös-ohjelmistoa.

Tämän artikkelin englanninkielinen versio on: 2715633
Huomautus Tässä artikkelissa esitellään korjaus virhesanomat. Jos olet käyttäjä, kokeile tarkkuus Kun kohtaat korjaus virhe "Sinun täytyy ottaa Windows in ominaisuudet-valintaikkunasta .NET kehys." Mille tahansa muiden virheiden korjaus-kohderyhmän sisältö on app valmistaja tai kehittäjä, sinun tulee ilmoittaa, että on ongelmia tämän app jotta app toimittajalta.
Virhe: "sinun on otettava käyttöön Windowsin ominaisuudet-valintaikkunasta .NET kehys"
Näyttöön tulee virhesanoma
Tämä sovellus käynnistäminen ei onnistu. Sinun täytyy ottaa Windows in ominaisuudet-valintaikkunasta .NET kehys (Ohjauspaneeli, valitse Ohjelmat, Windowsin ominaisuuksien ottaminen käyttöön tai poistaminen käytöstä).
Syy
Tämä ongelma ilmenee, koska sovellus ei ole määritetty siten, että on mahdollista selvittää oikea .NET Framework runtime-versio. Vastaava korjaus-koodi on SHIM_GOTO_CONTROLPANEL.
Ratkaisu
Ratkaise se, .NET Framework 3.5 on Windows 7 ja Windows 8-käyttöjärjestelmän ominaisuus käyttöön.

Windows 8

.NET Framework 3.5 on oletusarvon mukaan käytössä Windows 8. Voit ottaa sen käyttöön seuraavasti:
  1. Kirjoita ensin muutama aloitusnäytössäOhjauspaneeli, ja valitse sittenOhjauspaneelisovellusten luettelosta.
  2. -Ohjauspaneeli, valitseOhjelmat. (Tai valitseOhjelmat ja toiminnot-Jos et käytä luokka oletusnäkymä.)
  3. -Ohjelmat ja toiminnot, valitseWindowsin ominaisuuksien ottaminen käyttöön ja poistaminen käytöstäAvaaWindowsin ominaisuudet-valintaikkuna.
  4. -Windowsin ominaisuudet-Valitse.NET framework 3.5 (sisältyy .NET 2.0 ja 3.0)valintaruudun valinta ja valitse sittenOK.

Windows 7:

Oletusarvon mukaan .NET Framework 3.5 on käytössä Windows 7, niin tämä virhe ilmenee vain, jos ominaisuus on aiemmin poistettu käytöstä. .NET Framework 3.5 uudelleen käyttöön seuraavasti:
  1. Valitse Käynnistä-valikostaOhjauspaneeli.
  2. -Ohjauspaneeli, valitseOhjelmat. (Tai valitseOhjelmat ja toiminnot-Jos et käytä luokka oletusnäkymä.)
  3. -Ohjelmat ja toiminnot, valitseWindowsin ominaisuuksien ottaminen käyttöön ja poistaminen käytöstäAvaaWindowsin ominaisuudet-valintaikkuna.
  4. -Windowsin ominaisuudet-ValitseMicrosoft .NET Framework 3.5.1valintaruudun valinta ja valitse sittenOK.

Kolmansien osapuolten ratkaisujen vastuuvapauslauseke

Tiedot ja tässä asiakirjassa ratkaisun edustavat Microsoft Corporationin nykyisen näkymän näistä ongelmista artikkelin julkaisemisesta. Tämä ratkaisu on saatavana Microsoftin tai kolmannen osapuolen palveluntarjoajan kautta. Emme erityisesti suosittele mitään kolmannen osapuolen palveluntarjoajan tai kolmannen osapuolen ratkaisua, jonka kuvaus saattaa olla tässä artikkelissa. Saattaa olla olemassa myös muita kolmannen osapuolen palveluntarjoajia tai kolmansien osapuolten ratkaisuja, joita tässä artikkelissa ei kuvata. Koska olemme täytyy vastata muuttuviin, nämä tiedot olisi ei tulkita sitoumuksen Microsoft. Emme takaa tai hyväksyy tai liuosta, joka on esitetty Microsoftin tai minkä tahansa mainitun kolmannen osapuolen palveluntarjoajan tietojen oikeellisuus.

Microsoft ei anna mitään takuita, ja jättää kaikki esitykset, takuut ja vastuut, onko ilmaistut, oletetut ja laista johtuvat. Nämä sisältävät mutta eivät rajoitu LUPAUKSET, takuut tai ehdot, otsikko, LOUKKAAMATTOMUUDESTA, tyydyttävässä kunnossa, soveltuvuudesta kaupankäynnin kohteeksi ja sopivuudesta johonkin tiettyyn tarkoitukseen minkä tahansa palvelun, ratkaisun, tuotteen tai muiden aineistoa tai tietoja osalta. Missään tapauksessa Microsoft on velvollinen tahansa kolmannen osapuolen ratkaisun, jossa mainitaan tässä artikkelissa.

Virhe: "Tämä sovellus käynnistäminen ei onnistu"
Näyttöön tulee virhesanoma
Tämä sovellus käynnistäminen ei onnistu.
Syy
App ei ole määritetty siten, että on mahdollista selvittää oikea .NET Framework runtime-versio. Vastaava korjaus-koodi on SHIM_NOVERSION_FOUND.
Ratkaisu
Ei voi korjata kokoonpano-ongelman itse. Voit ratkaista ongelman toimittajalta app.
Virhe: "se perustuu .NET Framework-version, jota ei tueta tässä laitteessa"
Näyttöön tulee virhesanoma
Tämä sovellus käynnistäminen ei onnistu. Se perustuu .NET Framework-version, jota ei tueta tässä laitteessa.
Syy
Tämä ongelma ilmenee, koska sovellus ei ole tehty tämän laitteen toimimaan. Esimerkiksi yrität ehkä suorittaa app, joka on rakennettu laite, joka on ARM-suoritin Intel-suoritinta. Vastaava korjaus-koodi on SHIM_UNSUPPORTED_PLATFORM.
Ratkaisu
Ei voi korjata kokoonpano-ongelman itse. Asenna oikea versio sovelluksen toimittajalta app.
Tietoja virhesanomista korjaus
Kun käynnistät Microsoft .NET Framework-sovellus, korjaus-ohjelma määrittää common language runtime (CLR) version ladata, lataa sen ja käynnistää sovelluksen. Jos korjaus kohtaa virheen (esimerkiksi jos se ei löydä tietokoneeseen .NET Frameworkin versiot), se tuo näyttöön virhesanoman ohjeita. Tässä artikkelissa on Lisätietoja virhekoodeista, SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELja SHIM_UNSUPPORTED_PLATFORM.

Saat lisätietoja .NET Frameworkin alustus-virheet-kohdassa seuraavassa MSDN: N WWW-sivulla:

Varoitus: Tämä artikkeli on käännetty automaattisesti

Ominaisuudet

Artikkelin tunnus: 2715633 – Viimeisin tarkistus: 05/21/2016 07:33:00 – Versio: 5.0

Microsoft .NET Framework 4.5

  • kbquadranttechsupp kbconsumer kbsurveynew kbtshoot kbexpertiseinter kbmt KB2715633 KbMtfi
Palaute
html>