Olet tällä hetkellä offline-tilassa. Internet-yhteyden muodostamista uudelleen odotetaan

Lähetä sähköpostitse -komento puuttuu tai se ei ole käytettävissä Excel 2007:ssä, PowerPoint 2007:ssä tai Word 2007:ssä

Oire
Valitset Microsoft Office Excel 2007:ssä, Microsoft Office PowerPoint 2007:ssä tai Microsoft Office Word 2007:ssä Office-valikosta Lähetä. Kun teet tämän, kohtaat jonkin seuraavista ongelmista:
  • Lähetä-komento ei ole käytettävissä.
  • Lähetä sähköpostitse -komento ei ole käytettävissä.
Syy
Tämä ongelma saattaa ilmetä, kun Microsoft Outlook ei ole asennettuna tietokoneeseen.
Ratkaisu
Voit ratkaista tämän ongelman jollakin seuraavista tavoista.

Tapa 1: Muuta Outlook oletussähköpostiohjelmaksi

Jos haluat, että Outlook muutetaan oletussähköpostiohjelmaksi puolestasi, siirry Korjaa ongelma puolestani -osaan. Jos haluat muuttaa Outlookin oletussähköpostiohjelmaksi itse, siirry Haluan korjata ongelman itse -osaan.

Korjaa ongelma puolestani


Jos haluat, että oletussähköpostiohjelma muutetaan Outlookiksi automaattisesti, napsauta Korjaa tämä ongelma -linkkiä. Tiedostojen lataaminen -valintaikkunassa Suorita ja noudata tämän ohjatun toiminnon ohjeita.




Huomautus Tämä ohjattu toiminto saattaa olla saatavana vain englanninkielisenä. Automaattinen korjaus toimii kuitenkin myös muiden Windowsin kieliversioiden kanssa.

Huomautus Jos et ole käyttämässä tietokonetta, jossa tämä ongelma ilmenee, voit tallentaa automaattisen korjauksen muistitikkuun tai CD-levylle ja suorittaa sen sitten tietokoneessa, jossa ongelma ilmenee.

Haluan korjata ongelman itse

Voit muuttaa Outlookin oletussähköpostiohjelmaksi itse seuraavasti:
  1. Käynnistä Microsoft Internet Explorer.
  2. Valitse Työkalut-valikosta Internet-asetukset.
  3. Valitse Ohjelmat-välilehti.
  4. Valitse Sähköposti-ruudussa Microsoft Outlook.
  5. Valitse OK.

Tapa 2: Rekisteriasetusten tarkistaminen

Tärkeää Tässä osassa, tavassa tai tehtävässä olevissa vaiheissa kerrotaan, miten rekisteriä muokataan. Vakavia ongelmia saattaa kuitenkin ilmetä, jos rekisteriä muokataan virheellisesti. Varmista siis, että noudatat ohjeita huolellisesti. Varmuuskopioi rekisteri varmuuden vuoksi ennen sen muokkaamista. Tällöin voit palauttaa sen, jos ongelmia ilmenee. Lisätietoja rekisterin varmuuskopioimisesta ja palauttamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
322756 Rekisterin varmuuskopioiminen ja palauttaminen Windowsissa
  1. Sulje kaikki ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita Avaa-ruutuun regedit ja valitse sitten OK.
  3. Etsi seuraava rekisterin aliavain ja valitse se:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem
  4. Etsi seuraavat rekisteriarvot. Nämä arvot ovat yleensä Windows Messaging Subsystem -avaimessa.
    NimiTyyppiData
    MAPIREG_SZ1
    CMCREG_SZ1
    CMCDLLNAMEREG_SZ Mapi.dll
    CMCDLLNAME32REG_SZ Mapi32.dll
    MAPIXREG_SZ 1
    MAPIXVERREG_SZ 1.0.0.1
    OLEMessagingREG_SZ1
  5. Jos jokin näistä rekisteriarvoista puuttuu, lisää arvot seuraavasti:
    1. Valitse Windows Messaging Subsystem -aliavain, valitse Muokkaa -valikosta Uusi ja valitse sitten Merkkijonoarvo.
    2. Kirjoita puuttuvan arvon nimi ja paina sitten ENTER-näppäintä.
    3. Valitse uusi arvo ja valitse sitten Muokkaa-valikosta Muokkaa.
    4. Kirjoita puuttuvalle merkkijonoarvolle oikea arvo Muokkaa merkkijonoa -valintaikkunan Arvon data -ruutuun.
    5. Toista vaiheet 6a - 6d jokaiselle vaiheen 4 taulukosta puuttuvalle arvolle.
  6. Valitse Tiedosto-valikosta Lopeta.
Yleensä Excel 2007, PowerPoint 2007 ja Word 2007 näyttävät oikeat sähköpostivaihtoehdot automaattisesti, kun vaaditut rekisteriavaimet ovat olemassa. Jos nämä ohjelmat eivät näytä oikeita sähköpostivaihtoehtoja tässä kuvattujen toimien tekemisen jälkeen, lisää sähköpostivaihtoehdot kyseisiin ohjelmiin. Voit tehdä tämän seuraavasti:
  1. Valitse Tiedosto-valikosta Ohjelman asetukset.
  2. Valitse Mukauttaminen ja valitse sitten Komennot-luettelosta Kaikki komennot.
  3. Valitse haluamasi komento ja lisää se sitten Pikatyökaluriviin valitsemalla Lisää. Valitse esimerkiksi Lähetä tarkistettavaksi ja lisää Lähetä tarkistettavaksi -komento työkaluriviin valitsemalla Lisää.
  4. Valitse OK.

Tapa 3: Tiedoston lähettäminen liitteenä sähköpostiohjelmasta

Ongelman kiertotapana voit liittää Office-tiedoston viestiin sähköpostiohjelmasta selaamalla tiedoston sijaintiin.
Enemmän tietoa
Microsoft Office 2003 -versiota aiemmat Microsoft Office -versiot käyttävät MAPI-tietoihin sekä rekisteriä että Win.ini-tiedostoa. Office 2003 ja Officen uudemmat versiot käyttävät MAPI-tietoihin vain rekisteriä.

Lisätietoja on seuraavassa Microsoftin verkkosivustossa:
WD2007 Word2007 PPT2007 XL2007 email fixit fix it
Ominaisuudet

Artikkelin tunnus: 918792 – Viimeisin tarkistus: 09/18/2011 19:19:00 – Versio: 3.0

Microsoft Office Excel 2007, Microsoft Office PowerPoint 2007, Microsoft Office Word 2007

  • kbfixme kbmsifixme kbtshoot kbexpertisebeginner kbprb KB918792
Palaute
ent.write("