#ARVO! Virhe Keski arvo-tai summa-funktioissa

Jos Keski arvo tai summa viittaa soluihin, jotka sisältävät #VALUE! virheet, kaavat johtavat #VALUE! -virheen.

#ARVO! Virhe Keski arvo

Jotta virhearvot voidaan jättää huomiotta, laaditaan kaava, joka ohittaa viittausalueen virheet laskettaessa keskiarvoa jäljellä olevilla normaaleilla arvoilla.

Tällöin käytetään KESKIARVO-funktiota yhdessä JOS- ja ONVIRHE-funktioiden kanssa sen määrittämiseksi, onko määritetyllä alueella virhe. Tilanne edellyttää matriisikaavaa:

=KESKIARVO(JOS(ONVIRHE(B2:D2),””,B2:D2))

Tämä on matriisi kaava. Sinun täytyy joko painaa ENTER -näppäintä (vain jos käytät Microsoft 365 ) tai Ctrl + Vaihto + Enter-näppäin yhdistelmää kaavassa.

Huomautus: Jos käytössäsi on Microsoft 365-version nykyinen versio, voit yksinkertaisesti kirjoittaa kaavan tulostus soluun ja vahvistaa kaavan dynaamiseksi matriisi kaavaksi painamalla ENTER -näppäintä. Muussa tapa uksessa kaava on kirjoitettava perintönä matriisi kaavana valitsemalla ensin tulos solu, kirjoittamalla kaavan tulostus soluun ja painamalla sitten näppäin yhdistelmää CTRL + VAIHTO + ENTER vahvistaaksesi sen. Excel lisää puolestasi kaavan alkuun ja loppuun aaltosulkeet. Katso lisätietoja matriisikaavoista kohdasta Matriisikaavoihin liittyviä ohjeita ja esimerkkejä.

Matriisi-funktio Keski ARVOLLA, jos haluat korjata #VALUE! -virheen korjaaminen

Huomautus: Edellä oleva funktio toimii #ARVO!-virheen lisäksi myös muun muassa #PUUTTUU-, #TYHJÄARVO- ja #JAKO/0!-virheiden kanssa.

Voit käyttää SUMMA-funktiota samalla tavalla:

= SUMMA(JOS(ONVIRHE(B2:D2),””,B2:D2))

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

#ARVO! -virheen korjaaminen

KESKIARVO-funktio

SUMMA-funktio

Yleiskuva kaavoista Excelissä

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excelin funktiot (aakkosjärjestyksessä)

Kaikki Excelin funktiot (luokittain)

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×