Lukujen tai päivämäärien laskeminen ehdon perusteella

Jos haluat laskea yhden ehdon täyttävät luvut tai päivämäärät (kuten suurempi tai suurempi kuin, pienempi, suurempi tai yhtä suuri tai pienempi kuin tai yhtä suuri kuin), käytä LASKE.JOS-funktiota. Jos haluat laskea alueeseen kuuluvat luvut tai päivämäärät (kuten yli 9 000 ja samanaikaisesti alle 22 500), voit käyttää LASKE.JOS.JOS.MÄÄRÄ-funktiota. Vaihtoehtoisesti voit käyttää myös TULOJEN.SUMMA-funktiota.

Esimerkki

Huomautus: Sinun on säätää näitä tässä kuvattuja solukaavan viittauksia sen mukaan, mihin ja miten nämä esimerkit kopioidaan Excel taulukkoon.

1

A

B

2

Myyjä

Lasku

3

Larsson

15 000

4

Larsson

9 000

5

Lidman

8 000

6

Suyma

20 000

7

Larsson

5 000

8

Suominen

22 500

9

Kaava

Kuvaus (tulos)

10

=LASKE.JOS(B2:B7,">9000")

LASKE.JOS-funktio laskee alueella B2:B7 niiden solujen määrän, jotka sisältävät lukuja, jotka ovat suurempia kuin 9 000 (4)

11

=LASKE.JOS(B2:B7,"<=9000")

LASKE.JOS-funktio laskee alueen B2:B7 solujen määrän, joka sisältää lukuja, jotka ovat pienempiä kuin 9 000 (4)

12

=LASKE.JOS.MÄÄRÄ(B2:B7,">=9000",B2:B7,"<=22500")

LASKE.JOS.JOUKKO-funktio (käytettävissä Excel 2007:ssä ja sitä uudemmassa versiossa) laskee alueen B2:B7 solujen määrän, joka on suurempi tai yhtä suuri kuin 9 000 ja on pienempi tai yhtä suuri kuin 22 500 (4)

13

=TULOJEN.SUMMA((B2:B7>=9000)*(B2:B7<=22500))

TULOJEN.SUMMA-funktio laskee alueen B2:B7 solujen määrän, joka sisältää luvun, joka on suurempi tai yhtä suuri kuin 9 000 ja pienempi tai yhtä suuri kuin 22500 (4). Voit käyttää tätä funktiota Excel 2003:ssa ja aiemmissa versioissa, joissa LASKE.JOS.MÄÄRÄ ei ole käytettävissä.

14

Päivämäärä

15

3/11/2011

16

1.1.2010

17

12/31/2010

18

6/30/2010

19

Kaava

Kuvaus (tulos)

20

=LASKE.JOS(B14:B17,">1.3.2010")

Laskee alueen B14:B17 solujen määrän, kun tiedot ovat suurempia kuin 1.3.2010 (3)

21

=LASKE.JOS(B14:B17,"31.12.2010")

Laskee alueen B14:B17 solujen määrän, joka on yhtä suuri kuin 31.12.2010 (1). Yhtäläisyysmerkkiä ei tarvita ehdoissa, joten sitä ei sisällytetä tähän (kaava toimii yhtäläisyysmerkkinä, jos lisäät sen ("=31.12.2010").

22

=LASKE.JOS.A(B14:B17,">=1.1.2010";B14:B17;"<=31.12.2010")

Laskee alueen B14:B17 solujen määrän, jotka ovat väliltä 1.1.2010 ja 31.12.2010 (3).

23

=TULOJEN.SUMMA((B14:B17>=PÄIVÄYSARVO("1.1.2010"))*(B14:B17<=PÄIVÄYSARVO("31.12.2010"))

Laskee alueen B14:B17 solujen määrän, jotka ovat väliltä 1.1.2010 ja 31.12.2010 (3). Tämä esimerkki korvaa LASKE.JOS.JOS.EXCEL 2007:ssä. PÄIVÄYSARVO-funktio muuntaa päivämäärät numeroarvoksi, jota TULOJEN.SUMMA-funktio voi sitten käyttää.

Tarvitsetko lisäohjeita?

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

×