Miten korjata #DIV/0! -virheen korjaaminen

Microsoft Excel näyttää #JAKO/0! -virheen, kun luku jaetaan nollalla (0). Näin tapahtuu, kun syötät yksinkertaisen kaavan (esimerkiksi =5/0) tai kun kaava viittaa arvon 0 sisältävään tai tyhjään soluun, kuten tässä kuvassa.

Esimerkkejä kaavoista, jotka aiheuttavat #DIV/0! -virheet.

Korjaa virhe jollakin seuraavista tavoista:

  • Varmista, että funktion tai kaavan jakajana ei ole nolla tai tyhjä solu.

  • Muuta kaavan soluviittaus toiseen soluun, joka ei sisällä nollaa (0) tai tyhjää arvoa.

  • Kirjoita arvo #PUUTTUU soluun, johon viitataan kaavassa jakajana. Näin kaavan tulokseksi tulee #PUUTTUU sen merkiksi, että jakajan arvo ei ole käytettävissä.

Monta kertaa #DIV/0! -virhettä ei voida välttää, koska kaavat odottavat sinun tai jonkun muun syötteitä. Tässä tapauksessa et halua virhesanoman näkyvän lainkaan, joten voit estää virheen käsittelyn muutamalla virheenkäsittelymenetelmällä, kun odotat tietoja.

Määritä nimittäjä nollan (0) tai tyhjän arvon osalta

Yksinkertaisin tapa estää #DIV/0! -virhe on käyttää JOS-funktiota nimittäjän olemassaolon arvioimiseksi. Jos arvo on 0 tai ei, näytä kaavan tulokseksi arvo 0 tai ei #DIV/0! -virhearvon, muussa tapauksessa laske kaava.

Jos virheen tuottava kaava on esimerkiksi =A2/A3, palauta nolla (0) käyttämällä kaavaa =JOS(A3,0,A2/A3,0) tai tyhjä merkkijono käyttämällä kaavaa =JOS(A3,A2/A3,""). Voit myös näyttää seuraavanlaisen mukautetun viestin: = JOS(A3,A2/A3, "Tiedot tarvitaan"). Ensimmäisen esimerkin OSAMÄÄRÄ-funktiolla voit käyttää kaavaa =IF(A3,OSAMÄÄRÄ(A2,A3),0). Tämä kertoo Excelille JOS(A3 olemassa, palauta kaavan tulos, muussa tapauksessa ohita se).

Esimerkkejä #DIV/0! -virheet.

Josvirhe-funktion avulla voit estää #DIV/0! -virheen korjaaminen

Voit myös estää tämän virheen sisäkkäin jakotoiminnon JOSVIRHE-funktion sisällä. Käyttämällä tässäkin jakolaskua A2/A3 voit käyttää kaavaa =JOSVIRHE(A2/A3,0). Tällöin Excel palauttaa arvoksi 0, jos kaavan tulos on virhe, muussa tapauksessa Excel palauttaa kaavan tuloksen.

Excel 2007:ää aiemmassa versiossa voit käyttää JOS(ONVIRHE())-menetelmää: =JOS(ONVIRHE(A2/A3),0,A2/A3) (katso lisätietoja ON-funktioista).

Huomautus: sekä JOSVIRHE- että JOS(ONVIRHE())-menetelmät ovat virhekäsittelijiä, sillä ne poistavat kaikki virheet, eivät vain #DIV/0!. Varmista ennen virheenkäsittelyn käyttöä, että kaava toimii oikein. Muussa tapauksessa et välttämättä huomaa, että kaava ei toimi haluamallasi tavalla.

Vihje: Jos Excelissä on käytössä virheentarkistus, voit napsauttaa virheen näyttävän solun vieressä olevaa Painikkeen kuva -painiketta. Valitse Näytä laskennan vaiheet, jos se on käytettävissä, ja valitse tietoihisi parhaiten sopiva ratkaisu.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa

Katso myös

JOS-funktio

JOSVIRHE-funktio

ON-funktiot

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Tarvitsetko lisäohjeita?

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×