Tässä artikkelissa kuvataan Microsoft Excelin SIIRTYMÄ-funktion kaavasyntaksi ja käyttö.

Kuvaus

Palauttaa viittauksen alueeseen, joka on sarakkeiden tai rivien määrän avulla määritetyn etäisyyden päässä solualueesta solusta. Funktion palauttama viittaus voi kohdistua yksittäiseen soluun tai solualueeseen. Voit määrittää palautettavan viittauksen rivien ja sarakkeiden määrän.

Syntaksi

SIIRTYMÄ(viittaus; rivit; sarakkeet; [korkeus]; [leveys])

SIIRTYMÄ-funktion syntaksissa on seuraavat argumentit:

  • Viittaus Pakollinen. Viittaus, josta siirtymä perustuu. Viittauksen on viitattava viereiseen soluun tai vierekkäisten solujen alueeseen. Muussa tapauksessa SIIRTYMÄ palauttaa #VALUE! -virhearvon.

  • Rivit    Pakollinen. Niiden rivien määrä ylös- tai alaspäin, johon haluat yläsolun viittaamaan. Jos riviargumenttina käytetään lukua 5, viittauksen vasemmassa yläkulmassa oleva solu on viisi riviä viittauksen alapuolella. Rivit voivat olla positiivisia (eli alkuviittauksen alapuolella olevia) tai negatiivisia (eli aloitusviittauksen yläpuolella).

  • Cols    Pakollinen. Vasemmalla tai oikealla olevien sarakkeiden määrä, johon haluat tuloksen vasemman yläsolun viittaamaan. Jos sarakeargumenttina käytetään lukua 5, viittauksen vasen yläsolu on viisi saraketta viittauksen oikealla puolella. Sarake voi olla positiivinen (eli aloitusviittauksen oikealla puolella) tai negatiivinen (eli aloitusviittauksen vasemmalla puolella).

  • Korkeus    Valinnainen. Luku, joka osoittaa palautettavan viittauksen korkeuden riveinä. Luvun on oltava positiivinen.

  • Leveys    Valinnainen. Luku, joka osoittaa palautettavan viittauksen leveyden. Luvun on oltava positiivinen.

Huomautuksia

  • Jos rivit ja sarakkeet-siirtymäviittaus on laskentataulukon reunan yli, SIIRTYMÄ-funktio palauttaa #REF! -virhearvon.

  • Jos et määritä korkeus- tai leveys-argumenttia, ohjelma käyttää viittaus-argumentin korkeutta ja leveyttä.

  • SIIRTYMÄ-funktio ei siirrä soluja tai muuta valintaa, se vain palauttaa viittauksen. SIIRTYMÄ-funktiota voi käyttää missä tahansa funktiossa, jossa annetaan viittausargumentteja. Esimerkiksi kaava SUMMA(SIIRTYMÄ(C2;1;2;3;1)) laskee kokonaisarvon 3 rivin korkuisesta ja 1 sarakkeen levyisestä alueesta, joka on yhden rivin verran solun C2 alapuolella ja 2 saraketta solun C2 oikealla puolella.

Esimerkki

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Kaava

Kuvaus

Tulos

=SIIRTYMÄ(D3;3;-2;1;1)

Näyttää solun B6 arvon (4).

4

=SUMMA(SIIRTYMÄ(D3;F5;3;-2;3;3))

Alueen B6:D8 summat

34

=SIIRTYMÄ(D3; -3; -3)

Palauttaa virhearvon, koska kaava viittaa solualueeseen, jota taulukossa ei ole.

#VIITTAUS!

Tiedot

Tiedot

4

10

8

3

3

6

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Insider-käyttäjille

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×