SUMMA.JOS (SUMMA.JOS-funktio)

SUMMA.JOS (SUMMA.JOS-funktio)

Summa. Jos -funktiolla voit laskea yhteen niiden alue arvot, jotka täyttävät määrittämäsi ehdot. Oletetaan esimerkiksi, että lukuja sisältävässä sarakkeessa haluat laskea yhteen vain ne arvot, jotka ovat suurempia kuin 5. Voit käyttää seuraavaa kaavaa: = summa. Jos (B2: B25; ">5")

Suuren vaikutuksen tekeminen ilmoituksilla

Tämä video on osa lukujen lisääminen Excelissä-harjoitus kurssia.

Vihjeitä: 

  • Voit halutessasi käyttää ehtoja yhdelle alueelle ja laskea eri alueen vastaavien arvojen summan. Esimerkiksi kaava =SUMMA.JOS(B2:B5;"John";C2:C5) laskee vain niiden alueen C2:C5 solujen summan, joita vastaavien solujen arvo alueella B2:B5 on "John".

  • Jos haluat laskea solujen summan useiden ehtojen perusteella, lue ohjeaihe SUMMA.JOS.JOUKKO-funktio.

Tärkeää: SUMMA. Jos-funktio palauttaa vääriä tuloksia, kun sitä käytetään 255-merkkejä yli-tai merkki jono #VALUE!.

Syntaksi

SUMMA.JOS(alue; ehdot; [summa-alue])

SUMMA.JOS-funktion syntaksilla on seuraavat argumentit:

  • alue   Pakollinen. Solualue, jonka haluat arvioida ehtojen mukaan. Kunkin alueen solujen on sisällettävä lukuja tai lukuja sisältäviä nimiä, matriiseja tai viittauksia. Funktio ohittaa tyhjät arvot ja tekstiarvot. Valittu alue voi sisältää päivämääriä, jotka ovat Excelin vakiomuodossa (esimerkkejä alla).

  • ehdot   Pakollinen. Ehtojen muoto on luku, lauseke, soluviittaus, teksti tai funktio, joka määrittää yhteenlaskettavat solut. Yleismerkit voidaan sisällyttää-kysymys merkki (?), joka vastaa mitä tahansa yksittäistä merkkiä, tähti (*), joka vastaa mitä tahansa merkki jonoa. Jos haluat löytää tekstissä olevan kysymysmerkin tai tähden, kirjoita tilde (~) ennen merkkiä.

    Esimerkiksi ehdot voidaan ilmaista muodossa 32, ">32", B5, "3?", "Apple *", "* ~?" tai tänään ().

    Tärkeää: Mikä tahansa tekstiehto tai loogisia tai matemaattisia symboleita sisältävä ehto on sijoitettava lainausmerkkien (") sisään. Jos ehto on numeerinen, lainausmerkkejä ei tarvita.

  • sum_range   Valinnainen. Lisättävät todelliset solut, jos haluat lisätä muita kuin Range -argumentissa määritettyjä soluja. Jos sum_range -argumentti jätetään pois, Excel lisää alueet -argumentissa määritetyt solut (samat solut, joihin ehtoja käytetään).

    Sum_range pitäisi olla sama koko ja muoto kuin alueena. Jos se ei ole, suoritus kyky voi kärsiä ja kaava laskee yhteen solu välin, joka alkaa sum_range ensimmäisestä solusta, mutta jonka mitat ovat samat kuin alueella. Esimerkki:

    alue

    sum_range

    Todelliset summattuina olevat solut

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Esimerkkejä

Esimerkki 1

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Kiinteistön hinta

Välityspalkkio

Tiedot

100 000 €

7 000 €

250 000 €

200 000 €

14 000 €

300 000 €

21 000 €

400 000 €

28 000 €

Kaava

Kuvaus

Tulos

=SUMMA.JOS(A2:A5;">160000";B2:B5)

Yli 160 000 € maksavien kiinteistöiden myyntipalkkioiden summa.

63 000 €

=SUMMA.JOS(A2:A5;">160000")

Yli 160 000 € maksavien kiinteistöjen arvojen summa.

900 000 €

=SUMMA.JOS(A2:A5;300000;B2:B5)

Yli 300 000 € maksavien kiinteistöiden myyntipalkkioiden summa.

21 000 €

=SUMMA.JOS(A2:A5;">" & C2;B2:B5)

Yli solussa C2 olevan arvon maksavien kiinteistöiden myyntipalkkioiden summa.

49 000 €

Esimerkki 2

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, jotta näet kaikki tiedot.

Luokka

Ruoka

Myynti

Vihannekset

Tomaatit

2 300 €

Vihannekset

Sellerit

5 500 €

Hedelmät

Appelsiinit

800 €

Voi

400 €

Vihannekset

Porkkanat

4 200 €

Hedelmät

Omenat

1 200 €

Kaava

Kuvaus

Tulos

=SUMMA.JOS(A2:A7;"Hedelmät";C2:C7)

Kaikkien Hedelmät-luokassa olevien ruokien myynnin summa.

2 000 €

=SUMMA.JOS(A2:A7;"Vihannekset";C2:C7)

Kaikkien Vihannekset-luokassa olevien ruokien myynnin summa.

12 000 €

=SUMMA.JOS(B2:B7;"*at";C2:C7)

Kaikkien kirjaimiin "at" (Porkkanat ja Omenat) päättyvien elintarvikkeiden myynnin summa.

4 300 €

=SUMMA.JOS(A2:A7;"";C2:C7)

Kaikkien sellaisten elintarvikkeiden summa, joilla ei ole luokkaa määritettynä.

400 €

Sivun alkuun

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Tutustu myös seuraaviin ohjeaiheisiin

SUMMA.JOS.JOUKKO-funktio laskee yhteen kaikki useita ehtoja täyttävät argumentit

NELIÖSUMMA-funktio laskee yhteen useita arvoja suoritettuaan jokaiselle niistä matemaattisen neliölaskutoimituksen

LASKE.JOS-funktio laskee ainoastaan yhden ehdon täyttävät arvot

LASKE.JOS.JOUKKO-funktio laskee ainoastaan useita ehtoja täyttävät arvot

JOS.JOUKKO-funktio (Office 365, Excel 2016 ja uudempi versio)

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Matemaattiset ja trigonometriset funktiot

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×