Voit julkaista työkirjan Microsoft SharePoint -kirjastossa, jotta muut käyttäjät voivat tarkastella tai muokata sitä selaimessa, vaikka heidän tietokoneeseensa ei olisikaan asennettu Exceliä. Julkaiseminen tarkoittaa käytännössä samaa kuin tallentaminen, mutta se tarjoaa joitain sisäänrakennettuja lisätoimintoja, joiden ansiosta voit säädellä sitä, mitä muut käyttäjät näkevät avatessaan työkirjan selaimessa.

On suositeltavaa ottaa koko organisaatiossa tavaksi tallentaa tai julkaista työkirjat yhteiselle SharePoint-sivustolle; näin työkirjaa ei tarvitse levittää ja muokata sähköpostitse eikä siitä näin ollen pääse syntymään lukuisia hiukan erilaisia versioita.

Julkaisuasetuksia määrittämällä voit tuoda esiin työkirjan tiettyjä osia, kuten kaavioita, tai estää joidenkin osien näkymisen selaimessa. Voit esimerkiksi näyttää kaavion mutta piilottaa sen pohjana olevat tiedot. Voit myös näyttää vain tiettyjä laskentataulukoita käyttäjille, joiden tarvitsee nähdä ne, ja piilottaa heiltä muut laskentataulukot.

Tässä artikkelissa kerrotaan, miten voit julkaista Excel for Windows -sivustosta työkirjan tai työkirjan tietojen yhdistämisen Excel Web Access -verkko-osaan SharePoint sivulla.

Kun julkaiset työkirjan SharePoint-sivustossa, koko työkirja tallentuu SharePointiin. Käyttäjä, jolla on tarvittavat SharePoint-käyttöoikeudet, voi tarkastella ja käsitellä koko työkirjaa joko selaimessa tai Excelin työpöytäsovelluksessa.

Jos SharePointissa käytetään Officen verkkoversio -sovelluksia, tietojen tarkastelu ja käsittely selaimessa voi tapahtua paljolti samoin kuin Excelin työpöytäsovelluksessa. Toisin kuin Excelin työpöytäsovelluksessa, selainruudukossa useat käyttäjät voivat muokata työkirjaa samanaikaisesti. Jos selaimessa näkyy Muokkaa Excel Online ‑sovelluksessa -painike, kun tarkastelet työkirjaa selaimessa, tiedät Officen verkkoversio ‑sovellusten olevan käytettävissä.

Muokkaa työkirjaa -valikon Muokkaa Excel Onlinessa -komento

Työkirjan valmisteleminen

Ennen työkirjan julkaisemista voit halutessasi määrittää, että vain osa sen laskentataulukoista ja kohteista näkyy selaimessa. Muista vain, että vaikka voit rajoittaa, mitä tässä tilassa näkyy, työkirjan sisältö tallentuu kokonaisuudessaan SharePoint-palvelimeen.

Jos haluat sisällyttää kohteeksi kokonaisia laskentataulukoita muiden kohteiden, kuten kaavioiden tai Pivot-taulukoiden, lisäksi, määritä koko laskentataulukko nimetyksi alueeksi. Valitse koko laskentataulukko ja määritä sitten nimetty alue. Tämä nimetty alue näkyy sitten käytettävissä olevana kohteena Julkaisuasetukset -valintaikkunassa, kun olet valmis julkaisemaan työkirjan.

Jotta käyttäjät voivat lisätä soluun arvon käyttääkseen toisessa solussa olevaa kaavaa, aseta tämä solu määritetyksi nimeksi Excelissä ennen työkirjan julkaisemista. Tämän jälkeen voit lisätä tämän määritetyn nimen parametriksi Selainnäkymän asetukset ‑valintaikkunan Parametrit-välilehdessä.

Seuraavassa esimerkissä näkyy solu D2, jonka nimeksi on määritetty "Korko". Selaimessa käyttäjä kirjoittaa arvon 5,625 Parametrit-ruudun Arvo-ruutuun ja valitsee Käytä. Tämä arvo ilmestyy soluun D2, ja solussa A2 oleva kaava käyttää solussa D2 olevaa arvoa. Kaavan tulos lasketaan uudelleen ja se näkyy solussa A2: $1 151,31.

Parametrin kirjoittaminen ruutuun tuo sen käyttöön solussa D2

Huomautus: Jos luot Excel-taulukkoon osittajia ja annat nimen taulukon ja osittajat sisältävälle solujoukolle, et voi käyttää osittajia taulukon suodattamiseen selaimessa julkaistessasi määritetyn alueen. Jos julkaiset taulukon tai koko laskentataulukon tai sen työkirjan, osittajat toimivat selaimessa odotettuun tapaan.

Työkirjan julkaiseminen

  1. Valitse Tiedosto-välilehdessä Tallenna nimellä ja valitse sitten SharePoint.

  2. Jos näet oman SharePoint Nykyinen -,Viimeisimmät-tai Vanhempi-kohdassa, valitse haluamasi kansio.

    Näkyviin tulee Tallenna nimellä -valintaikkuna.


    Valitse muussa tapauksessa Selaa, kirjoita SharePoint-sivuston verkko-osoite ja siirry kansioon, johon haluat julkaista työkirjan.

    Valitse SharePoint-kansio tai valitse Selaa
  3. Jos haluat poimia työkirjasta julkaistavaksi vain joitain laskentataulukoita tai kohteita, valitse Selainnäkymän asetukset.

    Valitse Tallenna nimellä -valintaikkunassa Selainnäkymän asetukset

    Näytössä näkyvät Näytä-välilehti ja Parametrit-välilehti.

  4. Jos haluat julkaista koko työkirjan, valitse Tallenna. Muussa tapauksessa tee sitten jompikumpi seuraavista:

    • Jos haluat näyttää koko työkirjan selaimessa, valitse Näytä-välilehdessä luetteloruudusta Koko työkirja.

    • Jos haluat näyttää selaimessa vain joitain laskentataulukoita, valitse Näytä-välilehden luetteloruudussa Taulukot ja poista valintaruutujen valinnat taulukoista, joita et halua piilottaa selaimessa.

      Kaikki taulukot on valittu oletuksena. Kun olet poistanut joidenkin kohtien valinnan ja haluat tehdä kaikista taulukoista jälleen näkyviä, se onnistuu helposti, kun valitset Kaikki taulukot -valintaruudun.

    • Jos haluat näyttää selaimessa vain joitain kohteita (kuten nimetyt alueet, kaaviot, taulukot tai Pivot-taulukot), valitse Näytä-välilehden luetteloruudussa Työkirjan kohteet ja valitse sitten näytettävien kohteiden valintaruudut.

    • Lisää Parametrit-välilehteen määritetyt nimet, joita haluat käyttää määrittämään soluja, joita käyttäjät voivat muokata tarkastellessaan työkirjaa selaimessa, ja valitse sitten OK.

  5. Tallenna työkirja.

Huomautukset: 

  • Jos valitset kohteita, joilla on sama nimi (kuten kaavio ja sen pohjana oleva taulukko), vain yksi näistä kohteista näkyy selaimessa. Jos haluat näyttää kaikki kohteet, varmista, että kaikilla työkirjan kohteilla on yksilöllinen nimi.

  • Voit nimetä uudelleen taulukoita Rakenne-välilehden Ominaisuudet-ryhmässä, Pivot-taulukoita Asetukset-välilehden Pivot-taulukko-ryhmässä ja kaavioita tai Pivot-kaavioita Asettelu-välilehden Ominaisuudet-ryhmässä. Vaihda myös muut päällekkäiset nimet, kuten nimettyjen alueiden nimet, jotka voit muuttaa Kaavat-välilehden Määritetyt nimet -ryhmässä.

Jos SharePointissa käytetään Officen verkkoversio -sovelluksia, tietojen tarkastelu ja käsittely selaimessa voi tapahtua paljolti samoin kuin Excelin työpöytäsovelluksessa. Toisin kuin Excelin työpöytäsovelluksessa, selainruudukossa useat käyttäjät voivat muokata työkirjaa samanaikaisesti. Jos selaimessa näkyy Muokkaa Excel Online ‑sovelluksessa -painike, kun tarkastelet työkirjaa selaimessa, tiedät Officen verkkoversio ‑sovellusten olevan käytettävissä.

Muokkaa työkirjaa -valikon Muokkaa Excel Onlinessa -komento

Lisätietoja on artikkelissa Työkirjan käytön erot Excel Excel Services.

Työkirjan valmisteleminen

Ennen työkirjan julkaisemista voit halutessasi määrittää, että vain osa sen laskentataulukoista ja kohteista näkyy selaimessa. Muista vain, että vaikka voit rajoittaa, mitä tässä tilassa näkyy, työkirjan sisältö tallentuu kokonaisuudessaan SharePoint-palvelimeen.

Jos haluat sisällyttää kohteeksi kokonaisia laskentataulukoita muiden kohteiden, kuten kaavioiden tai Pivot-taulukoiden, lisäksi, määritä koko laskentataulukko nimetyksi alueeksi. Valitse koko laskentataulukko ja määritä sitten nimetty alue. Tämä nimetty alue näkyy sitten käytettävissä olevana kohteena Julkaisuasetukset -valintaikkunassa, kun olet valmis julkaisemaan työkirjan.

Jotta käyttäjät voivat lisätä soluun arvon käyttääkseen toisessa solussa olevaa kaavaa, aseta tämä solu määritetyksi nimeksi Excelissä ennen työkirjan julkaisemista. Tämän jälkeen voit lisätä tämän määritetyn nimen parametriksi Selainnäkymän asetukset ‑valintaikkunan Parametrit-välilehdessä.

Seuraavassa esimerkissä näkyy solu D2, jonka nimeksi on määritetty "Korko". Selaimessa käyttäjä kirjoittaa arvon 5,625 Parametrit-ruudun ruutuun ja napsauttaa Käytä. Tämä arvo ilmestyy soluun D2, ja solussa A2 oleva kaava käyttää solussa D2 olevaa arvoa. Kaavan tulos lasketaan uudelleen ja se näkyy solussa A2: $1 151,31.

Katso Excel ohjeista lisätietoja alueiden määrittämisestä.

Parametrin kirjoittaminen ruutuun tuo sen käyttöön solussa D2

Huomautus: Jos luot Excel-taulukkoon osittajia ja annat nimen taulukon ja osittajat sisältävälle solujoukolle, et voi käyttää osittajia taulukon suodattamiseen selaimessa julkaistessasi määritetyn alueen. Jos julkaiset taulukon tai koko laskentataulukon tai sen työkirjan, osittajat toimivat selaimessa odotettuun tapaan.

Työkirjan julkaiseminen

  1. Valitse Tiedosto > Tallenna nimellä >SharePoint.

  2. Jos näet oman SharePoint kansion Nykyinen kansio- tai Viimeksi käytetyt kansiot -kohdassa, valitse haluamasi kansio. Valitse muussa tapauksessa Selaa ja kirjoita SharePoint verkko-osoite. Siirry sitten kansioon, johon haluat julkaista työkirjan. Näkyviin tulee Tallenna nimellä -valintaikkuna.

  3. Jos haluat poimia työkirjasta julkaistavaksi vain joitain laskentataulukoita tai kohteita, valitse Selainnäkymän asetukset. Näet Näytä-välilehden jaParametrit-välilehden. Jos haluat julkaista koko työkirjan, valitse Tallenna. Muussa tapauksessa tee sitten jompikumpi seuraavista:

    • Jos haluat näyttää koko työkirjan selaimessa, valitse Näytä-välilehdessä luetteloruudusta Koko työkirja.

    • Jos haluat näyttää selaimessa vain tietyt laskentataulukot, valitse Näytä-välilehden luetteloruudussa Taulukot ja poista sitten niiden laskentataulukoiden valintaruudut, jotka et halua piilottaa selaimessa.

      Kaikki taulukot on valittu oletuksena. Jos haluat, että kaikki taulukot ovat jälleen luettavissa, kun olet poistanut joidenkin ruutujen valinnan, valitse Kaikki taulukot -valintaruutu.

    • Jos haluat näyttää selaimessa vain tietyt kohteet (kuten nimetyt alueet, kaaviot, taulukot tai Pivot-taulukot), valitse Näytä-välilehden luetteloruudussa Työkirjan kohteet ja valitse sitten niiden kohteiden valintaruudut, jotka haluat näyttää.

    • Lisää Parametrit-välilehdessä määritetyt nimet, joiden avulla voit määrittää solut, joita voi muokata, kun käyttäjät tarkastelevat työkirjaa selaimessa. Sulje sitten valintaikkuna valitsemalla OK.

  4. Tallenna työkirja.

Huomautukset: 

  • Jos valitset kohteita, joilla on sama nimi (kuten kaavio ja sen pohjana oleva taulukko), vain yksi näistä kohteista näkyy selaimessa. Jos haluat näyttää kaikki kohteet, varmista, että kaikilla työkirjan kohteilla on yksilöllinen nimi.

  • Jos valitset kohteita, joilla on sama nimi (kuten kaavio ja sen pohjana oleva taulukko), vain yksi näistä kohteista näkyy selaimessa. Jos haluat näyttää kaikki kohteet, varmista, että kaikilla työkirjan kohteilla on yksilöllinen nimi.

  • Voit nimetä uudelleen taulukoita Rakenne-välilehden Ominaisuudet-ryhmässä, Pivot-taulukoita Asetukset-välilehden Pivot-taulukko-ryhmässä ja kaavioita tai Pivot-kaavioita Asettelu-välilehden Ominaisuudet-ryhmässä. Vaihda myös muut päällekkäiset nimet, kuten nimettyjen alueiden nimet, jotka voit muuttaa Kaavat-välilehden Määritetyt nimet -ryhmässä.

  • Voit nimetä uudelleen taulukoita Rakenne-välilehden Ominaisuudet-ryhmässä, Pivot-taulukoita Asetukset-välilehden Pivot-taulukko-ryhmässä ja kaavioita tai Pivot-kaavioita Asettelu-välilehden Ominaisuudet-ryhmässä. Vaihda myös muut päällekkäiset nimet, kuten nimettyjen alueiden nimet, jotka voit muuttaa Kaavat-välilehden Määritetyt nimet -ryhmässä.

Lisätietoja Web Access Excel osista on artikkelissa Työkirjan näyttäminen Excel-verkko-osassa.

Kun julkaiset työkirjan SharePoint-palvelimeen, työkirjan koko sisältö tallennetaan palvelimeen, ja sitä voi tarkastella ja käyttää, jos avaat työkirjan Excel työpöytäohjelmassa. Jos Office Web Apps otetaan käyttöön SharePoint-palvelimessa, tietojen tarkasteleminen ja käyttäminen verkkoselaimessa voi olla hyvinkin kuin Excel työpöytäohjelmassa. Työkirjan samanaikainen muokkaaminen on itse asiassa mahdollista selainruudukossa, kun Office web apps otetaan käyttöön. Kun tarkastelet työkirjaa selaimessa ja Muokkaa selaimessa -painike on näkyvissä, tämä tarkoittaa, että Office verkkosovellukset ovat käytettävissä.

Muokkaa selaimessa ‑painike

Lisätietoja on artikkelissa Työkirjan käytön erot Excel Excel Services.

Työkirjan valmisteleminen

Ennen kuin julkaiset työkirjan, voit (Julkaisuasetukset-valintaikkunassa) valita laskentataulukot tai kohteet, jotka haluat näkyvän selaimessa, kun muokkaaminen ei ole käytössä, napsauttamalla Muokkaa selaimessa -painiketta. Muista kuitenkin, että vaikka voit valita, mitä tässä tilassa voi tarkastella, työkirjan koko sisältö tallennetaan edelleen SharePoint palvelimeen.

Jos haluat sisällyttää kohteeksi kokonaisia laskentataulukoita muiden kohteiden, kuten kaavioiden tai Pivot-taulukoiden, lisäksi, määritä koko laskentataulukko nimetyksi alueeksi. Valitse koko laskentataulukko ja määritä sitten nimetty alue. Tämä nimetty alue näkyy sitten käytettävissä olevana kohteena Julkaisuasetukset -valintaikkunassa, kun olet valmis julkaisemaan työkirjan.

Jos haluat antaa käyttäjille parametrin kaavaan, kun tarkastelet laskentataulukkoa selaimessa, määritä solu määritetyksi nimeksi. Sen jälkeen voit lisätä määritetyn nimen parametriksi Julkaisuasetukset-valintaikkunanParametrit-välilehdessä.

Esimerkiksi seuraavassa kuvassa, jossa näkyy laskentataulukko selaimessa, solulla D2 on määritetty nimi Rate. Selaimessa käyttäjä on syöttänyt arvon 5,625 Parametrit-ruudun ruutuun ja napsauttanut Käytä. Tämä arvo ilmestyy soluun D2, ja solussa A2 oleva kaava käyttää solussa D2 olevaa arvoa. Kaavan tulos lasketaan uudelleen ja se näkyy solussa A2: $1 151,31.

Parametrin käyttäminen selaimessa

Katso Excel ohjeista lisätietoja alueiden määrittämisestä.

Työkirjan julkaiseminen

  1. Valitse Tiedosto-välilehdessä Tallenna ja lähetä.

  2. Valitse Tallenna SharePoint.
    Huomautus    Jos Tallenna SharePoint -komento ei ole käytettävissä, voit silti tallentaa työkirjan SharePoint-sivustoon Tallenna nimellä -komennolla.Julkaisuasetukset-valintaikkuna ei ole käytettävissä. Voit myös ladata työkirjan suoraan SharePoint kirjastosta. Käyttäjät voivat tarkastella ja muokata työkirjan sisältöä selaimessa menemällä suoraan sivustoon, johon työkirja on tallennettu.

    Tallenna nimellä ‑komento

  3. Jos haluat valita työkirjassa julkaistavat yksittäiset laskentataulukot tai kohteet, napsauta Julkaisuasetukset-painiketta. Muussa tapauksessa jos haluat julkaista koko työkirjan, siirry suoraan vaiheeseen 4.
    Tee Näytä-välilehdessä seuraavat toimet:

    • Jos haluat näyttää koko työkirjan selaimessa, valitse luetteloruudussa Koko työkirja.

    • Jos haluat näyttää vain tietyt laskentataulukot selaimessa, valitse Taulukot luetteloruudusta ja poista niiden laskentataulukoiden valintaruutujen valinnat, joita et halua näyttää.
      Huomautus    Kaikki taulukot on valittuna oletusarvoisesti. Jos haluat, että kaikki taulukot ovat jälleen luettavissa, kun olet poistanut joidenkin valintaruutujen valinnan, valitse Kaikki taulukot -valintaruutu.

    • Jos haluat näyttää selaimessa vain tietyt kohteet (kuten nimetyt alueet, kaaviot, taulukot tai Pivot-taulukot), valitse Kohteet työkirjan luetteloruudussa ja valitse sitten niiden kohteiden valintaruudut, jotka haluat näyttää.
      Huomautus Jos valitset kohteita, joissa on sama nimi (kuten kaavio ja sen pohjana oleva taulukko), vain yksi näistä kohteista on käytettävissä selaimessa. Jos haluat näyttää kaikki kohteet, varmista, että jokaisella työkirjan osalla on yksilöllinen nimi. Voit nimetä uudelleen taulukoita Rakenne-välilehden Ominaisuudet-ryhmässä, Pivot-taulukoita Asetukset-välilehden Pivot-taulukko-ryhmässä ja kaavioita tai Pivot-kaavioita Asettelu-välilehden Ominaisuudet-ryhmässä. Päällekkäiset kohteet, kuten nimetyt alueet, voidaan nimetä uudelleen Määritetyt nimet -ryhmän Kaavat-välilehdessä.
      Laskentataulukoiden tai kohteiden valitseminen

    • Lisää Parametrit-välilehdessä määritetyt nimet, joita haluat käyttää määrittämään solut, joita voi muokata, kun käyttäjät tarkastelevat työkirjaa selaimessa. Sulje sitten valintaikkuna valitsemalla OK.
      Parametrien määrittäminen

  4. Valitse sijainti, jossa haluat julkaista työkirjan.
    Nykyinen sijainti -, Viimeisimmät sijainnit- tai Sijainnit-kohdassa voi jo olla tallennettuja palvelinsijainteja. Jos tällaisia sijainteja ei ole tai haluat tallentaa uuteen sijaintiin, kaksoisnapsauta Sijainnit-kohdassa Selaa sijaintia.

  5. Kirjoita Tallenna nimellä -valintaikkunaan sivuston verkko-SharePoint ja siirry sitten sivustoon tai kirjastoon, johon haluat tallentaa työkirjan.

  6. Jos et ole vielä valinnut yksittäisiä laskentataulukoita tai kohteita tai määrittänyt parametreja, napsauta Julkaisuasetukset-painiketta.

  7. Hyväksy Tiedostonimi-ruudussa työkirjalle ehdotettu nimi tai kirjoita uusi nimi.

  8. Jos haluat näyttää työkirjan sisällön selainikkunassa heti julkaisutoiminnon päätyttyä, varmista, että Avaa Excel selaimessa -valintaruutu on valittuna.

  9. Valitse Tallenna.

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×