Vioittuneen työkirjan korjaaminen

Kun Microsoft Excel havaitsee vioittuneen työkirjan avattaessa, se käynnistää tiedostonpalautustilan automaattisesti ja yrittää korjata työkirjan. Jos tiedostojen palautustila ei käynnisty, yritä palauttaa työkirja tämän manuaalisen prosessin avulla:

  1. Valitse Tiedosto > Avaa.

  2. Napsauta sijaintia ja kansiota, joka sisältää vioittuneen työkirjan.

  3. Valitse Avaa-valintaikkunassa vioittunut työkirja.

  4. Napsauta Avaa-painikkeen vieressä olevaa nuolta ja valitse Avaa ja korjaa.

    Avaa ja korjaa -komento

  5. Jos haluat palauttaa mahdollisimman paljon työkirjan tietoja, valitse Korjaa.

    Jos korjaaminen ei pysty palauttamaan tietoja, poimi arvot ja kaavat työkirjasta valitsemalla Poimi tiedot.

Jos automaattinen tai manuaalinen korjaus ei toimi, jotkin palautusmenetelmät voivat auttaa tietojen palauttamisessa. Voit myös välttää työsi menettämisen käyttämällä työkirjan varmuuskopiota tai luomalla palautustiedoston aika ajoin.

Vioittuneen työkirjan tietojen palauttaminen

Voit palauttaa tiedot valitsemalla yhden seuraavista tavoista. Jos tämä ei onnistu, kokeile toista menetelmää. Voit myös kokeilla kolmannen osapuolen ohjelmistoratkaisuja ja yrittää palauttaa työkirjan.

Tärkeää: Jos levyvirhe tai verkkovirhe estää työkirjan avaamisen, siirrä työkirja toiseen kiintolevyasemaan tai paikalliseen levylle, ennen kuin yrität kokeilla jotain seuraavista palautusvaihtoehdoista.

Tietojen palauttaminen, kun työkirja on avoinna Excelissä

  • Työkirjan palaaminen viimein tallennetuksi versioksi    Jos työkirja vioittuu työskentelyn aikana, mutta voit palauttaa työkirjan viimeisimpaan tallennettuun versioon ennen muutosten tallentamista:

    1. Valitse Tiedosto > Avaa.

    2. Kaksoisnapsauta Excelissä avoinna olevan työkirjan nimeä.

    3. Avaa työkirja uudelleen valitsemalla Kyllä.

      Työkirja avautuu ilman muutoksia, jotka ovat saattaneet aiheuttaa työkirjan vioittumisen.

Tietojen palauttaminen, kun työkirjaa ei voi avata Excelissä

  • Laskenta-asetuksen valitseminen Excelissä manuaaliseen muotoon    Kokeile vaihtaa laskenta-asetus automaattisesta manuaaliseen. Koska työkirjaa ei lasketa uudelleen, se voi aukeaa.

    1. Valitse Tiedosto > Uusi.

    2. Valitse Uusi-kohdassa Tyhjä työkirja.

    3. Valitse Tiedosto > Asetukset.

    4. Valitse Kaavat-luokanLaskenta-asetukset-kohdassaManuaalinenja valitse sitten OK.

    5. Valitse Tiedosto > Avaa.

    6. Etsi vioittunut työkirja ja avaa se kaksoisnapsauttamalla sitä.

  • Linkitä vioittuneeen työkirjaan ulkoisia viittauksia käyttämällä    Jos haluat hakea työkirjasta vain tietoja, ei kaavoja tai laskettuja arvoja, yritä linkittää vioittuneeen työkirjaan ulkoisia viittauksia käyttämällä.

    1. Valitse Tiedosto > Avaa.

    2. Siirry kansioon, joka sisältää vioittuneen työkirjan.

    3. Napsauta vioittuneen työkirjan tiedostonimeä hiiren kakkospainikkeella, valitse Kopioija valitse sitten Peruuta.

    4. Valitse Tiedosto > Uusi.

    5. Valitse Uusi-kohdassa Tyhjä työkirja.

    6. Kirjoita uuden työkirjan soluun A1 =Tiedostonimi! A1, jossa Tiedostonimi on vaiheessa 3 kopioidun vioittuneen työkirjan nimi, ja paina sitten Enter-näppäintä.

      Huomautus:  Sinun on annettava vain työkirjan nimi, jotta sinun ei tarvitse kirjoittaa tiedostotunnisteena.

    7. Jos Päivitä arvot -valintaikkuna tulee näkyviin, valitse vioittunut työkirja ja valitse sitten OK.

    8. Jos näkyviin tulee Valitse taulukko -valintaikkuna, valitse haluamasi taulukko ja valitse OK.

    9. Valitse solu A1.

    10. Valitse Aloitus>kopioi taipaina näppäinyhdistelmää Ctrl+C.

    11. Valitse alue solusta A1 alkaen, joka on suunnilleen samankokoinen kuin solualue, joka sisältää vioittuneen työkirjan tietoja.

    12. Valitse Aloitus>Liitätai paina näppäinyhdistelmää Ctrl+V.

    13. Kun solualue on edelleen valittuna, valitse Aloitus->kopioi uudelleen tai paina näppäinyhdistelmää Ctrl+C.

    14. Valitse > -kohdan alapuolella olevanuoli ja valitse sitten Liitä arvot-kohdassa Arvot.

      Arvojen liittäminen poistaa vioittuneen työkirjan linkit ja jättää vain tiedot.

  • Hae tiedot vioittuneesta työkirjasta makron avulla:    Jos kaavio on linkitetty vioittuneeen työkirjaan, yritä poimia kaavion lähdetiedot makron avulla.

    1. Kopioi seuraava makrokoodi ja liitä se moduulitaulukkoon:

      Sub GetChartValues()

      Dim NumberOfRows As Integer

      Dim X As Object

      Laskuri = 2

      ' Laske tietorivien määrä.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Arvot)

      Laskentataulukot("Kaaviotiedot"). Cells(1, 1) = "X Values"

      ' Kirjoita x-akselin arvot laskentataulukkoon.

      Laskentataulukoiden kanssa ("Kaaviotiedot")

      . Alue(. Solut(2; 1), _

      . Cells(NumberOfRows + 1, 1)) = _

      Application.Transponoi(ActiveChart.SeriesCollection(1). XValues)

      End With

      ' Käy läpi kaikki kaavion sarjat ja kirjoita niiden arvot

      ' -laskentataulukkoon.

      Jokaista ActiveChart.SeriesCollection-kaavion X-kirjainta varten

      Laskentataulukot("Kaaviotiedot"). Cells(1, Counter) = X.Name

      Laskentataulukoiden kanssa ("Kaaviotiedot")

      . Alue(. Solut(2; laskuri), _

      . Cells(NumberOfRows + 1, Counter)) = _

      Application.Transpose(X.Values)

      End With

      Laskuri = Laskuri + 1

      Seuraava

      End Sub

    2. Lisää tai poista laskentataulukko työkirjaan napsauttamalla sen taulukon välilehteä hiiren kakkospainikkeella ja nimeä se uudelleen ChartData-ruudussa.

    3. Valitse kaavio, josta haluat poimia pohjana olevat tietoarvot.

      Huomautus: Kaavio voi olla upotettu työkirjaan tai erillisessä kaaviotaulukossa.

    4. Suorita makro.

    5. Kaavion tiedot laitetaan ChartData-laskentataulukkoon.

Sivun alkuun

Työkirjan varmuuskopion automaattinen tallentaminen

Kun työkirjasta on varmuuskopio, voit aina käyttää tietojasi, jos työkirja on poistettu vahingossa tai se vioittuu.

  1. Napsauta Tiedosto > Tallenna nimellä.

  2. Valitse Tietokoneja napsauta sitten Selaa-painiketta.

    Selaa-painike

  3. Napsauta Tallenna nimellä -valintaikkunassa Työkalut-kohdan vieressä olevaa nuoltaja valitse Yleiset asetukset.

    Työkalut-valikon Yleiset asetukset

  4. Valitse Yleiset asetukset -valintaikkunassa Luo aina varmuuskopio -valintaruutu.

    Yleiset asetukset -valintaikkunan Luo aina varmuuskopio -asetus

Sivun alkuun

Luo palautustiedosto automaattisesti määritettyjen välein

Työkirjan palautustiedosto auttaa myös varmistamaan, että voit käyttää tietojasi, jos työkirja poistetaan vahingossa tai jos se vioittuu.

  1. Valitse Tiedosto > Asetukset.

  2. Valitse Tallenna-luokan Tallenna työkirjat-kohdassa Tallenna automaattisen korjauksen tiedot joka -ruutu ja kirjoita sitten minuuttimäärä. (Oletusarvo on 10.)

    Excelin asetukset -valintaikkunan Tallenna-välilehden Automaattinen tallennus -asetus

  3. Kirjoita Automaattisen palautuksen tiedoston sijainti -ruutuun sijainti, johon haluat tallentaa palautustiedoston.

  4. Varmista, että Poista automaattinen palautus käytöstä vain tässä työkirjassa -valintaruutua ei ole valittu.

Sivun alkuun

Tarvitsetko lisäohjeita?

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×