Erreur « Le nom du certificat de sécurité n’est pas valide ou ne correspond pas au nom du site » dans Outlook dans un environnement de Office 365 dédié ou ITAR

S’applique à
Microsoft Business Productivity Online Dedicated Microsoft Business Productivity Online Suite Federal

Symptômes

Dans un environnement de Microsoft Office 365 itar (International Traffic in Arms Regulations) dédié ou international, un utilisateur est invité par une boîte de dialogue Alerte de sécurité qui inclut le message d’erreur suivant :

Remarque

Le nom du certificat de sécurité n’est pas valide ou ne correspond pas au nom du site.

Par exemple, la boîte de dialogue Alerte de sécurité ressemble à ce qui suit :

Alerte de sécurité

Ce problème peut se produire dans les circonstances suivantes :

  • L’utilisateur tente de créer un profil dans Microsoft Office Outlook.
  • L’utilisateur tente de démarrer un client Outlook.
  • Le problème se produit par intermittence lorsque le client Outlook est en cours d’exécution.

Si l’utilisateur clique sur Oui, l’utilisateur peut continuer l’opération. Toutefois, si l’utilisateur clique sur Non, la recherche de découverte automatique échoue. L’échec de la recherche de découverte automatique empêche les fonctionnalités suivantes de fonctionner comme prévu :

  • Création automatique d’un profil Outlook à l’aide de la découverte automatique
  • Assistant Absence du bureau (OOF)
  • Informations de disponibilité

Cause

En règle générale, ce problème se produit lorsque l’URL à laquelle vous essayez d’accéder n’est pas répertoriée dans l’objet ou l’autre nom de l’objet (SAN) du certificat SSL (Secure Sockets Layer) du site web. Bien que les configurations des différentes organisations puissent différer légèrement, ce problème se produit généralement parce que les enregistrements DNS (Autodiscover Domain Name System) de l’organization sont configurés de manière incorrecte.

Résolution

Pour résoudre ce problème, vous devrez peut-être modifier vos enregistrements DNS de découverte automatique (internes, externes ou les deux). Toutefois, ces modifications ne doivent pas être prises à la légère, car la fonctionnalité de découverte automatique peut ne pas fonctionner si les enregistrements DNS sont configurés de manière incorrecte.

Avant de modifier les enregistrements DNS de découverte automatique, vous devez comprendre comment le client Outlook tente de localiser le service de découverte automatique. Le client Outlook tente de localiser le service de découverte automatique en utilisant l’ordre fondamental des opérations suivant. Toutefois, l’étape dans laquelle se trouve le service de découverte automatique varie d’un déploiement à l’autre. Cet emplacement dépend de l’existence d’une solution locale dans la coexistence et de l’environnement de messagerie local spécifique (par exemple, un Microsoft Exchange Server local, un Lotus Notes local ou un autre environnement).

Le tableau suivant présente l’ordre fondamental des opérations pour la façon dont le client Outlook localise le service de découverte automatique :

1
  1. Objet Point de connexion de service (SCP) - Connexions internes uniquement.
  2. Le client Outlook tente de localiser un enregistrement A pour l’URL retournée par l’objet SCP.
2
  1. Domaine SMTP de l’utilisateur. (Par exemple, https://proseware.com)
  2. Le client Outlook tente de localiser un enregistrement A pour le domaine SMTP de l’utilisateur.
3
  1. Le domaine SMTP de l’utilisateur est ajouté à la découverte automatique. (Par exemple, https://autodiscover.proseware.com)
  2. Le client Outlook tente de localiser un enregistrement A pour l’URL qui est ajoutée avec la découverte automatique.
4
  1. Le client Outlook tente de localiser un enregistrement de service DNS (SRV) pour le service de découverte automatique dans la zone DNS qui correspond au domaine SMTP de l’utilisateur. (Par exemple, _autodiscover._tcp.proseware.com)
  2. L’enregistrement SRV retourne ensuite une autre URL, pour laquelle un type d’enregistrement pouvant être résolu doit exister, tel qu’un enregistrement A ou un enregistrement CNAME.
5 Résultat Si le service de découverte automatique est introuvable par l’une de ces méthodes, la découverte automatique échoue.

En résumé, le service de découverte automatique peut être résolu à l’aide d’un enregistrement A, D’un enregistrement CNAME ou d’un enregistrement SRV. Pour déterminer les enregistrements actuellement utilisés, exécutez les commandes suivantes à l’invite de commandes ou dans Windows PowerShell :

  1. Pour localiser un enregistrement A, exécutez les commandes suivantes. Veillez à remplacer SMTPDomain.com ci-dessous par le domaine par la valeur en haut de votre erreur de certificat.

nslookup 

set type=A 

Autodiscover.SMTPDomain.com 
  1. Pour localiser un enregistrement SRV, exécutez les commandes suivantes :

nslookup 

set type=SRV 

_autodiscover._tcp.SMTPDomain.com 

Dans l’exemple suivant, le client Outlook peut localiser le service de découverte automatique à l’aide de l’enregistrement A pour l’URL de découverte automatique, comme décrit à l’étape 3 du tableau précédent :

autodiscover.proseware.com Toutefois, comme nous l’avons mentionné dans la section « Cause », cette URL n’est pas répertoriée dans le san du certificat SSL utilisé par le service de découverte automatique. Par exemple, consultez la capture d’écran suivante :

le service de découverte automatique

Pour résoudre ce problème, utilisez la méthode suivante.

Remplacez l’enregistrement A existant à l’aide d’un enregistrement SRV qui pointe vers un espace de noms qui se trouve déjà dans le san du certificat SSL

Il s’agit de la méthode de résolution préférée dans la conception de service actuelle, car le certificat SSL existant n’a pas besoin d’être mis à jour et déployé. Selon l’ordre fondamental des opérations répertoriées plus haut dans cette section, le organization peut implémenter le nouvel enregistrement en utilisant une méthode contrôlée et testée pour empêcher les pannes du service de découverte automatique.

Pour résoudre ce problème, procédez comme suit :

  1. Créez un enregistrement SRV.

    L’enregistrement SRV doit être créé dans la zone DNS qui correspond au domaine SMTP de l’utilisateur. L’enregistrement SRV doit avoir les propriétés suivantes :

    • Service : _autodiscover
    • Protocole : _tcp
    • Port : 443
    • Hôte : URL pour la redirection. Cette URL peut être l’URL Outlook Web Access (OWA), car l’adresse IP résolue doit être identique au service de découverte automatique. En outre, cela peut varier d’un déploiement à l’autre.
  2. Avant de supprimer l’enregistrement A existant, le nouvel enregistrement SRV doit être testé en modifiant le fichier hôte d’un utilisateur pour rediriger l’enregistrement A actuel vers une adresse IP non valide. Ce test peut vérifier que le nouvel enregistrement SRV fonctionne comme prévu avant de déployer les nouveaux enregistrements DNS sur l’ensemble du organization.

    Remarque Lorsque l’enregistrement SRV est utilisé par un client Outlook, l’utilisateur peut recevoir le message suivant qui l’informe de la redirection qui est sur le point de se produire. Nous recommandons à l’utilisateur de sélectionner la zone Ne plus me demander sur ce site web case activée pour que le message ne s’affiche plus.
    Ne me demander à nouveau sur ce site web

  3. Lorsque l’enregistrement SRV fonctionne comme prévu, vous pouvez supprimer l’enregistrement A existant de DNS.

Informations supplémentaires

Pour plus d’informations sur le service de découverte automatique, accédez au site web Microsoft TechNet suivant :

Présentation du service de découverte automatique