Test-OAuthConnectivity échoue toujours quand Exchange Server utilise un proxy pour se connecter à Internet dans les Exchange Server 2019 et 2016

S’applique à
Exchange Server 2019 Exchange Server 2016

Symptômes

Dans Microsoft Exchange Server 2019 ou Exchange Server 2016, supposons que vous avez défini un serveur proxy web que le Exchange Server utilise pour accéder à Internet à l’aide du paramètre InternetWebProxy et qu’il n’y a pas d’accès direct à Internet. Vous pouvez constater que la connectivité OAuth échoue toujours si vous la testez à l’aide de l’applet de commande Test-OAuthConnectivity , même si la connectivité fonctionne correctement.

Cause

Ce problème se produit car l’applet de commande Test-OAuthConnectivity ne respecte pas les paramètres InternetWebProxy définis sur le Exchange Server. Par conséquent, si le Exchange Server est bloqué pour se connecter directement à Internet, vous ne testerez pas correctement la connectivité OAuth.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Pour résoudre ce problème, installez l’une des mises à jour suivantes : Pour Exchange Server 2019, installez la mise à jour cumulative 1 pour Exchange Server 2019 ou une mise à jour cumulative ultérieure pour Exchange Server 2019.

Pour Exchange Server 2016, installez la mise à jour cumulative 12 pour Exchange Server 2016 ou une mise à jour cumulative ultérieure pour Exchange Server 2016.

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.