Résolution des erreurs SOAP dans les pages du projet de Business Portal dans Microsoft Dynamics SL


Symptômes


Lorsque vous visitez de projet associé pages telles que l’heure entrée, entrée de dépenses, Communicator Webpart, analyste projet et Executive analyste de projet dans portail d’entreprise, vous recevez un message d’erreur rouge de temps semblable à l’un des éléments suivants :

Message d’erreur 1 :

Erreur : Pièce jointe : Maximum nouvelle tentative de connexion dépassé. HRESULT = 0 x 80004005 : erreur - Client non spécifiée : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0 x 80004005 : erreur - Client non spécifiée : envoyer le message Soap a échoué ou aucune réponse reconnue a été reçue HRESULT = 0 x 80004005 : erreur - Client non spécifiée : erreur de client non spécifiée. HRESULT = 0 x 80004005 : erreur non spécifiée faultcode = Client faultstring = pièce jointe : nombre maximal de tentatives de connexion dépassée.

Consultez la rubrique solutions 6, 7, 8 et 9

Message d’erreur 2 :

Expiration du délai de connexion : Connector. HRESULT = 0x800A1527 - Client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1527 - Client : envoyer le message Soap a échoué ou aucune réponse reconnue a été reçue HRESULT = 0x800A1527 - Client : erreur de client non spécifiée.

Consultez la rubrique solutions 6, 7, 8 et 9

Message d’erreur 3 :

Certificat de connecteur : incorrect. HRESULT = 0x800A1529 - Client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1529 - Client : envoyer le message Soap a échoué ou aucune réponse reconnue a été reçue HRESULT = 0x800A1529 - Client : erreur de client non spécifiée. HRESULT = 0X800A1529

Consultez Résolution 6 et 9

Message d’erreur 4 :

Connecteur : HTTP Erreur non spécifiée. HRESULT = 0x800A1518 - Client : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0x800A1518 - Client : envoyer le message Soap a échoué ou aucune réponse reconnue a été reçue HRESULT = 0x800A1518 - Client : erreur de client non spécifiée. HRESULT = 0X800A1518

Consultez la rubrique solutions 6, 7, 8 et 9

Message d’erreur 5 :

Connexion failure.:No schéma d’autorisation n’est autorisé sur le connecteur. HRESULT = 0 x 80004005 : erreur - Client non spécifiée : une erreur inattendue s’est produite lors du traitement de cette demande. HRESULT = 0 x 80004005 : erreur - Client non spécifiée : envoyer le message Soap a échoué ou aucune réponse reconnue a été reçue HRESULT = 0 x 80004005 : erreur - Client non spécifiée : erreur de client non spécifiée. HRESULT = 0 x 80004005 : erreur non spécifiée

Consultez la rubrique solutions 7 et 9

Message d’erreur 6 :

Client : chargement de la demande dans SoapReader a échoué. HRESULT = 0 x 80070057 : le paramètre est incorrect. -Client : erreur de client non spécifiée. HRESULT = 0 x 80070057 : le paramètre est incorrect. FaultCode = Client.

Consultez la rubrique solutions 6, 7, 8 et 9

Message d’erreur 7 :

L’application ne peut pas ouvrir la base de données système.
[DBNETLIB] [ConnectionOpen (Connect()).] SQL Server n’existe pas ou accès refusé.
Votre administrateur système doit exécuter pcConfiguration sur le serveur de portail d’entreprise pour résoudre ce problème.

Consultez la rubrique solutions 5 et 9

Message d’erreur 8 :

Une erreur a été rencontrée.
Erreur : Erreur lors de l’ouverture de la base de données système. (pcconnect)

Consultez la rubrique solutions 1, 2, 3, 4 et 9

Message d’erreur 9 :

L’application ne peut pas lire les informations de connexion de Solomon.
Votre administrateur système doit exécuter pcConfiguration sur le serveur de portail d’entreprise pour résoudre ce problème

Consultez la rubrique solutions 1, 2, 3, 4 et 9

Message d’erreur 10 :

Impossible de se connecter à la base de données système PCConfiguration de s’exécuter. Mot de passe et de nom d’utilisateur non valide.

Consultez la rubrique solutions 4 et 9

Message d’erreur 11 :

Erreur : Le Client SOAP : une erreur s’est produite lors du traitement de la demande SOAP.
Chemin d’accès non valide spécifié dans le ProjectService.wsdl de PCService.asmx
Votre administrateur système doit exécuter pcConfiguration - Service Web de mise à jour sur le serveur de portail d’entreprise pour résoudre ce problème.

Consultez la rubrique solutions 6 et 9

Cause


Pour les pages du projet à fonction, Internet Information Services (IIS) doit pour être en mesure de préparer et d’envoyer une demande SOAP Simple Object Access Protocol () dans le fichier PCService.asmx.  Plusieurs choses qui posent le configurer pour que cela fonctionne.  Si une ou plusieurs des actions suivantes ne sont pas le programme d’installation correctement, il peut provoquer les erreurs répertoriées dans la section « Symptômes » :

  1. Les informations de connexion de base de données Microsoft Dynamics SL sont manquant ou stockées de manière incorrecte dans le Registre.
  2. Le Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll est manquant, ne pas enregistré, ou les utilisateurs n’ont pas les autorisations pour le fichier.
  3. L’identité du pool d’applications n’a pas les autorisations pour la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Business Portal\PMA\Solomon
  4. Le capicom.dll est manquant, non enregistré, d’une version incorrecte, ou que les utilisateurs n’ont pas les autorisations pour le fichier
  5. Le serveur qui exécute IIS et le serveur SQL doit être en mesure de communiquer à l’aide du protocole TCP/IP
  6. Le chemin d’accès au fichier PCService.asx dans le ProjectService.wsdl est incorrect
    1. Le chemin d’accès doit pointer sur le nom du serveur IIS
    2. Le chemin d’accès doit inclure le numéro de port
    3. Le chemin d’accès doit être une URL non - SSL
    4. Si vous utilisez des en-têtes d’hôtes IIS, le chemin d’accès doit correspondre au site Web approprié
  7. Le site IIS n’utilise pas l’authentification Windows (NTLM)
  8. La variable de SessionState dans le fichier web.config est définie de manière incorrecte

Le message d’erreur ne fournit pas en général la quantité d’informations sur lequel des éléments précédents peut être incorrect.  Par conséquent, nous vous recommandons que vous essayez de toutes les résolutions possibles.

Résolution


Résolution 1 : Exécutez l’utilitaire PCConfiguration

  1. Accéder au fichier PCConfiguration.exe sur le serveur de portail d’entreprise et double-cliquez dessus pour l’exécuter.  Il se trouve généralement dans le dossier c:\Inetpub\wwwroot\bin ou dans le dossier C:\Inetpub\wwwroot\wss\VirtualDirectories\80\bin.
  2. Remplir les cases suivantes :
    1. Nom de SQL Server - Entrez le nom du serveur SQL qui héberge les bases de données Microsoft Dynamics SL
    2. Système de base de données - entrez le nom de la base de données système de Microsoft Dynamics SL
    3. L’utilisateur SQL - Entrez le nom de l’utilisateur qui a accès à la base de données système SQL.  « SA » ou « BusinessPortalUser » sont des options courantes.
    4. Mot de passe - Entrez le mot de passe pour l’utilisateur entré dans la zone utilisateur de SQL
  3. Cliquez sur tester la connexion.  Si vous recevez une erreur, vérifiez les valeurs à l’étape 2. Remarque : Ce bouton ne peut pas effectuer l’action en raison du bogue 55474.
  4. Cliquez sur mettre à jour le Registre.  Vous devez recevoir le message suivant : « les données ont été écrites correctement dans le Registre »
  5. Fermez l’utilitaire et réessayez les pages de portail d’entreprise.

Résolution 2 - Vérifiez que le fichier Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll

  1. Sur le serveur de portail d’entreprise, lancez le Gestionnaire Internet Information Services (IIS)
  2. Cliquez sur le site Web de Business Portal et sélectionnez « Propriétés »
  3. Sous l’onglet répertoire de base, notez la valeur dans la zone « Chemin d’accès Local »
  4. Sous l’onglet répertoire de base, notez la valeur dans la zone de liste déroulante Pool d’applications « »
  5. Cliquez sur OK pour fermer la fenêtre « Propriétés »
  6. Dans le Gestionnaire des services IIS, développez sur « Des Pools d’applications ».  Cliquez sur le pool d’applications disponible sur l’étape 4 et sélectionnez « Propriétés ».
  7. Sous l’onglet « Identity », notez que l’utilisateur spécifié comme identité du pool d’application.
  8. Cliquez sur OK pour fermer la fenêtre « Propriétés ».
  9. Fermez le Gestionnaire de IIS
  10. Dans l’Explorateur Windows, accédez à dans le répertoire trouvé à l’étape 3
  11. Dans le dossier Bin, faites défiler vers le bas et recherchez le fichier Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll.
    1. Si ce fichier est manquant, vous devrez peut-être réinstaller le portail d’entreprise
  12. Cliquez sur le fichier et sélectionnez Propriétés
  13. Sous l’onglet « Sécurité », assurez-vous que l’utilisateur de l’étape 7 a les droits « Lecture » et « lecture et exécution »
  14. Cliquez sur OK pour fermer la fenêtre « Propriétés »
  15. Cliquez de nouveau sur le fichier et sélectionnez « Ouvrir avec... »
  16. Choisissez « Sélectionner le programme à partir d’une liste »"
  17. Cliquez sur « Parcourir... »
  18. Accédez au dossier C:\Windows\System32 et trouver le fichier Regsvr32.exe, puis cliquez sur « Ouvrir »
  19. Cliquez sur OK.  Vous devez recevoir le message suivant : « DllRegisterServer dans C:\Inetpub\wwwroot\bin\Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll réussi. »
  20. Essayez de charger de nouveau les pages de portail d’entreprise

Résolution 3 - Vérifiez la clé de Registre

  1. Sur le serveur de portail d’entreprise, lancez le Gestionnaire Internet Information Services (IIS)
  2. Cliquez sur le site Web de Business Portal et sélectionnez Propriétés
  3. Sous l’onglet répertoire de base, notez la valeur dans la zone de liste déroulante « Application Pool »
  4. Cliquez sur OK pour fermer la boîte de dialogue de propriétés et fermer le Gestionnaire des services Internet sur
  5. Cliquez sur Démarrer -> exécuter et tapez RegEdt32.  Il doit s’ouvrir l’Éditeur du Registre
  6. Accédez à HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Business Portal\PMA\Solomon
    1. Si cette clé de Registre est manquante, reportez-vous à la résolution 1 d’exécuter l’utilitaire PCConfiguration
  7. Droit « Solomon » et sélectionnez « Autorisations »
  8. Assurez-vous que l’utilisateur de l’étape 3 a 'lu' autorisations
  9. Essayez de charger de nouveau les pages de portail d’entreprise

Pour plus d’informations, reportez-vous à la section base de connaissances l’Article 912363 .

Résolution 4 - Vérifiez que le fichier capicom.dll

  1. Sur le serveur de portail d’entreprise, accéder au dossier C:\windows\system32
  2. Cliquez droit sur CAPICOM. Fichier DLL et sélectionnez « Propriétés »
    1. Si ce fichier est manquant, vous devrez peut-être copier le fichier à partir d’une autre station de travail ou de réinstaller le portail d’entreprise
  3. Sous l’onglet Version, vérifiez que la Version du fichier affiche 2.1.0.1
    1. Si la version du fichier est incorrecte, vous devrez peut-être copier le fichier à partir d’une autre station de travail ou de réinstaller le portail d’entreprise
  4. Sous l’onglet sécurité, vérifiez que le groupe Domaine\Utilisateurs a lu et lire & exécuter les droits pour ce fichier.  ConsultezL’Article 927618 de la base de connaissances
  5. Cliquez sur OK pour fermer la boîte de dialogue Propriétés
  6. Cliquez de nouveau sur le fichier et sélectionnez « Ouvrir avec... »
  7. Choisissez « Sélectionner le programme à partir d’une liste »"
  8. Cliquez sur « Parcourir... »
  9. Accédez au dossier C:\Windows\System32 et trouver le fichier Regsvr32.exe, puis cliquez sur Ouvrir
  10. Cliquez sur OK.  Vous devez recevoir le message suivant : « DllRegisterServer dans C:\WINDOWS\system32\capicom.dll réussi. »
  11. Essayez de charger de nouveau les pages de portail d’entreprise
  12. Si vous recevez toujours l’erreur :
    1. Consultez Résolution 1 pour exécuter l’utilitaire PCConfiguration à nouveau.
    2. Redémarrez IIS en cliquant sur Démarrer -> exécuter et tapez « IISReset »
    3. Essayez de charger de nouveau les Pages de portail d’entreprise

Pour plus d’informations, reportez-vous à la section base de connaissances l’Article 909144 .

Résolution 5 : Vérifiez que le serveur IIS et le serveur SQL sont en mesure de communiquer à l’aide du protocole TCP/IP

  1. Le protocole TCP/IP doit être activé sur les deux le SQL Server et sur le serveur IIS hébergeant les sites de portail d’entreprise.
  2. Pour plus d’informations sur la façon de vérifier cela, consultez la base de connaissances l’Article 954024

Résolution 6 - Vérifiez que le chemin d’accès du fichier PCService.asx dans le fichier ProjectService.wsdl

  1. Sur le serveur de portail d’entreprise, accéder au fichier ProjectService.wsdl.  Il se trouve généralement dans le répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
  2. Ouvrez le fichier dans le bloc-notes
  3. Faites défiler vers le bas du fichier et recherchez la balise qui commence par « < SOAP : adresse d’emplacement = »
  4. Il doit être une URL vers le fichier PCService.asmx dans cette balise.  Il doit ressembler à ceci :

    "HTTP://machinename:80/BusinessPortal/Applications/PMA/PCService.asmx"

    Cette URL a plusieurs exigences spécifiques.  Vérifiez et corrigez les éléments suivants selon les besoins :
    1. L’URL doit spécifier le nom de l’ordinateur (par exemple, BPSERVER).  Adresses IP (par exemple 192.168.0.10), localhost ou un nom de domaine (comme BP.contoso.com) ne fonctionne pas pour les demandes SOAP.
      1. Pour trouver le nom de l’ordinateur, cliquez sur Démarrer -> exécuter et tapez CMD
      2. Tapez le nom d’hôte, puis appuyez sur entrer
      3. Le nom de l’ordinateur doit être retourné.  Machinename dans l’URL doit être défini pour faire correspondre ce.
    2. L’URL ne doit pas utiliser SSL.  L’URL doit commencer par « http:// » et non « https:// »
      1. Si votre site Web est configuré pour exiger SSL, consultez la base de connaissances l’Article 924723 pour savoir comment configurer une exception pour permettre une connexion non-SSL dans le fichier PCService.asmx.
    3. L’URL doit résoudre sur le site Web de BusinessPortal dans IIS
      1. Cela peut poser un problème si vous utilisez des en-têtes d’hôte pour différencier plusieurs sites Web qui s’exécutent sur le même serveur.
      2. Pour plus d’informations, reportez-vous à la section base de connaissances l’Article 2005711 .
  5. Tester l’URL pour vous assurer qu’elle est valide.  Pour ce faire, copiez l’URL et collez-la dans Internet Explorer sur le serveur de portail d’entreprise.  Il doit ouvrir une page intitulée « PCServices ».  Si au lieu de cela, vous recevez une erreur de sharepoint ou d’une erreur « Impossible d’afficher la page », vérifiez à nouveau les éléments à l’étape 4.
  6. Maintenant que le fichier ProjectService.wsdl possède une URL valide, essayez à nouveau les pages de portail d’entreprise

Pour plus d’informations, reportez-vous à la base de connaissances l’Article 892356 ou la base de connaissances l’Article 897024 .

Résolution 7 - Vérifiez la méthode d’authentification dans IIS

  1. Sur le serveur de portail d’entreprise, lancez le Gestionnaire Internet Information Services (IIS)
  2. Cliquez sur le site Web de Business Portal et sélectionnez Propriétés
  3. Sous l’onglet sécurité de répertoire, dans la section « authentification et contrôle d’accès », cliquez sur Modifier...
  4. Assurez-vous que « authentification intégrée de Windows » est activée.
  5. Assurez-vous que « activer l’accès anonyme », « Authentification Digest pour les serveurs de domaine Windows » et « Authentification .NET Passport » sont désactivés
  6. « Authentification de base » ne doit pas être vérifiée. Toutefois, cela pose un problème si elle est activée
  7. Cliquez sur OK, puis cliquez sur le OK à nouveau pour fermer la boîte de dialogue Propriétés
  8. Fermez le Gestionnaire de IIS
  9. Redémarrez IIS en cliquant sur Démarrer -> exécuter et tapez « IISReset »
  10. Essayez de nouveau les Pages de portail d’entreprise

Résolution 8 – Vérifiez la variable Sessionstate du fichier web.config

  1. Sur le serveur de portail d’entreprise, lancez le Gestionnaire Internet Information Services (IIS)
  2. Cliquez sur le site Web de Business Portal et sélectionnez Propriétés
  3. Sous l’onglet répertoire de base, notez la valeur dans la zone « Chemin d’accès Local »
  4. Cliquez sur OK pour fermer la boîte de dialogue de propriétés et fermer le Gestionnaire des services Internet sur
  5. Accédez à dans le répertoire trouvé dans l’étape 3 et recherchez le fichier web.config
  6. Effectuez une copie de sauvegarde du fichier web.config
  7. Ouvrez le fichier web.config dans le bloc-notes
  8. Recherchez la balise qui commence par « < sessionState »
  9. Modifier la balise entière à lire « < sessionState mode = « InProc » / > »
  10. Enregistrez le fichier et fermez le bloc-notes
  11. Redémarrez IIS en cliquant sur Démarrer -> exécuter et tapez « IISReset »
  12. Essayez de charger de nouveau les Pages de portail d’entreprise

Résolution 9 - exécuter le script PCConnectDebug et soumettre les résultats pour prendre en charge.

  1. Télécharger B2004933_pcConnectDebug.zip
  2. Décompressez le fichier sur le serveur de portail d’entreprise
  3. Copiez le fichier « pcConnectDebug.asp » dans le répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
  4. Sur le serveur Business Portal, ouvrez Internet Explorer et ouvrez une session sur le portail d’entreprise
  5. Cliquez sur la page Web de centre de projet
  6. Collez l’URL suivante pour ouvrir la page de PCConnectDebug :
    http://servername:port/BusinessPortal/Applications/PMA/pcconnectdebug.asp 

    Remplacez le « NomServeur » par le nom du serveur BP.  Remplacez le « port » avec le numéro de port que du site Web de BP est en cours d’exécution sous.
  7. Vous êtes invité à « Cliquez sur OK » pour continuer.  Cliquez sur OK.
  8. Une page Web s’affichera qui commence par « Début de débogage... ».   Dans Internet Explorer, cliquez sur fichier -> Enregistrer en tant que... et enregistrez la page dans un fichier.
    1. Avertissement: en fonction de la distance à laquelle le débogage a été en mesure d’atteindre, les résultats peuvent contenir un mot de passe en texte clair.  N’hésitez pas à modifier le fichier dans le bloc-notes et remplacez le mot de passe avec le mot « thePassword » avant de soumettre le fichier pour prendre en charge.
  9. Envoyer ce fichier aux Services de Support client Microsoft pour une analyse ultérieure.
  10. Dès que le problème est résolu, supprimez le fichier pcConnectDebug.asp du répertoire C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

Informations du Support interne Microsoft


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