CORRECTIF : Plusieurs problèmes se produisent lorsque vous utilisez l’adaptateur BizTalk pour JD Edwards EnterpriseOne ou adaptateur BizTalk pour JD Edwards OneWorld XE dans BizTalk Server 2006 R2 ou dans BizTalk Server 2009


Symptômes


Considérez le scénario suivant :
  • Vous disposez d’un ordinateur qui exécute Microsoft BizTalk Server 2006 R2 ou Microsoft BizTalk Server 2009.
  • Vous utilisez une des cartes suivantes d’échanger des messages entre BizTalk Server et un système JD Edwards EnterpriseOne Fonction d’entreprise :
    • Carte Microsoft BizTalk pour JD Edwards EnterpriseOne
    • Carte Microsoft BizTalk pour JD Edwards OneWorld XE
Dans ce scénario, un ou plusieurs des problèmes suivants peuvent se produire.

Problème 1

Une fois que vous essayez d’envoyer un message à l’aide de la carte, la carte est inactive pour un certain temps et que vous essayez d’envoyer un autre message. Dans ce scénario, la carte n’envoie pas le premier message. Cependant, la carte envoie le deuxième message. En outre, un événement semblable au suivant est enregistré dans le journal d’Application :

Problème 2

Lorsque vous définissez la propriété transport D’appels simultanés maximum sur une valeur supérieure à 1 pour la carte, de nombreuses instances de message est mise en attente et ne sont pas traités.

Problème 3

Périodiquement, les messages sont interrompus. En outre, certaines entrées d’événement semblables aux suivants sont consignées dans le journal d’Application :

Événement 1

Événement 2

Événement 3

Cause


Ces problèmes se produisent en raison d’une erreur dans les adaptateurs BizTalk pour les Applications d’entreprise.

Résolution


Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez disposer d’adaptateurs BizTalk pour les Applications d’entreprise (également appelé LOB adaptateurs BizTalk) installé. En outre, l’ordinateur doit être en cours d’exécution BizTalk Server 2006 R2 Service Pack 1 (SP1) ou BizTalk Server 2009.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
BizTalk Server 2006 R2 Service Pack 1
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Microsoft.biztalk.adapters.bizutil.dll1.0.5022.13164,23208-Aug-201116:47x86
Pour BizTalk Server 2009
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Microsoft.biztalk.adapters.bizutil.dll1.0.5102.2156,04028-Jul-201010:30x86

Comment faire pour appliquer ce correctif.

Pour appliquer ce correctif logiciel après que l’avoir installé, effectuez les opérations suivantes :
  1. Enregistrer manuellement le fichier Microsoft.BizTalk.Adapters.BizUtil.dll dans le global assembly cache (GAC). Pour ce faire, procédez comme suit.

    1. Ouvrez une fenêtre d’invite de commandes de Visual Studio ou l’invite de commandes SDK . Modifiez le répertoire en cours à ce qui suit :
      Adaptateurs BizTalk %ProgramFiles%\Common Files\Microsoft pour l’entreprise Applications\Bin
      Important Pour ouvrir une fenêtre d’invite de commandes de Visual Studio , vous devez disposer de Microsoft Visual Studio 2008 ou Microsoft Visual Studio 2005 est installé. Pour ouvrir une fenêtre d’invite de commandes SDK , vous devez disposer de Microsoft.NET Framework 2.0 SDK est installé.
    2. Dans la fenêtre d’invite de commandes de Visual Studio ou l’invite de commandes SDK , tapez la commande suivante et appuyez sur ENTRÉE :
      gacutil /i Microsoft.BizTalk.Adapters.BizUtil.dll
  2. Créer une nouvelle sous-clé dans le Registre. Pour ce faire, procédez comme suit :

    Avertissement Des problèmes graves peuvent survenir si vous modifiez le Registre incorrectement à l’aide de l’Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent vous obliger à réinstaller le système d’exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
    1. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
    2. Recherchez, puis sélectionnez la clé de Registre suivante :
      Pour le système d’exploitation 32 bits.
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters

      Pour le système d’exploitation 64 bits
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalkAdapters
    3. Dans le menu Edition , pointez sur Nouveau, puis cliquez sur Valeur DWORD.
    4. Tapez AgentOutboundTimeoutet appuyez sur ENTRÉE.
    5. Dans le menu Edition, cliquez sur Modifier.
    6. Sélectionnez décimal, tapez 60000, puis cliquez sur OK.
    La valeur de AgentOutboundTimeout est utilisée pour recycler les processus de RunTimeAgent après une certaine période d’inactivité. Nous vous conseillons de définir la valeur pour qu’elle soit supérieure à la durée nécessaire à l’opération à effectuer sur le serveur Oracle. Par défaut, la valeur est 60 000 millisecondes (1 minute).

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d’informations sur BizTalk Adapter pour JD Edwards EnterpriseOne, visitez le site Web Microsoft Developer Network (MSDN) suivant :Pour plus d’informations sur BizTalk Adapter pour JD Edwards OneWorld XE, visitez le site Web MSDN suivant :Pour plus d’informations sur la fenêtre d’invite de commandes de Visual Studio , reportez-vous au site Web MSDN suivant :Pour plus d’informations sur les correctifs de BizTalk Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2003907 des informations sur les correctifs de BizTalk Server