PRJ : Description le MPX projet Exchange du Format de fichier

S’applique à : Microsoft Office Project Standard 2003Project Standard 2010

Résumé


Le format de fichier MPX 4.0 est un format de fichier ASCII que vous pouvez utiliser pour transférer des informations de projet entre les différentes versions de Microsoft Project ainsi que des programmes tiers qui prennent en charge le format de fichier MPX, tels que le Planificateur de projet Primavera et Orée du bois Estimation de la précision.

Le fichier Mpxfile.wri se (Windows) et le fichier de Format de fichier MPX (Macintosh) décrivent le format de MPX 4.0 les fichiers créés dans Microsoft Project, versions 4.0, 4.1 et 98. Vous pouvez trouver ces fichiers dans le dossier où vous avez installé Microsoft Project version 4.0 ou 4.1. La section « Informations supplémentaires » de cet article contient l’intégralité du texte du fichier Mpxfile.wri se. (Remarque : le fichier Mpxfile.wri se n’est pas inclus dans Microsoft Project 98 ou Microsoft Project 2000.)

Le tableau suivant répertorie les versions de Microsoft Project qui peuvent de créer ou de lire le format de fichier MPX 4.0 :


Create Read
----------------
Microsoft Project 4.0 Yes Yes
Microsoft Project 4.1 Yes Yes
Microsoft Project 98 Yes Yes
Microsoft Project 2000 No Yes
Microsoft Project 2002 No Yes
Microsoft Project 2003 No Yes
Microsoft Project 2007 No Yes
Microsoft Project 2010 No Yes
Le convertisseur Microsoft Project est un programme Windows qui vous permet de convertir des fichiers créés dans le logiciel de gestion de projet de tiers au format MPX 4.0. Pour plus d’informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

130206 PRJ : le convertisseur de Microsoft Project pour le projet, 4.0 et 4.1
221256 PRJ : mise à jour du convertisseur de projet pour ABT Project Workbench 4.x
Pour plus d’informations sur la façon de résoudre les messages d’erreur qui se produisent lorsque vous ouvrez un fichier qui contient des données non valides, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

141261 PRJ : comment interpréter le Message reçu lors de l’ouverture du fichier de .mpx

Plus d'informations


Voici le texte complet du fichier Mpxfile.wri se.

En utilisant le Format de fichier MPX

Sur le Format de fichier MPX

Le format de fichier MPX est le format de fichier ASCII que vous pouvez utiliser pour transférer des informations de projet entre Microsoft Project et d’autres applications prenant en charge le format de fichier MPX comme Primavera Planificateur de projet et l’estimation de la précision Orée du bois. Le format de fichier MPX permet aux informations sur le projet de transfert ne peut pas apparaître dans une table, comme les informations d’affectations de ressources détaillées, des informations de calendrier, ou des informations dans la boîte de dialogue informations sur le projet.

Avant d’enregistrer un fichier Microsoft Project dans le format de fichier MPX, vérifiez que l’application à laquelle vous voulez transférer les informations de votre projet peut interpréter le format MPX. Dans certains cas, vous devrez peut-être exécuter un programme de conversion avant d’utiliser votre fichier dans l’autre application.

Microsoft Project peut également ouvrir des fichiers enregistrés au format de fichier MPX. Fichiers Microsoft Project version 4.1 pour Windows 95 peuvent ouvrir et enregistrer de Microsoft Project version 1.0, 3.0, 4.0 et 4.1 MPX.

Vous ouvrez un fichier comme n’importe quel autre fichier Microsoft Project. Lorsque vous ouvrez un fichier, vous pouvez fusionner le fichier dans le projet actif ou placer les informations dans un nouveau projet. Si vous choisissez de fusionner des fichiers et utilisez des ID uniques, les informations contenues dans le nouveau fichier remplacera les informations contenues dans l’enregistrement correspondant. Vous pouvez créer des fichiers MPX contenant uniquement les informations que vous souhaitez fusionner dans le projet existant, ainsi que les affectations de ressources. Par exemple, vous pouvez créer un fichier MPX qui contient uniquement les informations de coût qui a été modifié. En incluant l’ID Unique et le nouveau coût pour cet ensemble de ressources, seulement cette information est remplacée dans votre projet.

Un projet de fichier pour enregistrer un fichier au format MPX, consultez l’exportation dans la rubrique Format MPX dans l’aide en ligne. Lorsque vous exportez un fichier MPX, vous ne spécifiez pas une table car les tables d’exportation de tâches et les ressources sont automatiquement utilisées. Si vous supprimez les tables d’exportation de GLOBAL. MPT, vous ne pourrez pas exporter un fichier MPX, sauf si vous copiez les tables d’exportation de votre fichier de sauvegarde globale global. MPT ou votre projet en cours.

Vous pouvez modifier les tables d’exportation en choisir des Tables dans le menu Affichage, plus de Tables de choix, exporter en cliquant sur le bouton Modifier ; Toutefois, faites-le uniquement si demandé par l’application dans laquelle vous transférez les informations exportées. Les tables d’exportation fournis avec Microsoft Project sont les tables standard utilisées par la plupart des applications prenant en charge le format de fichier MPX.

Si les tâches ou les ressources entrant incluent le numéro d’identification Unique de la position de la première ou la deuxième et vous fusionnez deux fichiers, Microsoft Project fusionne les informations de l’enregistrement correspondant. Si aucune correspondance n’est trouvée, un nouvel enregistrement est créé à la fin des tâches ou des ressources. Si vous ne fusionnez pas le fichier que vous ouvrez et les tâches entrantes ou ressources incluent un numéro d’identification que le premier champ, Microsoft Project insère chaque tâche ou ressource dans la ligne comportant le numéro d’identification correspondant pour que le numéro d’identification de chaque tâche ou ressource dans Microsof Projet de t est le même que le numéro d’identification d’origine. Si le fichier entrant ignore un numéro d’ID, la ligne de tâche ou de ressource avec ce numéro d’identification est vide afin que vous pouvez importer des lignes vides entre les tâches ou les ressources.

Les différences suivantes existent entre les fichiers de la version 3.0 de Microsoft Project MPX et MPX version 4.0 et 4.1 :

-Lorsque vous ouvrez un fichier dans Microsoft Project, vous ne plus obtenir l’invite à fusionner le fichier dans le projet existant par défaut. Si vous souhaitez fusionner les informations dans le fichier MPX dans le fichier en cours vous devez spécifier cela dans la liste des paramètres de la commande FileOpen. Pour obtenir des instructions sur la procédure à suivre, consultez l’aide pour la fusion de Format de fichier MPX.

-Un nouvel enregistrement a été ajouté pour stocker les informations utilisées par les fonctionnalités de groupe de travail.

-Un nouvel enregistrement a été ajouté pour stocker des informations sur les tâches récurrentes.

-Le paramètre de Position du symbole de l’enregistrement des paramètres de devise maintenant prend en charge un espace entre le symbole et le nombre.

-Remarque : a il n’existe aucune différence entre le format de fichier MPX pour Microsoft Project version 4.1 pour Windows 95 et le format de fichier MPX pour Microsoft Project version 4.0.

Spécifications du Format de fichier MPX

Cette section est destinée aux développeurs qui créent des utilitaires pour transférer des informations entre une autre application et Microsoft Project. Si vous transférez des fichiers MPX entre Microsoft Project et une autre application qui prend déjà en charge le format de fichier MPX, vous n’avez pas besoin de lire cette section.

Un fichier MPX se compose d’enregistrements séparés par des retours chariot et de la ligne de flux. Dans chaque enregistrement sont les champs qui contiennent les informations pour le projet. Les types d’enregistrements et l’ordre de ces enregistrements sont définis. Le tableau suivant répertorie tous les types d’enregistrement, le numéro d’enregistrement utilisé pour identifier chaque type d’enregistrement et le nombre d’enregistrements de chaque type qui peuvent être inclus dans le fichier MPX. Le fichier n’a pas à contenir tous les types d’enregistrements ; l’enregistrement requis uniquement est la création d’un fichier. Tous les enregistrements inclus dans le fichier MPX doivent être dans l’ordre indiqué dans la table, à ceci près que les enregistrements de commentaires peuvent être insérés n’importe où dans le fichier.

Record name Record number Maximum number of Records
----------------------------------------------------------------------------
File Creation (required) none 1
Currency Settings 10 1
Default Settings 11 1
Date and Time Settings 12 1
Base Calendar Definition 20 250
Base Calendar Hours 25 7 per Base Calendar
Definition record
Base Calendar Exception 26 250 per Base Calendar
Definition record
Project Header 30 1
Text Resource Table Definition 40 1
(Or you can use the Numeric Resource Table Definition record)
Numeric Resource Table Definition 41 1
Resource 50 9,999
Resource Notes 51 1 per Resource record
Resource Calendar Definition 55 1 per Resource record
Resource Calendar Hours 56 7 per Resource Calendar
Definition record
Resource Calendar Exception 57 250 per Resource Calendar
Definition record
Text Task Table Definition 60 1
(Or you can use the Numeric Task Table Definition record)
Numeric Task Table Definition 61 1
Task 70 9,999
Task Notes 71 1 per Task record
Recurring Task 72 1 per Task record
Resource Assignment 75 100 per Task record
Assignment Workgroup fields 76 1 per Assignment record
Project Names 80 500
DDE and OLE Client Links 81 500
Comments 0 unlimited
REMARQUE
Certains enregistrements dans le fichier doivent suivre d’autres enregistrements. Les enregistrements dans le tableau précédent qui répertorient un nombre maximal « par « l’enregistrement précédent doivent figurer immédiatement après cet enregistrement. Par exemple, jusqu'à 100 ressources, les affectations peuvent être répertoriées par enregistrement de la tâche. Si une tâche a des affectations de ressources 10, les 10 enregistrements d’affectation de ressource doivent être situé immédiatement après l’enregistrement de cette tâche et la tâche suivante avant d’enregistrer.

Un fichier MPX commence toujours par l’enregistrement de la création d’un fichier. Cet enregistrement identifie le format de fichier (MPX), le caractère séparateur de liste utilisé pour séparer les champs dans les enregistrements, les fichiers de l’application et numéro de version utilisé pour créer le MPX, la version du format MPX utilisé dans le fichier et la page de code utilisée pour créer le fichier. Chaque enregistrement, à l’exception de l’enregistrement de la création d’un fichier, commence par le numéro d’enregistrement. Le numéro d’enregistrement est suivi par un caractère séparateur de liste et les informations de chacun des champs ; chaque champ est séparé par le caractère séparateur de liste.

Les règles générales pour le contenu du champ sont les suivantes :

-Champs calculés n’avez pas besoin d’être importées car ils sont ignorés.

-Si le caractère séparateur de liste, généralement une virgule ou un point-virgule, est inclus dans un champ, par exemple, pour séparer les prédécesseurs, le champ est placé entre guillemets.

-Si un champ contient un guillemet, les deux guillemets sont utilisés.

-Le caractère séparateur de liste ne doit pas être inclus dans les champs vides à la fin d’un enregistrement.

-Le caractère séparateur de liste doit être inclus dans les champs vides entre les champs qui contiennent des informations.

-Lors de l’exportation d’un fichier Microsoft Project MPX, les dates et les heures sont écrits dans le format de date par défaut pour la table d’exportation. Microsoft Project peut importer les dates entrées dans les formats de dates affichées dans la boîte de dialogue Options. Pour plus d’informations sur les formats de date et d’heure, recherche d’aide de Microsoft Project pour les Dates et passez à la rubrique Dates.

-Microsoft Project ignore un espace blanc (espaces et les tabulations) au début et à la fin des champs lors de l’importation d’un fichier MPX.

-Les champs importés vides ne pas remplacent les informations existantes lors de la fusion de fichiers MPX.

L’ordre et le contenu exact des champs dans chaque enregistrement sont décrites dans les définitions d’enregistrement suivantes. Le numéro de l’enregistrement servant à identifier le type d’enregistrement suit le nom de l’enregistrement. L’exemple dans chaque définition d’enregistrement utilise une virgule comme séparateur de liste.

Création de fichiers - aucun numéro d’enregistrement   Il s’agit d’un enregistrement qui identifie le format de fichier (MPX), le caractère séparateur de liste utilisé dans le fichier, le numéro de version et le programme utilisé pour créer le fichier, le numéro de version du format de fichier MPX utilisé dans le fichier et la page de code utilisée pour créer le fichier requis. Ce doit être le premier enregistrement dans le fichier. Lors de l’exportation à partir de Microsoft Project, le caractère séparateur de liste est spécifié dans l’élément de paramètres régionaux dans le panneau de configuration Windows.

Les champs de cet enregistrement sont les suivantes :
-MPX suivie immédiatement par le caractère séparateur de liste
-Nom/Identificateur du programme
-Nombre la version du fichier
-Page de code (850, 437, MAC, ANSI)

Exemple : MPX, Microsoft Project 3.0

Cet exemple indique qu’une virgule est utilisée comme caractère séparateur de liste dans ce fichier et la version du format MPX utilisé dans le fichier est exportée à partir de Microsoft Project version 3.0.

Paramètres de devise - 10   Cet enregistrement indique les paramètres pour les options de devise dans la boîte de dialogue Options. Si vous incluez des valeurs monétaires dans votre fichier d’importation, spécifiez les paramètres de devise ici afin que les valeurs sont correctement importées. Si cet enregistrement n’est pas inclus, les paramètres actuels dans la boîte de dialogue Options sont utilisées. Pour plus d’informations sur les paramètres de devise, rechercher l’aide de Microsoft Project pour les paramètres de devise par défaut. Séparateurs décimaux et milliers sont spécifiés dans l’élément de paramètres régionaux dans le panneau de configuration Windows.

Les champs de cet enregistrement sont les suivantes :
: Symbole monétaire
-Symbole Position (0 = après, 1 = avant, 2 = après avec un espace, 3 = avant avec un espace)
-Devise chiffres (0,1,2)
-Des milliers séparateur
-Séparateur décimal

Exemple : les $ 10, 1,2, «, ».

Cet exemple spécifie que les valeurs monétaires incluent un signe dollar ($) avant que deux chiffres figurent après la virgule décimale, qu’une virgule est utilisée pour séparer les milliers, et qu’un point est utilisé comme séparateur décimal. Étant donné que le caractère séparateur de liste est inclus dans le champ séparateur de milliers, le champ est entouré de guillemets.

Paramètres - 11 par défaut   Cet enregistrement indique les paramètres pour les options par défaut dans la boîte de dialogue Options. Si les durées que vous importez n’incluent pas une abréviation de durée, spécifiez l’unité de durée par défaut ici, afin que les unités de durée sont correctes. Si cet enregistrement n’est pas inclus, les paramètres actuels dans la boîte de dialogue Options sont utilisées. Pour plus d’informations sur les options par défaut, rechercher l’aide de Microsoft Project pour les valeurs par défaut de la durée.

Les champs de cet enregistrement sont les suivantes :
-Les unités de durée par défaut (0 = minutes, 1 = heures, 2 = jours, 3 = semaines)
-Type de durée par défaut (0 = ne pas fixe, 1 = fixe)
-Unités de travail par défaut (0 = minutes, 1 = heures, 2 = jours, 3 = semaines)
-Default heures/jour
-Default heures/semaine
-Taux Standard par défaut
-Taux d’heures sup. par défaut
-Mise à jour du statut des ressources mises à jour Office état (0 = non, 1 = Oui)
-Fractionner les tâches en cours (0 = non, 1 = Oui)

Exemple : 11,2,0,1,8,40, $10/ h, $15/ h, 1

Cet exemple spécifie les paramètres par défaut suivants : durées sont en jours et ne sont pas corrigées, sont des unités de travail en heures, il existe huit heures dans une journée de travail et 40 heures dans une semaine de travail, le taux de salaire standard est de 10 $ par heure, le taux de salaire des heures supplémentaires est de 15 $ par heure , et la case à cocher mise à jour de l’état de ressource de tâche état mises à jour.

Format MPX 1.0 : étant donné que seuls les nombres entiers sont autorisés pour les heures par jour par défaut et d’heures par semaine par défaut dans Microsoft Project version 1.0, une valeur non entière d’une option est arrondie à l’entier le plus proche lorsque vous créez un fichier au format MPX 1.0. Options pas dans Microsoft Project version 1.0 ne sont pas écrites lorsque vous créez un fichier au format MPX 1.0.

Paramètres date et heure - 12   Cet enregistrement spécifie les paramètres pour l’option de Format de Date texte barre dans la boîte de dialogue Mise en page, la date et des options de temps dans la boîte de dialogue Options. Si cet enregistrement n’est pas inclus, les paramètres actuels dans la boîte de dialogue Options sont utilisées. Pour plus d’informations sur les paramètres de date et d’heure, consultez l’aide pour les Dates et passez à la rubrique Dates.

Les champs de cet enregistrement sont les suivantes :
-Date de commande (0 = jour/mois/année, 1 = jour/mois/année 2 = année, mois, jour)
-Le Format d’heure (0 = 12 heures, 1 = 24 heures)
-L’heure par défaut (nombre de minutes après minuit)
: Séparateur de date
: Séparateur d’heure
-0:00 et 11:59 texte
-12:00 à 23:59 texte
-Le Format de date (0 -14) *
-Barre de Format de Date texte (-194 0) *

* Il existe 20 différents formats pour les dates. Pour afficher les formats de date disponibles, dans le menu Outils, choisissez Options, sélectionnez l’onglet Affichage et sélectionnez l’option de date que vous souhaitez dans la liste Format de Date. Pour plus d’informations, recherchez dans l’aide pour les Dates et passez à la rubrique Dates.

Exemple : 12,0,0,480, /, :, am, pm

Cet exemple spécifie que les dates sont dans l’ordre mois/jour/année, qui sont des heures au format 12 heures, la durée par défaut est 8:00 a.m. (ou 480 minutes après minuit), que le mois, le jour et l’année sont séparées par une barre oblique, que les heures et les minutes sont séparées par un signe deux-points , et que « am » et « pm » sont utilisés pour indiquer le matin et chaque soir.

Définition du calendrier de base - 20   Ces enregistrements définissent les calendriers de base et leur périodes ouvrée et chômé le jours de la semaine. Lorsque vous fusionnez un fichier MPX, les informations de calendrier sont fusionnées dans le projet actif, et les calendriers portant le même nom sont écrasés. Les paramètres par défaut sont utilisés s’il n’existe aucune entrée pour un jour. Les paramètres par défaut sont de lundi à vendredi pour les jours de travail, ainsi que le samedi et dimanche pour les jours chômés. Dans cet enregistrement, le champ nom est obligatoire. Pour chacun des jours, une écriture de 0 indique que le jour est un jour chômé, et une entrée de 1 indique que le jour est un jour ouvré.

Les champs de cet enregistrement sont les suivantes :
-Nom
-Dimanche
-Lundi
-Le mardi
-Mercredi
-Jeudi
-Vendredi
-Samedi

Exemple : les 20, auteurs, 0, 1, 1, 1, 1, 1, 0

Cet exemple spécifie que lundi à vendredi sont des jours ouvrés et samedi et dimanche sont des jours chômés du calendrier de base appelés writers.

Heures du calendrier de base - 25   Ces enregistrements de spécifient les heures de travail pour les jours de la semaine, si elles diffèrent des paramètres par défaut. Les heures de travail par défaut sont 8:00 à 12 h 00 et 13 h 00 à 17:00 heures Chaque enregistrement d’heures calendrier de Base fait référence à l’enregistrement précédent de la définition de calendrier de Base. Jusqu'à sept de ces enregistrements peuvent suivre chaque enregistrement de la définition de calendrier de Base.

-Le jour de la semaine (1 à 7, où 1 = dimanche et 7 = samedi)
-À partir de 1
-À l’heure 1
-À partir de 2
-À la fois 2
-À partir de 3
-À la fois 3

Exemple : 25,2, 7 h 00, 11:00, 12:00 4:00

Cet exemple spécifie que le lundi, les heures de travail sont de 7 h 00 à 11 h 00 et 12 h 00 à 16 h 00.

Calendrier de base Exception - 26   Ces enregistrements définissent les exceptions pour les jours et les heures spécifiées dans les deux types d’enregistrement précédents. Jusqu'à 250 de ces enregistrements peuvent suivre chaque enregistrement de la définition de calendrier de Base. Ces enregistrements doivent être répertoriés dans l’ordre chronologique. Si une exception est un jour, vous pouvez laisser vide le champ Date. Si aucun temps sont indiqués, les heures par défaut de 8 h 00 à 12:00 et de 13 h 00 à 17:00 heures sont utilisées.

Les champs de cet enregistrement sont les suivantes :
-À partir de Date
-Date de fin
-Jour chômé/travail (0 = non ouvrables, 1 = travail)
-À partir de 1
-À l’heure 1
-À partir de 2
-À la fois 2
-À partir de 3
-À la fois 3

Exemple 1 : 26,12/24/95,12/25/95,0
Exemple 2 : 26,10/4/95, 1, 8:00, 12:30

Exemple 1 montre le 24 décembre et 25, 1995, les jours chômés.
L’exemple 2 montre comment dimanche 4 octobre 1995, une journée de travail de 8 h 00 à 12:30
Exemple 2 requiert une virgule pour marquer l’emplacement du champ de Date.

Format MPX 1.0 : dans la mesure où les exceptions seulement 50 sont autorisées dans la version 1.0, toutes les exceptions après les 50 premières seront ignorées lors de la création d’un fichier au format MPX 1.0 de Microsoft Project.

En-tête de projet - 30   Cet enregistrement définit les champs du projet global, telles que la date de fin de la date de début de projet et le projet. Les champs de cet enregistrement correspondent aux informations dans les boîtes de dialogue des statistiques et des informations sur le projet.

Les champs et les onglets de cet enregistrement sont les suivantes :
-Onglet projet
-Société
-Le Gestionnaire
-Calendrier (Standard utilisé si aucune entrée)
-Date de début de (ce champ ou sur le champ suivant est calculé pour un fichier importé, en fonction du paramètre de la planification)
-Date de fin
-Permet de planifier à partir de (0 = début, 1 = fin)
-Date en cours *
-Commentaires
- Cost*
-Coût de base *
-Coût réel *
- Work*
-Base travail *
-Travail réel *
- Work*
- Duration*
-Base durée *
-Durée réel *
-Cent *
-Début de base *
-Fin de ligne de base *
-Début de réel *
-Fin réel *
-Variation de début de *
-Variation de fin *
-Sujet
: Auteur
: Mots clés

* Ces champs sont calculés par Microsoft Project, afin que les valeurs importées sont ignorées.

Exemple : 30, pointe d’exposition, musée National, Michael Edwards, Standard, 1/2/95

Dans cet exemple, les horloges présentent le projet pour le musée National est géré par Michael Edwards, utilise le calendrier Standard et démarre le 2 janvier 1995.

MPX 1.0 et 3.0 formats : champs pas dans la version 1.0 de Microsoft Project ou 3.0 ne sont pas écrites lorsque vous créez un fichier MPX 1.0 ou 3.0.

Définition de la Table ressource texte - 40   Cet enregistrement répertorie les champs de ressource, dans l’ordre, qui sont importées ou exportées. Pour les fichiers importés, les noms doivent correspondre les noms de champ utilisés dans Microsoft Project. Pour les fichiers exportés, cet enregistrement provenant de la table d’exportation de ressource. Vous devez utiliser cet enregistrement ou l’enregistrement de la Table de définition de ressource numérique décrites ci-après. Lors de l’exportation à partir de Microsoft Project, deux de ces enregistrements sont inclus. Pour une description complète des champs disponibles, recherche d’aide de Microsoft Project pour la table d’exportation et accédez à la synthèse de Table d’exportation (ressource) ou la rubrique de synthèse de Table d’exportation (tâche).

Pour cet enregistrement, répertorier les noms des champs de ressources que vous souhaitez, en les séparant par le caractère séparateur de liste.

Exemple : 40, nom, max. unités, taux standard

Cet exemple spécifie que chaque enregistrement de ressource dans le fichier contient le nom de la ressource, unités maximales et taux standard.

REMARQUE
Pour les fichiers importés, si vous ne fusionnez le nouveau fichier avec le projet ouvert et que l’ID est le premier champ indiqué après le numéro d’enregistrement dans l’enregistrement de texte ou de la définition de la Table ressource numérique, les enregistrements de ressources sont importés avec le même numéro d’identification, comme indiqué dans l’enregistrement. Par exemple, si la première est importée enregistrement de ressource a un numéro d’ID de 1 et le deuxième enregistrement de ressources importées a un numéro d’ID de 3, les enregistrements sont importés dans Microsoft Project en tant que ressources 1 et 3, en laissant vide la ressource 2. Si vous ne le faites fusion et le champ de l’ID Unique est le premier champ ou la deuxième suivant de champ le champ ID, Microsoft Project recherchera un enregistrement avec le même ID Unique et remplacez les informations existantes avec les nouvelles informations. Si aucune correspondance n’est trouvée, un nouvel enregistrement est ajouté à la fin de la liste.

MPX 1.0 et 3.0 Formats : pas dans les versions 1.0 ou 3.0 de Microsoft Project, les champs ne sont pas écrites lorsque vous créez un fichier au format MPX 1.0.

Un fichier MPX doit avoir au moins deux champs tâche et deux ressources.

Définition de la Table des ressources numériques - 41   À l’aide de nombres plutôt que des noms, cet enregistrement répertorie les champs de ressource, dans l’ordre, qui sont importées ou exportées. Ceci est une autre méthode pour identifier les champs de ressources inclus dans chaque enregistrement de ressource et est utile lors de la définition d’un fichier créé par un produit de langue étrangère.

Le tableau suivant répertorie les numéros de champ pour tous les champs de ressources dans Microsoft Project. Pour une description complète des champs disponibles, recherche d’aide de Microsoft Project pour la table d’exportation et consultez la rubrique de synthèse de Table d’exportation (ressource).

Pour cet enregistrement, liste les numéros des champs de ressources que vous souhaitez, en les séparant par le caractère séparateur de liste.

Field Number
------------------------------
% Work Complete 26
Accrue At 45
Actual Cost 32
Actual Work 22
Base Calendar 48
Baseline Cost* 31
Baseline Work* 21
Code 4
Cost* 30
Cost Per Use 44
Cost Variance* 34
Email Address 11
Group 3
ID 40
Initials 2
Linked Fields* 51
Max Units 41
Name 1
Notes 10
Objects* 50
Overallocated* 46
Overtime Rate 43
Overtime Work* 24
Peak* 47
Remaining Cost* 33
Remaining Work* 23
Standard Rate 42
Text1 5
Text2 6
Text3 7
Text4 8
Text5 9
Unique ID 49
Work* 20
Work Variance* 25

* When creating a file to be imported into Microsoft Project, you do not have to
include this field as it will be ignored.
Exemple : 41,1,41,42

Cet exemple répertorie les numéros de champ qui correspondent aux champs illustrés dans l’exemple précédent (nom, unités maximales et taux Standard).

MPX 1.0 et 3.0 Formats : champs pas dans la version 1.0 de Microsoft Project ou 3.0 ne sont pas écrites lorsque vous créez un fichier MPX 1.0 ou 3.0.

Ressource - 50   Ces enregistrements contiennent les informations de chaque ressource importé ou exporté. Chaque enregistrement de ressource décrit une ressource. Lorsque vous importez des informations, les champs qui sont inclus sont définis par l’enregistrement de la définition de la Table ressource texte ou de l’enregistrement de la Table de définition de ressource numérique. Lorsque vous exportez des informations, les champs qui sont inclus sont ceux répertoriés dans la table d’exportation de ressource.

Pour cet enregistrement, indiquez les valeurs de champ pour la ressource, en les séparant par le caractère séparateur de liste.

Exemple : 50, charpentier, 4, 10/ h

Cet exemple affiche les informations de ressource distincts pour chaque type qui correspond à la définition de table de ressource spécifiée dans l’exemple précédent. Les unités Max est quatre et le taux Standard de 10 $ par heure.

Format MPX 1.0 : champs de texte qui sont trop longs sont tronqués lorsque vous créez un fichier au format MPX 1.0. Ressources uniquement 2000 seront enregistrées au format MPX 1.0.

Remarques sur les ressources - 51   Ces enregistrements contiennent des remarques relatives à l’enregistrement de ressource immédiatement précédent. Utilisez le caractère ASCII 127 pour indiquer une nouvelle ligne dans la note. Si la note inclut le caractère séparateur de liste, placez celle-ci entre guillemets.

Format MPX 1.0 : si la note est trop longue, il est tronqué lorsque vous créez un fichier au format MPX 1.0.

Définition de calendrier de ressource - 55   Ces enregistrements définissent les jours ouvrés pour la ressource spécifiée dans l’enregistrement précédent. Pour les fichiers importés, s’il n’existe aucune entrée pour le champ nom de calendrier de Base Standard est utilisé. Aucune entrée pour le jour spécifique n’indique que la date est fixée à la valeur par défaut (2). S’il n’y a aucun enregistrement de la définition du calendrier de ressource, Standard est utilisé comme calendrier de base pour la ressource, avec la valeur par défaut utilisée pour les jours. Pour chacun des jours, une écriture de 0 indique que le jour est un jour chômé, 1 indique que le jour est un jour ouvré, et 2 indique que la valeur par défaut est utilisé. Pour plus d’informations sur les calendriers de ressources, recherche d’aide de Microsoft Project pour le calendrier de la ressource et consultez la rubrique commande de temps de travail Change.

Les champs de cet enregistrement sont les suivantes :
-Nom du calendrier de base
-Dimanche
-Lundi
-Le mardi
-Mercredi
-Jeudi
-Vendredi
-Samedi

Exemple : 55 standard, 2, 2, 2, 2, 2, 0, 2

Cet exemple spécifie que la ressource définie qui précède immédiatement cet enregistrement (dans ce cas, charpentier) a la même jours ouvrés et les heures comme calendrier de base Standard pour dimanche au jeudi et samedi, mais ne fonctionne pas sur les vendredis.

Heures de calendrier de ressource - 56   Ces enregistrements définissent les heures de travail pour la ressource qui diffèrent du calendrier de base utilisé par la ressource. Ces enregistrements s’appliquent à l’enregistrement de la définition du calendrier de ressource qui précède immédiatement cet enregistrement. Jusqu'à sept de ces enregistrements peuvent suivre chaque enregistrement de la définition du calendrier de ressource.

Les champs de cet enregistrement sont les suivantes :
-Le jour de la semaine (1 à 7, où 1 = dimanche et 7 = samedi)
-À partir de 1
-À l’heure 1
-À partir de 2
-À la fois 2
-À partir de 3
-À la fois 3

Exemple : 56,3, 7 h 00, 11:00, 12:00 4:00

Cet exemple spécifie que le mardi, la ressource précédente (dans ce cas, charpentier) fonctionne à partir de 7 h 00 à 4 h 00 avec une heure de 11 h 00 à 12 h 00

Exception de calendrier de ressource - 57   Ces enregistrements définissent les exceptions pour les jours et les heures spécifiées dans les deux types d’enregistrement précédents. Jusqu'à 250 de ces enregistrements peuvent suivre chaque enregistrement de la définition du calendrier de ressource. Ces enregistrements doivent être répertoriés dans l’ordre chronologique. Si l’exception n'est qu’un seul jour, vous pouvez laisser vide le champ Date. Si aucun temps sont indiqués, les heures par défaut de 8 h 00 à 12:00 et de 13 h 00 à 17:00 heures sont utilisées.

Les champs de cet enregistrement sont les suivantes :
-À partir de Date
-Date de fin
-Jour chômé/travail (0 = non ouvrables, 1 = travail, 2 = valeur par défaut)
-À partir de 1
-À l’heure 1
-À partir de 2
-À la fois 2
-À partir de 3
-À la fois 3

Exemple : 57,11/9/95,11/13/95,0

Cet exemple spécifie que cette ressource (dans ce cas, charpentier) ne fonctionne pas à partir du 9 novembre 1995, le 13 novembre 1995.

Format MPX 1.0 : dans la mesure où les exceptions seulement 50 sont autorisées dans la version 1.0, toutes les exceptions après les 50 premières seront ignorées lors de la création d’un fichier au format MPX 1.0 de Microsoft Project.

Définition de la Table tâche texte - 60   Cet enregistrement répertorie les champs de tâche, dans l’ordre, qui sont importées ou exportées. Pour les fichiers importés, les noms doivent correspondre les noms de champ utilisés dans Microsoft Project. Si le fichier est en cours d’exportation, cet enregistrement provient de la table d’exportation de tâche. Vous pouvez utiliser cet enregistrement ou l’enregistrement de la définition de la Table tâche numérique décrites ci-après, mais une ou l’autre est requis. Lors de l’exportation à partir de Microsoft Project, deux de ces enregistrements sont inclus. Pour une description complète des champs disponibles, recherche d’aide de Microsoft Project pour la table d’exportation et accédez à la synthèse de Table d’exportation (ressource) ou la rubrique de synthèse de Table d’exportation (tâche).

Les champs qui sont calculés par Microsoft Project, telles que prévues de début et de fin prévue, sont ignorés si importé. Si vous avez une tâche de début ou de fin qui sont résolus, utilisez les champs de Type de contrainte et Date contrainte.

Pour cet enregistrement, répertorier les noms des champs que vous souhaitez, en les séparant par le caractère séparateur de liste de tâches.

Exemple : 60, nom, durée, prédécesseurs

Cet exemple spécifie que chaque enregistrement de tâche dans le fichier contient le nom de la tâche, durée et prédécesseurs.

REMARQUE
Pour les fichiers importés, si vous ne fusionnez le nouveau fichier avec le projet ouvert et des ID de tâche est le premier champ indiqué après le numéro d’enregistrement dans l’enregistrement de texte ou de la définition de la Table tâche numérique, les enregistrements de tâche sont importés avec le même numéro d’identification de tâche, comme indiqué dans l’enregistrement. Par exemple, si le premier enregistrement de la tâche importée a un numéro d’ID de tâche de 1 et le deuxième enregistrement de la tâche importée a un numéro d’ID de tâche 3, les enregistrements sont importés dans Microsoft Project en tant que tâches 1 et 3, en laissant la tâche 2 est vide. Si vous ne le faites fusion et le champ de l’ID Unique est le premier champ ou la deuxième suivant de champ le champ d’ID de tâche, Microsoft Project recherchera un enregistrement avec le même ID Unique et remplacez les informations existantes avec les nouvelles informations. Si aucune correspondance n’est trouvée, un nouvel enregistrement est ajouté à la fin de la liste. Si vous de fusion sur un ID Unique et que vous souhaitez conserver des relations correctes, inclure nº Unique des prédécesseurs en tant que champ à importer et supprimer les prédécesseurs.

Si vous fusionnez dans un nouveau fichier, vous devez inclure l’enregistrement 75 si vous voulez conserver les affectations de ressources. Si vous ne le faites pas, les affectations de ressources seront supprimées.

MPX 1.0 et 3.0 formats : champs pas dans la version 1.0 de Microsoft Project ou 3.0 ne sont pas écrites lorsque vous créez un fichier MPX 1.0 ou 3.0. Le champ des priorités dans les versions 4.0 et 4.1 correspondance aux versions 1.0 et 3.0 comme suit : effectuez pas le niveau et le plus élevé devient plus élevé ; Très élevé, supérieur et haute deviennent élevé ; Support est le support ; Très faible, faible et inférieur devient faible ; et plus faible est le plus bas.

Un fichier MPX doit avoir au moins deux champs tâche et deux ressources.

Définition de la Table tâche numérique - 61   À l’aide de nombres plutôt que des noms, cet enregistrement répertorie les champs de tâche, dans l’ordre, qui sont importées ou exportées. Ceci est une autre méthode pour identifier les champs de tâche inclus dans chaque enregistrement de tâche et est utile lors de la définition d’un fichier créé par un produit de langue étrangère.

Le tableau suivant répertorie les numéros de champ pour tous les champs de tâche dans Microsoft Project. Pour obtenir une description complète des champs disponibles, consultez l’aide de la table d’exportation et consultez la rubrique Résumé d’exporter la Table (tâche).

Pour cet enregistrement, afficher les numéros des champs de tâches souhaitées séparées par le caractère séparateur de liste.


Field Number
------------------------------
% Complete 44
% Work Complete 25
Actual Cost 32
Actual Duration 42
Actual Finish 59
Actual Start 58
Actual Work 22
Baseline Cost 31
Baseline Duration 41
Baseline Finish 57
Baseline Start 56
Baseline Work 21
BCWP 86
BCWS 85
Confirmed 135
Constraint Date 68
Constraint Type 91
Contact 15
Cost 30
Cost1 36
Cost2 37
Cost3 38
Cost Variance* 34
Created* 125
Critical* 82
CV* 88
Delay 92
Duration 40
Duration1 46
Duration2 47
Duration3 48
Duration Variance* 45
Early Finish* 53
Early Start* 52
Finish 51
Finish1 61
Finish2 63
Finish3 65
Finish4 127
Finish5 129
Finish Variance* 67
Fixed 80
Fixed Cost 35
Flag1 110
Flag2 111
Flag3 112
Flag4 113
Flag5 114
Flag6 115
Flag7 116
Flag8 117
Flag9 118
Flag10 119
Free Slack* 93
Hide Bar 123
ID 90
Late Finish* 55
Late Start* 54
Linked Fields* 122
Marked 83
Milestone 81
Name 1
Notes 14
Number1 140
Number2 141
Number3 142
Number4 143
Number5 144
Objects* 121
Outline Level 3
Outline Number 99
Predecessors 70
Priority 95
Project 97
Remaining Cost 33
Remaining Duration 43
Remaining Work 23
Resource Group* 16
Resource Initials 73
Resource Names 72
Resume 151
Resume No Earlier Than 152
Rollup 84
Start 50
Start1 60
Start2 62
Start3 64
Start4 126
Start5 128
Start Variance* 66
Stop 150
Subproject File 96
Successors 71
Summary* 120
SV* 87
Text1 4
Text2 5
Text3 6
Text4 7
Text5 8
Text6 9
Text7 10
Text8 11
Text9 12
Text10 13
Total Slack* 94
Unique ID 98
Unique ID Predecessors 74
Unique ID Successors 75
Update Needed 136
WBS 2
Work 20
Work Variance* 24

* When creating a file to be imported into Microsoft Project, you do not have to
include this field as it will be ignored. If you have start or finish dates that are
fixed, use the Constraint Type and Constraint Date fields.
Exemple : 61,1,40,70

Cet exemple répertorie les numéros de champ qui correspondent aux champs illustrés dans l’exemple précédent (nom, durée et prédécesseurs).

MPX 1.0 et format 3.0 : champs pas dans la version 1.0 de Microsoft Project ou 3.0 ne sont pas écrites lorsque vous créez un fichier MPX 1.0 ou 3.0.

Tâche - 70   Ces enregistrements contiennent les informations de chaque tâche importé ou exporté. Chaque enregistrement de tâche décrit une tâche. Lorsque vous importez des informations, les champs qui sont inclus sont définis par l’enregistrement de la définition de la Table tâche texte ou de l’enregistrement de la Table de définition de tâche numérique. Lorsque vous exportez des informations, les champs qui sont inclus sont ceux répertoriés dans la table d’exportation de tâche.

Pour cet enregistrement, indiquez les valeurs de champ pour la tâche, en les séparant par le caractère séparateur de liste.

Exemple : 70, verser ciment, 6d

Cet exemple montre les informations de la tâche « Couler ciment » qui correspond à la définition de table de tâche spécifiée dans l’exemple précédent. Durée de la tâche est de 6 jours.

Format MPX 1.0 : supérieure à 5 sont enregistrés en tant que niveau cinq des niveaux hiérarchiques. Les champs de texte qui sont trop longs sont tronqués. Tâches uniquement 2000 sont enregistrées.

Remarques sur les tâches - 71   Ces enregistrements contiennent des remarques relatives à l’enregistrement précédent de la tâche. Utilisez le caractère ASCII 127 pour indiquer une nouvelle ligne dans la note. Si la note inclut le caractère séparateur de liste, placez celle-ci entre guillemets.

Format MPX 1.0 : si la note est trop longue, il est tronqué lorsque vous créez un fichier au format MPX 1.0.

Abonnement de tâche - 72   Ces enregistrements indiquent si la tâche est une tâche répétitive.

Les champs inclus dans cet enregistrement, si la tâche est une tâche répétitive parent sont les suivants :
-Début des occurrences entré dans la boîte de dialogue informations sur la tâche périodique.
-Terminer la date saisie dans la boîte de dialogue informations sur la tâche périodique.
-Durée de chaque occurrence.
-Type de durée (jour, mois, etc.).
-Nombre d’occurrences.
-Le type choisi. (1 - tous les jours, 4 - une fois par semaine, 8 - tous les mois, 16 - annuel) dans la boîte de dialogue informations sur la tâche périodique.
-L’index de la liste déroulante dans la boîte de dialogue quotidienne (1, 2 pour toutes les autre etc..).
-L’index de la liste déroulante dans la zone toutes les semaines.
-L’index de la liste déroulante (premier, deuxième, troisième...) dans la zone mensuelle.
-L’index de liste déroulante (lundi, mardi...) dans la zone mensuelle.
-La liste déroulante index (tous, tous autres) si la case d’option en bas est sélectionnée dans la zone mensuelle.
-La valeur du jour, dans la zone mensuelle.
-La liste déroulante index (tous, chaque autre...) si la case d’option supérieure est sélectionnée dans la zone mensuelle.
-L’index de la liste déroulante (premier, deuxième...) dans la zone annuelle.
-L’index de liste déroulante (le lundi,...) dans la zone annuelle.
-La liste déroulante index (janvier, février...) dans la zone annuelle.
-La date indiquée dans la zone annuelle.

Si la tâche est une tâche répétitive d’enfant, le champ de cet enregistrement est la suivante :
-Unique ID du parent

Exemple : 72,1

Cet exemple spécifie que la tâche est une tâche répétitive enfant et que la tâche périodique parent a Unique ID 1.

Affectation de la ressource - 75   Ces enregistrements de la liste d’informations sur les ressources affectées à la tâche qui a été définie dans l’enregistrement précédent de la tâche. Si vous fusionnez des fichiers et que vous souhaitez que les informations d’affectations de ressource conservées, vous devez inclure les informations dans le fichier MPX. Si vous fusionnez, toutes les affectations existantes sur les tâches fusionnées seront supprimées. Si vous fusionnez des fichiers basés sur un ID Unique, les ressources sont affectées à l’aide de l’ID de ressource Unique, plutôt que les ID.

Les champs de cet enregistrement sont les suivantes :
-ID
-Unités
-Travail
-Travail planifié
-Travail réel
-Heures supplémentaires
-Coût
-Coût
-Coût réel
- Start*
- Finish*
-Délai
-ID Unique de ressources

* Dans la mesure où ces champs sont calculés par Microsoft Project, les valeurs importées sont ignorées.

Exemple : 75,3,0.5, 40h

Cet exemple spécifie que la ressource avec le numéro d’identification 3 affectée à la tâche précédente. Si les ressources entrants n’ont pas de numéros d’identification, la troisième ressource entrante est affectée. Dans cet exemple, la ressource est affectée à la tâche « Couler le ciment » de 40 heures de travail, avec des unités de 0,5.

Format MPX 1.0 : le délai est ignorée si vous créez un fichier au format MPX 1.0.

Champs de groupe de travail affectation ressource - 76   Ces enregistrements de répertorient les informations qui sont stockées avec chaque affectation pour les fonctionnalités de groupe de travail de Microsoft Project 4.0 et 4.1. Si vous utilisez les fonctionnalités de groupe de travail que vous devez inclure cet enregistrement pour vous assurer que les informations sont perdues.

Les champs de cet enregistrement sont les suivantes :
-ID Unique du message
-Confirmés (0 = False, 1 = True)
-Réponse en attente (0 = False, 1 = True)
-Début de mise à jour (Date)
-Mise à jour de fin (Date)
-ID de Schedule +

Exemple : 76,1,0,1,6/1/95,6/2/95

Cet exemple spécifie que l’affectation de ressource spécifiée dans l’enregistrement d’affectation ci-dessus (75) a Message Unique ID 1, n’a pas confirmé l’affectation, il n’a pas répondu au dernier message envoyé et qu’il a été informé que la tâche de début et dates de fin sont 6/1/95 et 2/6/95.

Noms de projet - 80   Ces enregistrements de répertorient tous les noms de liens DDE qui sont stockés dans le projet.

Les champs de cet enregistrement sont les suivantes :
-Nom
-Description

Exemple : 80,DDE_Link_T1,"T((1,3,5),(Name,Duration)) »

Cet exemple répertorie le lien DDE nommé DDE_Link_T1 et sa description. Pour plus d’informations sur DDE, consultez l’aide de DDE et consultez la rubrique Définition de protection continue des données (DDE, Dynamic Data Exchange). Étant donné que le caractère séparateur de liste est inclus dans la description, le champ est entouré de guillemets.

Format MPX 1.0 : Si vous enregistrez au format MPX 1.0, cet enregistrement n’est pas écrit.

DDE et OLE Client liens - 81   Ces enregistrements de répertorient toutes les liaisons DDE dans le projet.

-Source
-Créer un lien vers

Exemple : 81,Winword|d:\winword\MPX.doc ! DDE_Link1,"T(1,Name) »

Dans cet exemple, Winword|d:\winword\MPX.doc ! DDE_Link1 est l’argument de liaison et T(1,Name) est l’argument lier à. Étant donné que le caractère séparateur de liste est inclus dans la zone Lier à, le champ est entouré de guillemets. OLE liens Client sont distinguent des liens DDE client en affectant le premier caractère « : ». Par exemple : 81,:\LINK_1,"T(2,1) «, le » : » au début de la zone lien d’argument indique une liaison OLE.

Format MPX 1.0 : Si vous enregistrez au format MPX 1.0, cet enregistrement n’est pas écrit.

Commentaires - 0   Ces enregistrements peuvent être utilisés pour ajouter des commentaires dans le fichier et peuvent apparaître dans n’importe quelle position dans le fichier. Chaque enregistrement de commentaires doit commencer par « 0 ».