WINS records get tombstoned after upgrading to Windows 2008 R2

Symptoms

WINS records get tombstoned after upgrading WINS server from server 2003 to 2008 R2. If the client refreshes the WINS record, the corresponding record will be active again.

Cause

After replace a Windows 2003 WINS server with a Windows 2008 R2 server for an hour or two, most WINS records on the new server are in tombstone status.

The issue happen because the renew interval and extinction interval is much shorter than that of WINS 2003. The client registered with the 2003 server before so that the renew interval to client was 6 days. The client will not renew until 1/2 renew interval which is 3 days. However, the 2008 WINS server's renew interval and extinction interval becomes 40 minutes and after that, the record is set to tombstone.

Resolution

The solution Opening the Intervals tab and clicking "Restore default" will restore the 2003 values. 

2003 2008/2008 R2
Renew interval 6 days 40 minutes
Extinction interval 4 days 40 minutes
Extinction timeout 6 days 1 day
Verification interval 24 days 24 days

More Information

To recover the tombstone records, can wait for clients to renew with the new server. However, it might bring impact because there will be a time gap.


To workaround this, we can output the WINS database with command: netsh wins server \\winsservername show database servers={winsserverIP} file=c:\output.txt


Then develop a script which add records back with netsh wins server add context.
Propriétés

ID d'article : 2848811 - Dernière mise à jour : 16 mai 2013 - Révision : 1

Commentaires