Message d’erreur sur des écrans différents dans Microsoft Dynamics SL : « Message système 10232 - Échec de l’Assertion »


Symptômes


Vous recevez un message d’erreur semblable au suivant dans divers écrans de Microsoft Dynamics SL 7.0 : o{17944DF6-4CA9-4C98-98D7-03952B59E82Ct{17944DF6-4CA9-4C98-98D7-03952B59E82C. { 03952B59E82C-17944DF6-4CA9 - 4C 98-98D 7 :
Message système 10232 - Échec de l’Assertion ! Fichier : % ligne : % Expression : %s atteint un OK pour arrêter le programme et signaler l’erreur au Support de Microsoft, en notant l’expression ayant échouée, nom de fichier et numéro de ligne.

Cause


Ce message d’erreur peut se produire pour plusieurs raisons.
  • Se produit lorsqu’une personnalisation de l’écran est endommagé ou en conflit avec un autre personnalisation. Reportez-vous à la résolution 1.
  • Se produit pendant le processus d’importation de la Transaction, car la macro de fichier ou d’un contrôle de données ne correspond pas correctement à l’écran que vous importez dans. Reportez-vous à la section Résolution 2.
  • Se produit lorsque la version du fichier swimapi.dll qui est installé sur le lecteur local diffère de la version qui est installée sur le serveur de fichiers Microsoft Dynamics SL. Reportez-vous à la résolution 3.
  • Se produit lorsque vous cliquez sur Coller dans l’écran modèle (98.230.00) . Consultez Résolution 4
  • Se produit lorsque vous essayez d’ouvrir un écran qui contient une grille. Consultez Résolution de 5.
  • Se produit lorsque vous essayez de sélectionner une imprimante pour un modèle de rapport. Consultez Résolution 6.

Résolution


Résolution 1


Déterminer si une personnalisation de l’écran est endommagé ou en conflit avec un autre personnalisation en ouvrant l’écran en mode standard. Pour ce faire, procédez comme suit :


Si vous exécutez Microsoft Dynamics SL 7.0 et versions ultérieures, procédez comme suit :
  1. Dans la barre d’état, cliquez sur automatique.
  2. Cliquez sur Standard, puis cliquez sur OK..
  3. Ouvrez l’écran personnalisé.
    Remarque Si le Message système 10232 ne se produit pas lorsque vous ouvrez l’écran en mode Standard, la personnalisation est la source du problème et doit être recréé.

Si vous exécutez Microsoft Dynamics SL 6.5, procédez comme suit :
  1. Dans le menu Personnaliser , cliquez sur Sélectionnez un niveau.
  2. Cliquez sur Standard, puis cliquez sur OK.
  3. Ouvrez l’écran personnalisé.
    Remarque Si le Message système 10232 ne se produit pas lorsque vous ouvrez l’écran en mode Standard, la personnalisation est la source du problème et doit être recréé.

Résolution 2


Créer une macro de fichier et le contrôle de données qui corresponde exactement à l’écran que vous importez les données dans.
Remarque Consultez le fichier d’importation de Transaction aide ou le manuel d’importation de Transaction pour plus d’informations sur la façon de créer des fichiers de données et de contrôler les macros qui sont correctement mis en forme.

Résolution 3


Vérifiez que la version du noyau Microsoft Dyamics SL qui est installée sur le disque local est le même que sur le serveur de fichiers. Pour ce faire, procédez comme suit :
  1. Démarrer Microsoft Dynamics SL, puis cliquez sur aide.
  2. Dans le menu aide , cliquez sur à propos de Microsoft Dynamics SLet notez le numéro de version.
  3. Répétez les étapes 1 et 2 sur le serveur de fichiers Microsoft Dynamics SL.

Remarque Si les numéros de version diffèrent, installez la mise à jour de Microsoft Dynamics SL approprié sur le disque local.
Pour plus d’informations sur le noyau de Microsoft Dynamics SL builds, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

850447 la liste des versions, du noyau et des versions de Microsoft Dynamics SL


Résolution 4


Supprimer, puis recréer le modèle. Pour ce faire, procédez comme suit :
  1. Ouvrez l’écran approprié.
  2. Cliquez sur Actionset cliquez sur modèle, puis tapez le code dans la zone ID de modèle .
  3. Cliquez sur Supprimer, puis cliquez sur Oui lorsque vous êtes invité par le message de confirmation suivant :
    Le Message système 12 - Etes-vous sûr de vouloir supprimer ?
  4. Recréer le modèle en utilisant les valeurs appropriées.

Résolution 5


Enregistrer manuellement le MSIGRID. Fichiers OCX. Pour ce faire, procédez comme suit :
  1. Recherchez la MSIGRID. Fichiers OCX dans les chemins d’accès suivants :
    Système d’exploitation 32 bits : < lecteur_système > : \Windows\System32
    Système d’exploitation 64 bits : < lecteur_système > : \Windows\SysWOW64

    Remarque < lecteur_système > représente le lecteur sur lequel Microsoft Windows est installé.
  2. Avec le bouton droit de la MSIGRID. OCX du fichier, puis cliquez sur Ouvrir avec .
  3. Dans la boîte de dialogue Windows , cliquez sur Sélectionner le programme dans une liste , puis cliquez sur OK .
  4. Dans la boîte de dialogue Ouvrir avec , cliquez sur Parcourir .
  5. Recherchez et ouvrez le dossier suivant : système d’exploitation 32 bits : < lecteur_système > : \Windows\System32 64 bits système d’exploitation : < lecteur_système > : \Windows\SysWOW64
  6. Double-cliquez sur le fichier Regsvr32.exe, puis cliquez sur OK .
  7. Recherchez et ouvrez le dossier suivant : système d’exploitation 32 bits : < lecteur_système > : \Windows\System32 64 bits système d’exploitation : < lecteur_système > : \Windows\SysWOW64
  8. Cliquez sur OK lorsque vous recevez le message suivant :
    RegSvr32 - DllRegisterServer dans SystemDrive : \windows\system32\msigrid.ocx a réussi.

Résolution 6


Supprimer le modèle, puis sélectionnez l’imprimante souhaitée dans la fenêtre Options de l’imprimante (98.220.00) avant de recréer le modèle.
Remarque : Lorsque vous créez un modèle, les informations sur le pilote de l’imprimante de destination pour l’imprimante qui est spécifié dans l’écran Options de l’imprimante (98.220.00) sont codées dans le modèle.