Message d’erreur lorsque vous essayez d’accéder au site Web de Microsoft Dynamics CRM : « Vous n’êtes pas autorisé à afficher cette page »

S’applique à : Microsoft Dynamics CRM 2011Dynamics CRM 4.0

Symptômes


Lorsque vous essayez d’accéder au site Web de Microsoft Dynamics CRM, vous êtes invité pour les informations d’identification de domaine trois fois. Ensuite, le message d’erreur suivant s’affiche :

Vous n’êtes pas autorisé à afficher cette page.


Erreur HTTP 401.1 - non autorisé : Accès refusé en raison d’informations d’identification non valides.

Cause


Ce problème peut se produire lorsque une des conditions suivantes est remplie :
  • L’authentification de Microsoft Internet Information Services (IIS) pour le site Web de Microsoft Dynamics CRM n’est pas configurée pour utiliser l’authentification Kerberos.
  • Le site Web de Microsoft Dynamics CRM est configuré pour utiliser des en-têtes d’hôte.

Résolution


Pour résoudre ce problème, procédez comme suit.

Déterminer l’identificateur utilisé par le site Web de Microsoft Dynamics CRM
  1. Sur le serveur Microsoft Dynamics CRM, cliquez sur Démarrer, sur Outils d’administration, puis cliquez sur Gestionnaire des Services Internet (IIS).
  2. Développez le nom de l’ordinateur de Microsoft Dynamics CRM, puis cliquez sur Sites Web.
  3. Cliquez sur le site Web de Microsoft Dynamics CRM, puis notez la valeur dans la colonne d’identificateur .

    Remarque Si vous avez installé Microsoft Dynamics CRM sur le site Web par défaut, cette valeur est 1.
  4. Vérifiez que l’identificateur de site Web de Microsoft Dynamics CRM. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.
    2. Recherchez la sous-clé de Registre suivante :
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
    3. Cliquez sur le site Webet notez la valeur dans le champ données de la valeur .

      Remarque La valeur semblable à « / LM/W3SVC/1 ». Le dernier numéro est supposé pour être le même que l’identificateur de site Web que vous avez noté à l’étape 3.
Configurez IIS pour utiliser l’authentification Kerberos pour le site Web de Microsoft Dynamics CRM
  1. Cliquez sur Démarrer, sur exécuter, tapez cmd, puis cliquez sur OK.
  2. À l’invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE :
    C:\Inetpub\AdminScripts\adsutil.vbs get w3svc /1/NTAuthenticationProviders
    Remarque Dans cette commande, 1 représente la valeur que vous avez déterminé dans la section « Déterminer l’identificateur utilisé par le site Web de Microsoft Dynamics CRM ».

    Le résultat indique que l’authentification n’est pas définie à ce niveau ou que l’authentification est définie sur NTAuthenticationProviders : (chaîne) « NTLM ». Par conséquent, vous devez définir l’authentification Kerberos.
  3. À l’invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE :
    C:\Inetpub\AdminScripts\adsutil.vbs la valeur w3svc /1/NTAuthenticationProviders « Negotiate, NTLM »
    Remarque Dans cette commande, 1 représente la valeur que vous avez déterminé dans la section « Déterminer l’identificateur utilisé par le site Web de Microsoft Dynamics CRM ».
  4. Pour vérifier que l’authentification Kerberos est définie correctement, tapez la commande suivante à l’invite de commande, puis appuyez sur ENTRÉE :
    C:\Inetpub\AdminScripts\adsutil.vbs get w3svc /1/NTAuthenticationProviders
    Remarque Dans cette commande, 1 représente la valeur que vous avez déterminé dans la section « Déterminer l’identificateur utilisé par le site Web de Microsoft Dynamics CRM ».

    Le résultat est le suivant :
    NTAuthenticationProviders: (STRING) "Negotiate,NTLM" 
  5. Redémarrez le serveur Microsoft Dynamics CRM.
Remarque Vous pouvez utiliser un en-tête d’hôte pour accéder au site Web de Microsoft Dynamics CRM. Si vous faites cela, vous devez également suivre les instructions de cet article de la Base de connaissances Microsoft pour résoudre le problème.