Vous ne pouvez pas déterminer quels champs sont disponibles et les champs qui ne sont pas disponibles lorsque vous ouvrez une boîte de dialogue dans Microsoft Dynamics NAV


Microsoft Business Solutions-Navision 4.0 et Microsoft Navision 4.0 font désormais partie de Microsoft Dynamics NAV 4.0. Toutes les références à Microsoft Business Solutions-Navision ou à Microsoft Navision 4.0 concernent Microsoft Dynamics NAV.
Cet article s’applique à Microsoft Dynamics NAV 4.0 pour toutes les régions.

Symptômes


Lorsque vous ouvrez une boîte de dialogue dans Microsoft Dynamics NAV, vous ne peut pas déterminer quels champs sont disponibles et les champs qui ne sont pas disponibles, car tous les champs disponibles. Ce problème se produit si les conditions suivantes sont remplies :
  • Vous utilisez Microsoft Dynamics NAV sur un ordinateur Windows Vista.
  • Le jeu de couleurs Windows Aero est activé sur l’ordinateur.
Par exemple, ce problème se produit lorsque vous ouvrez la boîte de dialogue Fiche client dans Microsoft Dynamics NAV. Lorsque vous effectuez cette opération, les champs Solde et la Limite de crédit ont la même couleur. Toutefois, le champ Solde doit apparaître estompé, car il n’est pas disponible.

Cause


Ce problème se produit car Microsoft Dynamics NAV utilise les contrôles Windows qui ont une apparence différente lorsque l’ordinateur exécute Windows Vista.

Résolution


Informations sur le correctif

Un correctif pris en charge est désormais disponible auprès de Microsoft. Le correctif résout le problème qui est décrit dans cet article. Appliquez le correctif uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème immédiatement, contactez le Support technique pour Microsoft Dynamics et les produits connexes obtenir le correctif. Vous pouvez ouvrir une session sur le site de Microsoft Dynamics et créer une demande de support. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :Vous pouvez également contacter le Support technique pour Microsoft Dynamics et les produits associés par téléphone au (888) 477-7877.

Remarque Dans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Comment faire pour obtenir le correctif logiciel de Microsoft Dynamics NAV ou mettre à jour des fichiers

Une fois que vous demandez un correctif de Microsoft Dynamics NAV ou un fichier de mise à jour à partir d’un Support technique pour Microsoft Dynamics, un lien hypertexte sera envoyé dans un message électronique pour vous.


Le message électronique contiendra un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel de Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier – Avertissement de sécurité s’ouvre. Puis, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.


Si vous cliquez sur exécuter, les fichiers de démarrer le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers et ensuite fournir le mot de passe.


Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Vous devez ensuite fournir le mot de passe fourni dans le message électronique.


Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment faire pour installer un correctif Microsoft Dynamics NAV ou mettre à jour le fichier

Les mises à jour et correctifs logiciels de plate-forme Microsoft Dynamics NAV sont accessibles sous forme de fichiers unique. Pour installer un correctif Microsoft Dynamics NAV ou une mise à jour, vous devez remplacer les fichiers d’installation de Microsoft Dynamics NAV existantes avec le correctif ou les mise à jour fichiers. Pour ce faire, procédez comme suit.

Microsoft Dynamics NAV 4.0 Service Pack 3

Étape 1 : Remplacer le fichier d’installation du Client Microsoft Dynamics NAV

Dans l’installation du client Microsoft Dynamics NAV, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Dbm.dll4.0.3.25206345,20813-Sep-200720:18x86
Fin.exe4.0.3.252068,119,41613-Sep-200720:18x86
Fin.exe.manifestNe s'applique pas71111-Sep-200721:13Ne s'applique pas
Finhlink.exe4.0.3.25206119,92813-Sep-200720:17x86
Finsql.exe4.0.3.252068,168,56813-Sep-200720:18x86
Finsql.exe.manifestNe s'applique pas71414-Dec-200616:41Ne s'applique pas
Nc_netb.dll4.0.3.2520678,96813-Sep-200720:17x86
Nc_tcp.dll4.0.3.2520683,06413-Sep-200720:17x86
Nc_tcps.dll4.0.3.2520691,25613-Sep-200720:17x86

Pour remplacer les fichiers existants de Microsoft Dynamics NAV, procédez comme suit :
  1. Fermez le Client Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation du Client Microsoft Dynamics NAV.

    Remarque En général, le Client Microsoft Dynamics NAV est installé dans le répertoire suivant :
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
  3. Copiez les fichiers que vous avez téléchargé.
  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation du Client Microsoft Dynamics NAV.
  5. Dans le
    Confirmer le remplacement du fichier
    boîte de dialogue, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Microsoft Dynamics NAV 2009

Étape 1 : Remplacer les fichiers d’installation Client de Microsoft Dynamics NAV Classic

Dans l’installation de Microsoft Dynamics NAV Classic Client, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Dbm.dll6.0.29415.0444,2321-July-20099:19x86
Fin.exe6.0.29415.012,244,7921-July-20099:19x86
Finhlink.exe6.0.29415.0452,4321-July-20099:19x86
Finsql.exe6.0.29415.012,330,8321-July-20099:19x86
Nc_netb.dll6.0.29415.0108,3521-July-20099:19x86
Nc_tcp.dll6.0.29415.0108,3681-July-20099:19x86
Nc_tcps.dll6.0.29415.0153,4081-July-20099:19x86
Ndbcs.dll6.0.29415.01,333,0721-July-20099:19x86
Slave.exe6.0.29415.0161,6161-July-20099:19x86

Pour remplacer les fichiers existants de Microsoft Dynamics NAV, procédez comme suit :
  1. Fermez le Client Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV Classic Client.

    Remarque En général, le Client Microsoft Dynamics NAV Classic est installé dans le répertoire suivant :
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\
  3. Copiez les fichiers que vous avez téléchargé.
  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV Classic Client.
  5. Dans le
    Confirmer le remplacement du fichier
    boîte de dialogue, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Étape 2 : Remplacer les fichiers d’installation Client personnalisé de Microsoft Dynamics NAV

Dans l’installation Client personnalisé de Microsoft Dynamics NAV, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Dundaswinchart.dll5.0.0.16922,733,9041-Jul-20099:19x86
Microsoft.dynamics.framework.patterns.dll1.2.10579.17371,64830-Jun-20097:21x86
Microsoft.dynamics.framework.ui.dll1.2.10579.173654,28030-Jun-20097:21x86
Microsoft.dynamics.framework.ui.mapping.dll1.2.10579.173101,33630-Jun-20097:21x86
Microsoft.dynamics.framework.ui.navigation.dll1.2.10579.17322,49630-Jun-20097:21x86
Microsoft.dynamics.framework.ui.ux2006.dll1.2.10579.17393,0641-Jul-20099:08x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll1.2.10579.17339,8401-Jul-20099:08x86
Microsoft.dynamics.framework.ui.windows.dll1.2.10579.17384,95230-Jun-20097:21x86
Microsoft.dynamics.framework.ui.winforms.controls.dll1.2.10579.1732,067,44030-Jun-20097:21x86
Microsoft.dynamics.framework.ui.winforms.dll1.2.10579.173633,82430-Jun-20097:21x86
Microsoft.dynamics.nav.client.builder.dll1.2.10579.173166,7921-Jul-20099:08x86
Microsoft.dynamics.nav.client.exe6.0.29415.0142,2001-Jul-20099:08x86
Microsoft.dynamics.nav.client.interop.communicator.dll6.0.29415.076,7041-Jul-20099:08x86
Microsoft.dynamics.nav.client.serviceconnection.dll6.0.29415.076,7041-Jul-20099:08x86
Microsoft.dynamics.nav.client.ui.dll6.0.29415.0428,9201-Jul-20099:08x86
Microsoft.dynamics.nav.client.winforms.dll6.0.29415.0277,3841-Jul-20099:08x86
Microsoft.dynamics.nav.client.winforms.tlb6.0.29415.02,6521-Jul-20094:37Ne s'applique pas
Microsoft.dynamics.nav.language.dllNe s'applique pas1,866,6161-Jul-20099:08x86
Microsoft.dynamics.nav.types.dll6.0.29415.0383,8561-Jul-20099:08x86
Microsoft.office.interop.outlook.dll10.0.4504.0396,1521-Jul-20099:08x86
Pour remplacer les fichiers existants, procédez comme suit :
  1. Fermez le Client personnalisé de Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation Client personnalisé de Microsoft Dynamics NAV. En général, le Client personnalisé de Microsoft Dynamics NAV est installé dans le répertoire suivant :
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client
  3. Copiez les fichiers que vous avez téléchargé.
  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation Client personnalisé de Microsoft Dynamics NAV.
  5. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Étape 3 : Remplacer les fichiers d’installation de Microsoft Dynamics NAV Server

Dans l’installation de Microsoft Dynamics NAV Server, remplacez les fichiers suivants en utilisant le fichier de correctif ou la mise à jour.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Httpcfg.exe5.2.3790.022,3521-Jul-20099:08x86
Microsoft.dynamics.nav.language.dll6.0.29415.01,865,6001-Jul-20099:08x86
Microsoft.dynamics.nav.ncl.dll6.0.29415.0489,3361-Jul-20099:08x86
Microsoft.dynamics.nav.server.exe6.0.29415.0137,0881-Jul-20099:08x86
Microsoft.dynamics.nav.server.exe.configNe s'applique pas21117-Jun-20093:29Ne s'applique pas
Microsoft.dynamics.nav.service.dll6.0.29415.0120,7041-Jul-20099:08x86
Microsoft.dynamics.nav.service.runtime.dll6.0.29415.063,3761-Jul-20099:08x86
Microsoft.dynamics.nav.service.webservices.dll6.0.29415.0128,9201-Jul-20099:08x86
Microsoft.dynamics.nav.types.dll6.0.29415.0382,8401-Jul-20099:08x86
Microsoft.dynamics.nav.watson.dll6.0.29415.038,7841-Jul-20099:08x86
Nclcsrt.etxNe s'applique pas87,2791-Jul-200912:52Ne s'applique pas
Nclcsrt.stxNe s'applique pas81,0831-Jul-200912:52Ne s'applique pas
Nclcsrts.dllNe s'applique pas1,394,5121-Jul-20099:19x86
Ndbcs.dll6.0.29415.01,333,0721-Jul-20099:19x86
Pour remplacer les fichiers, procédez comme suit :
  1. Arrêtez le service serveur de Microsoft Dynamics NAV.
  2. Recherchez le répertoire d’installation de Microsoft Dynamics NAV server service.




    Remarque En règle générale, le service serveur de Microsoft Dynamics NAV est installé dans le répertoire suivant :
    C:\Program files\Microsoft Dynamics NAV\60\Service
  3. Copiez les fichiers que vous avez téléchargé.
  4. Collez les fichiers que vous avez téléchargé dans le répertoire d’installation de Microsoft Dynamics NAV server service.
  5. Cliquez sur Oui pour remplacer les fichiers dans le répertoire.
  6. Démarrez le service serveur de Microsoft Dynamics NAV.

Étape 4 : Remplacer courantes fichiers

Dans le dossier fichiers communs, remplacez les fichiers suivants.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Customization.xmlNe s'applique pas1,11517-Jun-20093:24Ne s'applique pas
Msoutl.olb11.0.5510.0200,24817-Jun-20093:24Ne s'applique pas
Pour remplacer les fichiers existants, procédez comme suit :
  1. Recherchez le répertoire de fichiers communs :
    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync
  2. Copiez les fichiers que vous avez téléchargé.
  3. Collez les fichiers que vous avez téléchargé dans le répertoire fichiers communs.
  4. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Étape 5 : Les fichiers de remplacement Windows\System32

Dans le dossier Windows\System32, remplacez les fichiers suivants.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Cdo.dll6.5.7940.0775,4801-Jul-20099:19x86
Gapi32.dll6.5.7940.071,4881-Jul-20099:19x86
Pour remplacer les fichiers existants, procédez comme suit :
  1. Recherchez le répertoire Windows\System32 :
    C:\Windows\System32
  2. Copiez les fichiers que vous avez téléchargé.
  3. Collez les fichiers que vous avez téléchargé dans le répertoire fichiers communs.
  4. Lorsque vous y êtes invité, cliquez sur Oui pour remplacer les fichiers dans le répertoire d’installation.

Conditions préalables

Vous devez disposer d’un des produits suivants est installé pour appliquer ce correctif :
  • Microsoft Dynamics NAV 4.0 SP3 avec le correctif KB 940718
  • Microsoft Dynamics NAV 2009

Informations sur la suppression

Vous ne pouvez pas supprimer ce correctif.

Nécessite un redémarrage


Si vous êtes invité à redémarrer l’ordinateur, vous devez redémarrer l’ordinateur après avoir appliqué ce correctif.

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft