Vous pouvez recevoir une erreur « un problème est survenu durant la communication avec le serveur OLE Microsoft Access » de message lorsque vous essayez d’incorporer ou lier un document Word dans Access


Important Cet article contient des informations vous expliquant comment baisser les paramètres de sécurité ou comment désactiver certaines fonctions de sécurité sur un ordinateur. Vous pouvez apporter ces modifications pour contourner un problème spécifique. Cet article contient des informations vous expliquant comment baisser les paramètres de sécurité ou comment désactiver certaines fonctions de sécurité sur un ordinateur. Si vous implémentez cette solution de contournement, prendre toutes les mesures appropriées pour protéger votre système.
Niveau débutant : Requiert la connaissance de l’interface utilisateur sur les ordinateurs mono-utilisateur.


Cet article s’applique à un fichier de base de données (.mdb) Microsoft Access ou dans un fichier de base de données (.accdb) Microsoft Access.

Symptômes


Lorsque vous essayez de lier ou d’incorporer un document Microsoft Word dans Microsoft Access, vous pouvez recevoir un message d’erreur semblable au message d’erreur suivant :
Un problème est survenu durant la communication avec le serveur OLE Microsoft Access. Essayez une ou plusieurs des opérations suivantes :
  1. Assurez-vous que vous êtes connecté au serveur réseau où se trouve l’application serveur OLE.
  2. Fermez le serveur OLE et redémarrez-le en dehors de Microsoft Access.
  3. Réinstallez le serveur OLE pour vous assurer qu’il est enregistré.
Remarque pour les utilisateurs qui exécutent Microsoft Office Access 2007
Pour déterminer le numéro unique qui est associé au message qui s’affiche, appuyez sur CTRL + MAJ + I. Le numéro suivant apparaît dans le coin inférieur droit de ce message :
1200553

Cause


Ce problème peut se produire si vous disposez de Norton AntiVirus 2000, Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004 est installé sur votre ordinateur. Ce problème peut également se produire si vous avez exécuté LiveUpdate de Norton et que vous avez installé la mise à jour du blocage de scripts pour Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004.

Résolution


Important ces étapes peuvent accroître les risques de sécurité. Ces étapes peuvent également rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d’utilisateurs malintentionnés ou de logiciels malveillants comme les virus. Nous recommandons le processus décrit dans cet article pour permettre aux programmes de fonctionner comme ils sont conçus pour ou pour implémenter des fonctionnalités de programme spécifiques. Avant d’apporter ces modifications, nous vous recommandons d’évaluer les risques associés à l’implémentation de ce processus dans votre environnement particulier. Si vous choisissez d’implémenter ce processus, prenez toutes les mesures appropriées pour protéger votre système. Nous vous conseillons d’utiliser ce processus uniquement si vous avez vraiment besoin. Pour plus d’informations sur les virus informatiques, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

129972 virus informatiques : description, prévention et récupération

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

Désactiver le blocage de Script de Norton AntiVirus

Avertissement Cette solution de contournement peut rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d’utilisateurs malintentionnés ou de logiciels malveillants comme les virus. Nous ne recommandons pas cette solution de contournement, mais nous fournissons cette information afin que vous puissiez l'implémenter à votre convenance. Utilisez cette solution de contournement à vos risques et périls.

Remarque Un programme antivirus est conçu pour aider à protéger votre ordinateur contre les virus. Vous ne devez pas télécharger ou ouvrir des fichiers provenant de sources non fiables, visiter des sites Web que ne pas faire confiance, ou ouvrir les pièces jointes lorsque votre antivirus est désactivé.

Remarque Norton AntiVirus 2000 ne prend pas en charge la fonctionnalité de blocage de Script. Si vous utilisez Norton AntiVirus 2000, consultez la méthode 2.

Pour Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004, procédez comme suit :
  1. Démarrez Norton AntiVirus.
  2. Cliquez sur Options.
  3. Si un menu apparaît lorsque vous cliquez sur Options, cliquez sur Norton AntiVirus .

    La boîte de dialogue Options de Norton AntiVirus s’affiche.
  4. Cliquez sur le blocage de Script.
  5. Désactivez la case à cocher Activer le blocage de Script (recommandé) .
  6. Cliquez sur OK.
Remarque Vous pouvez réactiver le blocage de Script une fois que vous avez fini d’utiliser Access.

Pour plus d’informations, consultez la documentation de votre produit Norton ou visitez le site Web de Symantec suivant :Si ce lien ne fonctionne pas, consultez la Base de connaissances pour Symantec sur le site Web de Symantec suivant et recherchez 2001041119095106 d’ID de Document :

Méthode 2

Désactiver Norton AntiVirus pour Office plug-in pour Microsoft Office

Avertissement Cette solution de contournement peut rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d’utilisateurs malintentionnés ou de logiciels malveillants comme les virus. Nous ne recommandons pas cette solution de contournement, mais nous fournissons cette information afin que vous puissiez l'implémenter à votre convenance. Utilisez cette solution de contournement à vos risques et périls.

Remarque un programme antivirus est conçu pour aider à protéger votre ordinateur contre les virus. Vous ne devez pas télécharger ou ouvrir des fichiers provenant de sources non fiables, visiter des sites Web que ne pas faire confiance, ou ouvrir les pièces jointes lorsque votre antivirus est désactivé.

Remarque Cette méthode désactive le plug-in d’analyse antivirus installé au cours de l’installation de Norton AntiVirus. Ce plug-in analyse les documents pour les infections de virus de macro dans les programmes Office. Lorsque ce plug-in est désactivé, Norton AntiVirus n’analyse pas les documents ouverts. Toutefois, la fonctionnalité de protection automatique de Norton AntiVirus fournit toujours sur à assurer une protection en analysant tout fichier exécuté, télécharger, ouvrir, créer ou supprimer. Pour plus d’informations sur Norton AntiVirus, consultez la documentation de votre produit.

Pour Norton AntiVirus 2002, Norton AntiVirus 2003 et Norton AntiVirus 2004, procédez comme suit :
  1. Démarrez Norton AntiVirus.

    Remarque Si Norton AntiVirus fait partie de Norton SystemWorks (NSW) ou Norton Internet Security (NIS), lancez NSW ou NIS, puis cliquez sur Norton AntiVirus.
  2. Cliquez sur Options, puis cliquez sur divers.
  3. Dans la section comment protéger les documents Microsoft Office , cliquez sur Activer Office plug-in.

    Cela désactive le plug-in activer Office.
  4. Cliquez sur OK, puis quittez Norton Antivirus.
Pour Norton AntiVirus 2001, procédez comme suit :
  1. Démarrez Norton AntiVirus 2001.

    Remarque Si Norton AntiVirus fait partie de Norton SystemWorks (NSW) ou Norton Internet Security (NIS), lancez NSW ou NIS, puis cliquez sur Norton AntiVirus.
  2. Cliquez sur Options, puis cliquez sur Général.
  3. Dans la section Microsoft Office 2000 de plug-in , cliquez sur Activer le plug-in.

    Cela désactive la plug-in activer.
  4. Cliquez sur OK, puis quittez Norton Antivirus.
Pour Norton AntiVirus 2000, procédez comme suit :
  1. Cliquez sur Démarrer, puis cliquez sur exécuter.
  2. Dans la zone Ouvrir , tapez une des commandes suivantes et appuyez sur ENTRÉE.

    La commande que vous tapez dépend de votre système d’exploitation et le logiciel que vous exécutez. Veillez à inclure les guillemets lorsque vous tapez les commandes.
    • Pour Windows 95 ou Windows 98 avec Norton AntiVirus installé, tapez la commande suivante :
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton AntiVirus\OfficeAV.dll" 
    • Pour Windows 95 ou Windows 98 avec SystemWorks installé, tapez la commande suivante :
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton SystemWorks\Norton AntiVirus\OfficeAV.dll" 
    • Pour Windows NT ou Windows 2000 avec Norton AntiVirus installé, tapez la commande suivante :
      "C:\Winnt\System32\Regsvr32" -U "C:\Program Files\Navnt\OfficeAV.dll" 
Si la commande réussit, le message d’erreur suivant s’affiche :

DllUnregisterServer dans C:\Program Files\Norton AntiVirus\OfficeAV.dll a réussi.


Si la commande n’est pas correcte, recherchez sur votre disque dur pour le fichier OfficeAV.dll. Le chemin d’accès du fichier OfficeAV.dll sur votre ordinateur peut être différent du chemin d’accès dans le message. Lorsque vous recherchez le fichier OfficeAV.dll, mémorisez l’emplacement du fichier OfficeAV.dll et répéter ces étapes. Cependant, cette fois, changez la partie « C:\Program Files\Norton AntiVirus\OfficeAV.dll » de la commande à l’étape 2 le chemin d’accès du fichier OfficeAV.dll sur votre ordinateur.

Pour plus d’informations, consultez la documentation de votre produit Norton ou visitez le site Web de Symantec suivant :

Si ce lien ne fonctionne pas, visitez la Base de connaissances pour Symantec sur le site Web de Symantec suivant, puis recherchez le Document numéro 1999091612160606 :

Méthode 3

Réinstallez Norton Antivirus

Pour toutes les versions de Norton AntiVirus, procédez comme suit :
  1. Supprimez Norton AntiVirus, puis redémarrez votre ordinateur.
  2. Démarrez Word.
  3. Dans le menu Aide, cliquez sur Détecter et réparer.
  4. Réinstallez Norton AntiVirus, puis redémarrez votre ordinateur.

Plus d'informations


Procédure pour reproduire le problème

  1. Installez Norton AntiVirus 2000.
  2. Créer une nouvelle base de données Access 2000.
  3. Créez la table suivante, puis enregistrez la table sous Table1 :
       Table: Table1
    ----------------------------
    Field Name: ID
    Data Type: AutoNumber
    Indexed: Yes (No Duplicates)

    Field Name: Test
    Data Type: OLE Object

    Table Properties: Table1
    ------------------------
    PrimaryKey: ID

  4. Créer un formulaire qui est basé sur la table Table1. Enregistrez ce formulaire sous le nom de TestOLE.
  5. Ouvrez le formulaire TestOLE en mode formulaire.
  6. Cliquez sur le champ Test , puis cliquez sur Insérer un objet.
  7. Dans la boîte de dialogue Insérer un objet , cliquez sur à partir d’un fichier.
  8. Tapez le chemin d’accès d’un document Word, ou cliquez sur Parcourir pour sélectionner un document Word.
  9. Dans la boîte de dialogue Insérer un objet , cliquez sur OK pour fermer la boîte de dialogue.

    Vous recevez un des messages d’erreur qui est mentionné dans la section « Symptômes ».

Références


Pour plus d’informations sur le plug-in Norton AntiVirus pour Office, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

329820 comment utiliser des programmes Office avec le plug-in Norton AntiVirus pour Office

Microsoft fournit des informations pour contacter des sociétés tierces afin de vous aider à obtenir une aide technique. Ces coordonnées peuvent changer sans préavis. Microsoft ne garantit pas l'exactitude des informations de contact de ces tiers.
Pour plus d’informations sur les fournisseurs de matériels et de logiciels, les informations de contact, visitez le site Web de Microsoft à l’adresse suivante :

Les produits tiers dont traite cet article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft ne fait aucune garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.