Outlook demande un mot de passe et n’utilise pas l’authentification moderne pour se connecter à Microsoft 365

Numéro de l’article d’origine dans la base de connaissances : 3126599

Symptômes

Prenons les cas de figure suivants.

Scénario 1 :

Microsoft Outlook se connecte à votre boîte aux lettres principale dans un serveur Exchange local à l’aide de RPC, et il se connecte également à une autre boîte aux lettres située dans Microsoft 365.

Scénario 2 :

Vous migrez votre boîte aux lettres vers Microsoft 365 à partir d’un serveur Exchange auquel Outlook se connecte à l’aide de RPC.

Dans les deux cas, vous êtes invité à saisir des informations d’identification. De plus, Outlook n’utilise pas l’authentification moderne pour se connecter à Microsoft 365. Une fois vos informations d’identification saisies, elles sont transmises à Microsoft 365 et non à un jeton.

Cause

Outlook restreint les méthodes d’authentification disponibles à celles prises en charge par RPC. En l’occurence, l’authentification moderne n’est pas proposée.

Résolution

Importante

Suivez attentivement les étapes de cette section. Des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Avant de modifier le Registre, sauvegardez-le pour restauration en cas de problèmes.

Créez la clé de Registre suivante pour forcer Outlook à utiliser une méthode d’authentification plus récente pour les services web, comme EWS et la découverte automatique. Nous recommandons aux utilisateurs de forcer Outlook à utiliser l’authentification moderne.

  1. Quittez Outlook.

  2. Démarrez l’Éditeur du Registre à l’aide de l’une des procédures suivantes en fonction de votre version de Windows :

    • Windows 10, Windows 8.1 et Windows 8 : appuyez sur la touche Windows + R pour ouvrir la boîte de dialogue Exécuter. Saisissez regedit.exe, puis appuyez sur Entrée.
    • Windows 7 : cliquez sur Démarrer, saisissez regedit.exe dans la zone de recherche, puis appuyez sur Entrée.
  3. Dans l’Éditeur du Registre, recherchez la sous-clé de Registre suivante et cliquez dessus :

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  5. Saisissez AlwaysUseMSOAuthForAutoDiscover, puis appuyez sur Entrée.

  6. Cliquez avec le bouton droit sur AlwaysUseMSOAuthForAutoDiscover, puis cliquez sur Modifier.

  7. Dans la zone Données de la valeur, tapez 1, puis cliquez sur OK.

  8. Fermez l’Éditeur du Registre.

Informations supplémentaires

Avant d’utiliser cette clé de Registre et si vous exécutez Office 2013, assurez-vous que les mises à jour du 12 décembre 2015 ou ultérieures sont installées pour Outlook et MSO.

3114349 Mise à jour du 8 décembre 2015 pour Outlook 2013 (KB3114349)

3114333 Mise à jour du 8 décembre 2015 pour Office 2013 (KB3114333)

Remarque

Office 2016 ne nécessite pas de mise à jour pour que cette clé de Registre fonctionne.

Pour plus d’informations sur RPC, consultez l’article Le support de RPC sur HTTP dans Microsoft 365 prend fin le 31 octobre 2017.