Message d’erreur lorsque vous accédez à un périphérique de stockage USB après la reprise de l’interruption

Cet article fournit une solution à une erreur qui se produit lorsque vous accédez à un périphérique de stockage USB après la reprise de l’interruption.

Applicabilité : Windows 10 - Toutes les éditions
Numéro de la base de connaissances d’origine : 323754

Symptômes

Si vous essayez d’utiliser un périphérique de stockage USB (Universal Serial Bus) immédiatement après la suspension de votre ordinateur, le message d’erreur suivant peut s’afficher :

X :\ lecteur n’est pas accessible. Impossible d’effectuer la requête en raison d’une erreur d’appareil d’E/S.

Vous continuez à recevoir le message d’erreur lorsque vous essayez d’utiliser le périphérique de stockage USB jusqu’à ce que vous supprimiez et rattachez l’appareil, ou que vous redémarrant l’ordinateur. Ce problème peut se produire avec n’importe quel périphérique de stockage USB, tel que des lecteurs de disquettes, des disques durs ou des lecteurs de CD-ROM.

Cause

Ce problème se produit avec certains périphériques de stockage USB 1.x qui sont connectés à un contrôleur USB 2.0 dans Windows 2000 avec la mise à jour USB 2.0 installée.

Résolution

Pour résoudre ce problème, obtenez et installez le fichier Usbhub.sys mis à jour à partir du correctif logiciel.

Solution de contournement

Pour contourner ce problème, attendez environ 10 secondes après avoir repris votre ordinateur avant d’essayer d’utiliser le périphérique de stockage USB 1.x.

Si vous n’utilisez aucun périphérique USB 2.0 sur l’ordinateur, une autre solution consiste à désactiver le contrôleur USB 2.0 dans Gestionnaire de périphériques. Une fois que vous avez désactivé le contrôleur USB 2.0, le problème décrit plus haut dans cet article avec les appareils USB 1.x ne se produit pas.

Statut

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés au début de cet article.

Plus d’informations

Après avoir appliqué le correctif logiciel mentionné plus haut dans cet article, les comportements suivants changent :

  • Si vous essayez d’utiliser un périphérique de stockage USB 1.x immédiatement après avoir repris votre ordinateur, le problème peut toujours se produire. Toutefois, le problème ne se produit pas si vous essayez ensuite d’utiliser à nouveau le périphérique de stockage dans quelques secondes.

  • Peu de temps après avoir repris votre ordinateur, vous pouvez recevoir un message De suppression dangereuse de l’appareil qui mentionne l’appareil USB 1.x. Vous pouvez fermer cette boîte en toute sécurité. Ce message se produit en raison d’un problème de minutage Windows qui implique l’alimentation de la pile de pilotes du contrôleur complémentaire USB et de la pile ehCI (Enhanced Host Controller Interface) après la reprise de l’interruption.

    Si le pilote du hub racine du contrôleur compagnon s’allume en premier, les périphériques USB 1.x qui étaient attachés aux ports du hub racine lorsque l’ordinateur est entré en suspension ne sont plus attachés. Par conséquent, le pilote informe Plug-and-Play que l’appareil a été supprimé. Cela se produit parce que les appareils ont été routés vers le contrôleur EHCI lorsque l’indicateur de configuration a été défini, mais ils ne sont pas actuellement attachés au contrôleur compagnon.

    Lorsque le pilote du hub racine du contrôleur EHCI (pour USB 2.0) s’allume ultérieurement, les ports du hub racine sont réinitialisés et les périphériques USB 1.x sont routés vers les contrôleurs compagnons. Le hub du contrôleur compagnon énumère ensuite à nouveau les appareils. Ils sont ensuite détectés et deviennent fonctionnels.

    Cela n’affecte pas les appareils USB 2.0, car ils restent toujours attachés au contrôleur EHCI.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.