Les erreurs courantes et les étapes de dépannage pour les problèmes de connectivité réseau dans Microsoft Dynamics Retail Management System Store Operations ou dans Microsoft Dynamics Retail Management System Headquarters


Symptômes


Dans Microsoft Dynamics Retail Management System Store Operations ou dans Microsoft Dynamics Retail Management System Headquarters, les messages d’erreur suivants s’affiche :
Message d'erreur 1
Perdue de la connexion de base de données, l’application peut être fermé erreur #-2147467259 [DBNETLIB] [ConnectionWrite (WrapperWrite()).] Erreur de réseau générale. Consultez la documentation de réseau. (Source : fournisseur Microsoft OLE DB pour SQL Server) (État de SQL : 08S01) (Erreur native : 11) Aucun fichier d’aide disponible Sélectionnez GETDATE() comme CurrentDateTime

Remarque L’instruction de Microsoft SQL Server Sélectionnez réelle à la fin de ce message d’erreur peut être plus longue et plus complexe. Cette instruction peut faire référence à la table des commandes, la table OrderEntry ou la table des clients. Vous devez inclure l’instruction finale lors de la recherche et la résolution de ce problème dans la mesure où l’instruction peut vous aider à identifier ce problème. L’instruction indique les tables que le programme a accédé lors de la déconnexion.
Message d'erreur 2
SQL Server n’existe pas ou l’accès refusé.
Message d'erreur 3
ConnectionOpen (Connect())
Message d’erreur 4
Erreur : Impossible de supprimer la table '#temp', car il n’existe pas dans le catalogue système.
Message d’erreur 5
Erreur d’exécution '5' : argument ou appel de procédure non valide
Message d’erreur 6
' Erreur de réseau générale, erreur d’exécution 5'

Cause


Opérations de magasin et le siège nécessite des connexions fiables entre le serveur et les ordinateurs clients. Les erreurs mentionnées dans la section » Symptômes"se rapportent à des problèmes d’installation de réseau ou à des problèmes d’installation de matériel. Les erreurs ne sont pas liées à des opérations de la banque ou au siège social.

Problèmes de connectivité réseau peuvent avoir des causes diverses. Toutefois, ces problèmes ont généralement une ou plusieurs des causes suivantes :
  • Cartes réseau qui sont configurés de manière incorrecte
  • Commutateurs sont définies de manière incorrecte
  • Matériel défectueux
  • Problèmes liés aux pilotes
Certains problèmes de connectivité sont intermittentes et ne pointent pas clairement à une cause spécifique.

La liste suivante indique les causes des problèmes de connectivité réseau :
  1. Une connexion par câble endommagé ou peu fiables, une carte réseau défectueuse ou un concentrateur a échoué
  2. Un pilote de réseau incorrect ou des paramètres réseau incorrects
  3. L’installation d’une version antérieure de MDAC sur chaque station de travail que sur le serveur
  4. Fonctionnalités de désactiver la carte réseau lors de l’exécution de Microsoft Dynamics RMS d’économie d’énergie
  5. Un conflit d’adresse IP
  6. Dans l’utilitaire réseau du Client, les paramètres qui sont configurés de manière incorrecte
  7. Dans l’utilitaire réseau du serveur, les paramètres qui sont configurés de manière incorrecte
  8. Un manque de disponible de bande passante réseau, car les ressources système sont à l’aide de toute la bande passante réseau disponible
  9. Paramètres incorrects pour un mode de paiement spécifique, pour un périphérique ou d’un Registre
  10. Une configuration de réseau sans fil
  11. Est en conflit avec les paramètres pour les compléments tiers ou des personnalisations

Résolution


Pour résoudre ce problème, utilisez la résolution correspondant à ce problème de connectivité réseau appropriée qui est répertorié dans la section « Cause ».

Résolution 1

  1. Si ce problème se produit uniquement sur un ordinateur particulier, le problème peut impliquer le matériel installé sur cet ordinateur particulier. Examinez le câble pour vous assurer que le câble réseau est branché. Si vous devez remplacer la carte réseau, remplacez-le en utilisant le même type de carte.
  2. Si ce problème se produit sur plusieurs ordinateurs, examinez les composants réseau qui sont connectent les ordinateurs. Assurez-vous que le routeur se trouve. Échanger les câbles réseau, ou remplacez les câbles anciens nouveaux câbles.
  3. Sur toutes les stations de travail, vérifiez que les paramètres de partage d’imprimantes et de fichiers sont activées. Pour vérifier les paramètres, procédez comme suit :
    1. Cliquez sur Démarrer, puis cliquez sur Panneau de configuration.
    2. Double-cliquez sur connexions réseau.
    3. Cliquez sur Réseau local (LAN), puis cliquez sur Propriétés.
    4. Assurez-vous que la case à cocher imprimante et fichier partagés pour les réseaux Microsoft est sélectionnée.

Résolution 2

De nombreuses cartes utilisent des pilotes qui tentent de détecter automatiquement les paramètres de réseau. Ces paramètres incluent le type de média, connecteur de médiaet duplex. Parfois, les paramètres automatiques sont détectés correctement. Dans ce cas, vous devrez peut-être modifier manuellement les paramètres. Le paramètre duplex requiert généralement des modifications manuelles. Si les paramètres par défaut du pilote ne fonctionnent pas, essayez de modifier manuellement chaque paramètre un à la fois. Permet d’afficher les résultats après chaque modification.

Résolution 3

Vérifiez que la dernière version de MDAC est installée sur chaque station de travail. Vous pouvez déterminer la version de MDAC que vous exécutez en examinant le Registre. Les informations de version se trouvent dans la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess\FullInstallVer
Pour examiner le Registre, procédez comme suit :

  1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.
  2. Dans le volet de Navigation, recherchez la sous-clé suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess
  3. Dans le volet de résultats, recherchez la valeur de FullInstallVer et la valeur de Version dans la colonne nom. Ces clés ont les informations de version dans la colonne de données .

    Remarque Un composant MDAC peut être endommagé ou manquant. Vous serez peut-être en mesure de résoudre le problème en réinstallant MDAC. Pour rechercher et télécharger la dernière version de MDAC, visitez le site Web de Microsoft à l’adresse suivante :
    http://support.microsoft.com/select/?target=hub

Résolution 4

Économie d’énergie fonctionnalités dans Microsoft Windows peut désactiver à la carte réseau lorsque Store Operations or Headquarters est en cours d’exécution. Périodiquement, ils accèdent à l’ordinateur serveur de base de données pour les programme licence horodateurs de mettre à jour. Par conséquent, les programmes nécessitent une connexion réseau.

Pour résoudre ce problème, vous devez désactiver toutes les fonctionnalités qui sont dans le BIOS et le système d’exploitation d’économie d’énergie. Vérifiez les paramètres d’alimentation de l’ordinateur et de la carte réseau. Assurez-vous que l’ordinateur n’est pas configuré pour désactiver la carte réseau pour économiser l’énergie. Pour accéder aux paramètres d’alimentation de la carte réseau, procédez comme suit :
  1. Cliquez sur Démarrer, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Outils d’administration, puis double-cliquez sur Gestion de l’ordinateur.
  3. Cliquez sur Gestionnaire de périphériques, développez le dossier de la carte réseau, droit sur le composant de la carte, puis cliquez sur Propriétés.
  4. Cliquez sur l’onglet Gestion de l’alimentation .
  5. Désactivez la case à cocher Autoriser l’ordinateur à éteindre ce périphérique pour économiser l’énergie .

Résolution 5

Si vous utilisez une adresse IP fixe et TCP/IP, assurez-vous qu’aucun deux ordinateurs sur le réseau n’ont la même adresse IP. Utilisez la commande ping ou la ipconfig /all pour vérifier que vous n’utilisez pas la même adresse IP sur plusieurs ordinateurs. Pour déterminer l’adresse IP des ordinateurs sur le réseau et pour vérifier que vous pouvez envoyer entre le serveur et les ordinateurs clients, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez cmd, puis cliquez sur OK.
  2. Type de ipconfig/all, puis cliquez sur OK.
  3. Exécutez ping sur le serveur à partir de l’ordinateur qui a des erreurs de connectivité à l’aide de l’adresse IP et le nom de l’ordinateur. Exécutez ping sur l’ordinateur qui comporte des erreurs de connectivité du serveur à l’aide de l’adresse IP et le nom de l’ordinateur. Par exemple, à l’invite de commandes, tapez ping < nom_serveur >.

    Remarques
    • Dans cette commande, < nom_serveur > représente le nom réel de l’ordinateur que vous essayez d’exécuter la commande ping.
    • Vous pouvez également utiliser la commande Ping – T pour exécuter une commande ping constante sur le réseau. Vous pouvez exécuter cette commande toute la journée pour consigner tous les paquets de voyage à partir de la station de travail sur le serveur. Pour rechercher les délais d’attente, procédez comme suit :
      1. Avec le bouton droit n’importe où dans la fenêtre d’invite de commandes, puis cliquez sur Rechercher.
      2. Dans la boîte de dialogue Rechercher , tapez Request Timed Out.
      La liste des délais d’expiration indique combien de connexion gouttes s’est produite lors de la session ping. Par exemple, à l’invite de commandes, tapez Ping – T < nom_serveur >.
      Remarque Dans cette commande, < nom_serveur > représente le nom réel de l’ordinateur que vous essayez d’exécuter la commande ping.

Résolution 6

Vérifiez les paramètres de l’utilitaire réseau Client. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Tous les programmes, pointez sur Microsoft Dynamics RMS, puis cliquez sur Utilitaire réseau du Client.
  2. Examinez l’onglet Général . Si TCP/IP est répertorié comme un protocole désactivé, déplacez la liste dans le volet de protocole activé de TCP/IP. En outre, assurez-vous que TCP/IP est répertorié en premier.
  3. Il est recommandé que vous ajoutez un alias à l’onglet Alias . Pour ce faire, procédez comme suit :
    1. Cliquez sur l’onglet Alias , puis cliquez sur Ajouter.
    2. Recherchez le serveur qui exécute une instance de Microsoft SQL Server qui est à l’écoute des clients des Sockets TCP/IP. Spécifiez un nom unique pour ce serveur. Vérifiez que la case à cocher TCP/IP est activée.
    3. Dans la zone serveur , spécifiez l’instance de SQL Server qui est à l’écoute des clients des Sockets TCP/IP.

      Remarque Ce nom de cette instance est en général le nom du serveur. Toutefois, le nom dépend de la configuration de SQL sur le serveur. Si le nom d’une instance de SQL Server est le même que le nom du serveur, nous vous recommandons d’utiliser l’adresse IP du serveur au lieu du nom.
    4. Sous l’onglet Bibliothèques réseau , rechercher une ligne nommée dans la colonne de la Bibliothèque réseau TCP/IP et recherchez le fichier Dbnetlib.dll.

      Remarque Le fichier Dbnetlib.dll est le fichier de la bibliothèque associée. Si le fichier Dbnetlib.dll est manquant, vous pouvez copier le fichier à partir d’un autre ordinateur, ou vous pouvez télécharger le fichier en cliquant sur le site Web suivant :

      https://mbs.microsoft.com/downloads/customer/dbnetlib.zip
    5. Copiez le fichier Dbnetlib.dll dans le dossier suivant sur le disque dur de l’ordinateur client :

      C:\Windows\System32


    Remarque Vous devez décompresser ce fichier avant de le copier dans le dossier System32.

Résolution 7

Vérifiez les paramètres dans l’utilitaire réseau du serveur sur l’ordinateur serveur. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuteret tapez
    svrnetcn.
  2. Examinez l’onglet Général . Si TCP/IP est répertorié comme un protocole désactivé, déplacez la liste dans le volet de protocole activé de TCP/IP.

Résolution 8

Effectuer le suivi de l’heure de la journée lorsque des erreurs se produisent. Les erreurs peuvent se produire à la fois cohérent tout au long de la journée ou pendant toute la semaine, pour diverses raisons. Par exemple, le serveur de base de données peut être très occupé à traiter d’autres tâches. Ou la bande passante réseau peut être saturée. Déterminer si autres tâches planifiées, les sauvegardes, les mises à jour ou les outils de nettoyage sont en cours d’exécution sur le système. Surveiller l’utilisation des ressources serveur et l’utilisation des ressources réseau pour déterminer si le problème est lié à une demande importante sur les ressources système.

Résolution 9

Suivre les processus qui sont terminées dans Store Operations ou Headquarters lorsque ce problème se produit. Fréquemment, les erreurs de déconnexion apparaîtront pendant le processus d’appel d’offres dans PDV des opérations de banque. Le problème peut impliquer une offre spécifique, les périphériques ou un périphérique qui est accessible par un seul type de mode de paiement.

Déterminer quels périphériques sont accessibles lors de l’échec. Désactivez tous les périphériques. Ensuite, activez chaque périphérique un par un jusqu'à ce que les erreurs s’affichent à nouveau. Heures de pointe magasin, ce type de résolution des problèmes peut être difficile d’effectuer ou peut être inopportune la mise. Toutefois, ce type d’incident peut être le seul moyen pour trouver la cause du problème.

En outre, posez-vous les questions suivantes :
  • Sont tous les périphériques identique ou différente dans l’ensemble de la banque ?
  • Ne les erreurs de Registre qu’une seule expérience déconnexion ou les erreurs semblent se produisent régulièrement tout au long de tous les registres ?
  • Le problème suit les périphériques ou qu’il reste sur la caisse enregistreuse ?
Si les erreurs s’affichent sur un seul Registre, essayez de remplacer les périphériques qui se trouvent sur ce Registre avec les périphériques qui se trouvent sur une autre caisse enregistreuse et qui n’ont pas d’erreurs.

La source d’alimentation d’un périphérique est connue pour provoquer des erreurs similaires. Par conséquent, considérez que le périphérique s’exécute sur une source d’alimentation externe, ou si le périphérique est alimenté à partir de l’ordinateur. En fonction de l’ordinateur, et si le périphérique utilise l’ordinateur comme une source d’alimentation, certains périphériques peuvent épuiser la puissance disponible de l’ordinateur. Drain de cette puissance ralentit les performances.

Résolution de 10

Envisagez si Store Operations or Headquarters est configuré dans un environnement de réseau sans fil.

Remarque Nous ne permettent pas l’utilisation de réseaux sans fil avec Store Operations ou Headquarters.

Certains réseaux sans fil n’est peut-être pas aussi stable que les réseaux câblés. Store Operations and Headquarters nécessitant une connexion permanente à la base de données, la connexion doit être stable. Il est recommandé que vous remplacez un réseau câblé pour un réseau sans fil.

Résolution 11

Les compléments tiers ou les personnalisations que vous y accédez avant la processus de validation de la transaction, accessibles pendant la processus de validation de la transaction ou accessibles une fois la processus de validation de la transaction peut endommager ou assouplir la connectivité réseau dans Store Operations ou Headquarters. Prenez en compte les scénarios possibles de logiciels suivants :
  • Les produits tiers sont installés qui utilisent des crochets dans Store Operations ou Headquarters. Erreurs peuvent se produire si les hooks affichent de nouvelles fenêtres au point de vente, ou si les hooks d’exécuter les scripts SQL et les triggers pour extraire des données transactionnelles dans d’autres bases de données ou les tables. Si vous le pouvez, supprimer ou désactiver ces produits pour voir si les erreurs s’arrêter. Vous pouvez également installer le Store Operations or Headquarters sur un nouvel ordinateur. N’incluez pas les compléments ou personnalisations.
  • Une barre d’état HTML est en cours d’exécution. Erreurs peuvent se produire si une barre d’état HTML est en cours d’exécution. Pour déterminer si vous disposez d’une barre d’état HTML, afficher les propriétés d’affichage au point de vente en appuyant sur CTRL + F6. Cliquez sur l’onglet Écran de Transaction , pour voir si la case à cocher Afficher le code HTML est activée. Si vous avez une barre d’état HTML, posez-vous les questions suivantes :
    • La barre d’état HTML a été personnalisée ? Si la barre d’état HTML a été personnalisée, désactivez la case à cocher. Puis surveiller le système pendant plusieurs jours, afin de déterminer si les erreurs ont disparu.
    • Est le fichier de barre d’état HTML sur le disque dur de chaque ordinateur client sur le réseau, ou le fichier sur un serveur ? Pour vérifier l’emplacement de la barre d’état HTML, examinez l’onglet Enregistrer dans l’outil de Configuration de l’administrateur opérations magasin dans la partie supérieure de l’écran du PDV. Si le fichier de barre d’état HTML se trouve sur un serveur, déplacez le fichier sur le disque dur de chaque ordinateur client.
Remarque Nous vous recommandons de prendre en compte toutes les causes et résolutions qui sont mentionnées dans cet article. Les déconnexions réseau peuvent entraîner une corruption des données ou des mises à jour incomplètes à la base de données des opérations de la banque ou la base de données du siège social. Fonction lorsque la déconnexion se produit, toutes les tables ne rencontrerez le problème. Envisagez le scénario suivant. Une série de tables est mis à jour au cours du processus de transaction. Cette série commence avec la table de Transaction et la table TransactionEntry. La série se termine avec la table commandes et la table du Journal. Une déconnexion du réseau se produit pendant le processus de validation. Ce problème se produit, la transaction apparaît dans le rapport de ventes détaillé car ce rapport extrait la plupart de ses informations de la table de Transaction et de la table TransactionEntry. Toutefois, la transaction n’apparaisse pas dans le rapport Z de caisse, car le rapport Z de caisse tire toutes ses informations de la table de traitement par lots et à partir de la table Journal.

Plus d'informations


Pour plus d’informations sur l’évaluation des domaines généraux qui affectent les performances, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

180775 INF : effets du Client sur le débit de SQL Server



Pour plus d’informations sur la façon de résoudre les problèmes de connectivité réseau, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

325487 comment résoudre les problèmes de connectivité réseau