Vous recevez un message d’erreur lorsque vous essayez de restaurer une sauvegarde ou que vous essayez de graver une sauvegarde sur un CD-RW ou un DVD-RW dans Accounting Professional ou Accounting Express

S’applique à : Microsoft Office Accounting Professional 2007Microsoft Office Accounting Express 2007

Symptômes


Lorsque vous essayez de restaurer une sauvegarde ou que vous tentez de graver une sauvegarde sur un CD-RW ou sur un DVD-RW dans Microsoft Office Accounting professionnel ou dans Microsoft Office Accounting Express, vous recevez l’un des messages d’erreur suivants.
Message d’erreur 1
Ne prenant pas en charge le fonctionnement synchrone, il est possible que vous deviez modifier les paramètres du constructeur de l’écran de fichier pour indiquer que le handle a été ouvert de manière asynchrone (autrement dit, s’il a été ouvert explicitement pour les e/s superposé).
Message d’erreur 2
La famille de médias sur l’appareil C est mal formée. SQL Server ne peut pas traiter cette famille de médias. RESTAURATION de HEADERONLY est en fin anormale.
Message d’erreur 3
Accès refusé.

Cause


Ce problème se produit pour l'une des raisons suivantes :
  • Si vous recevez le message d’erreur 1, il n’y a pas de produit Microsoft SQL Server installé sur l’ordinateur. Reportez-vous à la méthode 1 ou à la méthode 2 dans la section « résolution ».
  • Si vous recevez le message d’erreur 2, Microsoft SQL Server 2005 est installé sur l’ordinateur. Vous essayez de restaurer la sauvegarde à l’aide d’un fichier de sauvegarde sur un dispositif de stockage portable. Toutefois, le périphérique de stockage portable est incompatible avec le processus de restauration SQL Server 2005. Voir la méthode 3 dans la section « résolution ».
  • Si vous recevez le message d’erreur 3, il est possible que vous essayiez de graver la sauvegarde sur un CD réinscriptible (CD-RW) ou un DVD réinscriptible (DVD-RW). La sauvegarde écrite directement sur le média est en conflit avec le processus de gravure. Voir la méthode 4 dans la section « résolution ».

Résolution


Pour résoudre ce problème, utilisez la méthode appropriée.

Méthode 1

Supprimez manuellement Accounting Professional ou Accounting Express. Puis réinstallez Accounting Professional ou Accounting Express. Pour plus d’informations sur la suppression manuelle de Accounting Professional ou Accounting Express, cliquez sur les numéros d’article suivants pour consulter les Articles de la base de connaissances Microsoft :
945462 Comment supprimer manuellement Accounting Professional 2008 ou Accounting Express 2008 et SQL Server 2005
930294 Comment supprimer manuellement Microsoft Office Accounting 2007 et Microsoft SQL Server Express 2005
Remarques Microsoft SQL Server 2005 Express Edition est installé lors de la réinstallation de Accounting Professional ou Accounting Express.

Méthode 2

Installez SQL Server 2005 Express Edition. Pour plus d’informations sur la façon d’obtenir SQL Server 2005 Express Edition, visitez le site Web de Microsoft suivant :

Méthode 3

Copiez le fichier de sauvegarde de l’appareil de stockage portable sur un disque dur local. Utilisez ensuite ce fichier de sauvegarde pour restaurer la sauvegarde sur votre ordinateur. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, puis cliquez sur mon ordinateur.
  2. Connectez l’appareil de stockage portable contenant le fichier de sauvegarde à l’ordinateur.
  3. Double-cliquez sur le nom de l’appareil de stockage portable.
  4. Cliquez avec le bouton droit sur le fichier de sauvegarde, puis cliquez sur copier.
  5. Double-cliquez sur un disque dur local. Par exemple, double-cliquez sur disque local (C).
  6. Dans le menu Edition, cliquez sur Coller.
  7. Démarrez Accounting Professional ou Accounting Express.
  8. Utilisez le fichier de sauvegarde que vous avez copié sur le disque dur local pour restaurer la sauvegarde sur votre ordinateur.

Méthode 4

Créez un fichier de sauvegarde pour votre entreprise, puis copiez le fichier de sauvegarde sur le CD-RW ou sur le DVD-RW. Pour cela, procédez comme suit :
  1. Démarrez Accounting Professional ou Accounting Express.
  2. Dans le menu fichier , cliquez sur ouvrir la société pour ouvrir votre société.
  3. Dans le menu fichier , pointez sur Outils, puis cliquez sur utilitaires de données.
  4. Dans l’onglet outils de base , cliquez sur sauvegarder.
  5. Cliquez sur Parcourir, spécifiez le nom du fichier de sauvegarde, puis cliquez sur Enregistrer.Remarque Par défaut, l’emplacement des fichiers de sauvegarde est le suivant :
    C:\Documents and Settings \User_name\Mes Documents\Small Business Accounting\Backups
  6. Si vous souhaitez ajouter un mot de passe pour protéger votre fichier de sauvegarde, tapez le mot de passe et le mot de passe de vérification.
  7. Cliquez sur OK.
  8. Une fois la sauvegarde terminée, cliquez sur Fermer dans la boîte de dialogue fichier des utilitaires de données Microsoft Office Accounting .
  9. Fermez comptabilité professionnelle ou Accounting Express.
  10. Cliquez sur Démarrer, puis cliquez sur mon ordinateur.
  11. Recherchez le fichier de sauvegarde que vous avez enregistré à l’étape 5.
  12. Cliquez avec le bouton droit sur le fichier de sauvegarde, puis cliquez sur copier.
  13. Recherchez le CD-ROM ou DVD en écriture, cliquez avec le bouton droit sur le lecteur, puis cliquez sur coller.