Le processus de MonitoringHost.exe sur le serveur d’administration racine System Center Operations Manager 2007 peut consommer plus de 2 giga-octets de mémoire

S’applique à : Microsoft System Center Operations Manager 2007

Symptômes


Vous rencontrez les problèmes suivants associés pour le service OpsMgr SDK Service dans Microsoft System Center Operations Manager 2007.

Problème 1

Le processus de MonitoringHost.exe sur le serveur d’administration racine Systems Center Operations Manager 2007 peut consommer plus de 2 gigaoctets (Go) de mémoire. Vous pouvez voir ce problème dans le Gestionnaire des tâches.

Problème 2

Une gestion pack dans Systems Center Operations Manager 2007 convertit des événements de service OpsMgr SDK Service aux alertes. Toutefois, lorsque vous importez à nouveau le pack d’administration, les événements qui ont déjà été traités sont traités de nouveau.

Cause


Problème 1 se produit car le module de source de données de service OpsMgr SDK Service ne limite pas le nombre d’éléments de données qui sont traités à la fois. Le module de source de données tente de lire tous les éléments de données en attente à partir de la base de données et traiter les éléments de données dans un lot. Le processus MonitoringHost.exe peut s’arrêter inopinément en réponse à une exception non gérée si trop d’éléments de données doivent être traitées.

Résolution


Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Instructions d’installation du correctif

Appliquez ce correctif sur chaque serveur qui héberge le rôle de serveur suivantes :
  • Serveur d’administration Operations Manager 2007
Pour ce faire, copiez le fichier SystemCenterOperationsManager2007-RTM-KB943706-X86-X64-ENU.MSI à partir du package de correctifs dans un dossier local ou dans un dossier partagé. Ensuite, exécutez ce fichier.

Remarque Vous pouvez exécuter ce fichier dans l’Explorateur Windows ou à l’invite de commande. Le processus d’installation redémarre le service de santé d’Operations Manager.

Les ordinateurs agents sont mis à jour automatiquement. Toutefois, vous devez approuver la mise à jour dans le dossier « Gestion en attente ». Pour ce faire, procédez comme suit :
  1. Sur l’ordinateur qui exécute le rôle de serveur d’administration, cliquez sur Démarrer, pointez sur Tous les programmes, pointez sur System Center Operations Manager 2007, puis cliquez sur Console opérateur.
  2. Sélectionnez le mode d’Administration , développez Administration, développez Gestion de périphérique, puis cliquez sur Administration en attente.
  3. Dans le dossier « Gestion en attente », examiner et approuver les ordinateurs agents pour appliquer ce correctif.
Remarque Si vous installez l’Agent d’Operations Manager 2007 sur n’importe quel ordinateur après avoir appliqué ce correctif, assurez-vous que vous approuvez l’installation dans le dossier « Gestion en attente ».

Conditions préalables

Aucunes conditions préalables ne sont requises.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
System Center Operations Manager 2007, les versions basées sur les x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Microsoft.enterprisemanagement.operationsmanager.common.dll6.0.5000.39405,50424-Oct-200709:34x86
Microsoft.mom.dataaccesslayer.dll6.0.5000.392,232,32024-Oct-200709:34x86
Microsoft.mom.sdkmodules.dll6.0.5000.39118,78424-Oct-200709:34x86
System Center Operations Manager 2007, les versions basées sur les x64
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Microsoft.enterprisemanagement.operationsmanager.common.dll6.0.5000.39405,50424-Oct-200709:34x86
Microsoft.enterprisemanagement.operationsmanager.dll6.0.5000.312,166,78424-Oct-200709:34x86
Microsoft.mom.dataaccesslayer.dll6.0.5000.392,232,32024-Oct-200709:34x86
Microsoft.mom.sdkmodules.dll6.0.5000.39118,78424-Oct-200709:34x86
Momperfsnapshothelper.exe6.0.5000.047,10424-Oct-200709:35x64
Momperfsnapshothelperproxy.dll6.0.5000.011,77624-Oct-200709:35x64

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft