Message d’erreur lorsque vous installez Microsoft Dynamics CRM 4.0 : « l’initialiseur de type pour 'Microsoft.CRM.LocatorService' a levé une exception » ou « Échec de l’Action Microsoft.crm.setup.common.registerasyncserviceAction »

S’applique à : Dynamics CRM 4.0

Symptômes


Lorsque vous installez Microsoft Dynamics CRM 4.0, vous recevez un des messages d’erreur suivants :



  • L’initialiseur de type pour 'Microsoft.CRM.LocatorService' a levé une exception. L’initialiseur de type pour 'Microsoft.CRM.ServerLocatorService' a levé une exception. Chaîne d’entrée n’était pas dans un format correct.
    Remarque Si vous recevez ce message d’erreur, vous recevez également le message d’erreur suivant dans Microsoft Application Error Reporting :


    System.TypeInitializationException : L’initialiseur de type pour 'Microsoft.Crm.LocatorService' a levé une exception. --->
    System.TypeInitializationException : L’initialiseur de type pour 'Microsoft.Crm.ServerLocatorService' a levé une exception. --->
    System.FormatException : Chaîne d’entrée n’a pas un format correct.

    à System.Number.StringToNumber (String str, les options NumberStyles, NumberBuffer & nombre, NumberFormatInfo info, Boolean parseDecimal) à System.Number.ParseInt32 (String s, NumberStyles style, NumberFormatInfo info)

    à System.Int32.Parse (String s, IFormatProvider fournisseur)

    à System.Diagnostics.PerformanceCounterLib.GetStringTable (Boolean isHelp)

    à System.Diagnostics.PerformanceCounterLib.get_NameTable()

    à System.Diagnostics.PerformanceCounterLib.get_CategoryTable()

    à System.Diagnostics.PerformanceCounterLib.CategoryExists (ordinateur de chaîne, de la catégorie chaîne)

    à System.Diagnostics.PerformanceCounterCategory.Exists (String categoryName, machineName de chaîne)

    à System.Diagnostics.PerformanceCounterCategory.Exists (String categoryName)

    à Microsoft.Crm.LocatorCache.CreatePerformanceCounters()

    à Microsoft.Crm.LocatorCache... ctor()

    à Microsoft.Crm.ServerLocatorService... cctor()

    ---Fin de la trace de pile d’exception interne---

    à Microsoft.Crm.LocatorService... ctor()

    à Microsoft.Crm.CrmTraceSettings.LoadScaleGroupSettings()

    à Microsoft.Crm.LocatorService... ctor()

    à Microsoft.Crm.LocatorService... cctor()

    ---Fin de la trace de pile d’exception interne---

    à Microsoft.Crm.Utility.RetrieveScaleGroupId()

    à Microsoft.Crm.CrmKeySetting.Initialize (Boolean loadSettingsFromConfigDB, Guid scaleGroupId, ConfigSku configSku)

    à Microsoft.Crm.CrmKeySetting... constructeur (CrmKeyType crmKeyType loadSettingsFromConfigDB Boolean, useCachedValues Boolean, Guid scaleGroupId, ConfigSku configSku)

    à Microsoft.Crm.CrmKeySetting.CreateKeySetting (CrmKeyType keyType, ConfigSku configSku)

    à Microsoft.Crm.Setup.Server.ServerSetup.Initialize()

    à Microsoft.Crm.Setup.Server.ServerSetup.InternalMain (String [] args)
  • « Échec de l’action Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction. Une exception s’est produite au cours de la phase de validation de l’installation. Cette exception est ignorée et l’installation va continuer. Toutefois, l’application ne pas fonctionne correctement une fois l’installation terminée. Délai d’attente a expiré et l’opération n’est pas terminée. »
  • En plus de l’erreur ci-dessus s’affiche comme suit dans le crm40svrSetup.log
    12:31:07 | Info | Exécution de l’action d’installation : Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction 12:32:38 | Erreur | System.Exception : Échec de l’Action Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction. ---> System.Configuration.Install.InstallException : une exception s’est produite au cours de la phase de validation de l’installation. Cette exception est ignorée et l’installation va continuer. Toutefois, l’application ne pas fonctionne correctement une fois l’installation terminée. ---> System.ServiceProcess.TimeoutException : délai d’attente a expiré et l’opération n’a pas été achevée. à System.ServiceProcess.ServiceController.WaitForStatus (ServiceControllerStatus desiredStatus, TimeSpan timeout) à Microsoft.Crm.ExtendedServiceInstaller.StartService (Object sender, InstallEventArgs e) à System.Configuration.Install.InstallEventHandler.Invoke (Object sender, InstallEventArgs e) à System.Configuration.Install.Installer.OnCommitted (IDictionary savedState) à System.Configuration.Install.Installer.Commit (IDictionary savedState)---fin de la trace de pile d’exception interne---à System.Configuration.Install.Installer.Commit (IDictionary savedState) à System.Configuration.Install.AssemblyInstaller.Commit (IDictionary savedState) à Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction.Do (IDictionary parameters) à Microsoft.Crm.Setup.Common.Action.ExecuteAction (Action action, IDictionary paramètres, Boolean undo)---fin de trace de pile d’exception interne---, erreur, RetryCancel, Option1
    Remarque Si vous recevez ce message d’erreur, les événements suivants sont enregistrés dans le journal d’Application sur le serveur Microsoft Dynamics CRM 4.0 :
    Événement 1
    Événement 2

Cause


Ce problème se produit pour l’une des causes suivantes.
  • Un problème avec les compteurs de performance sur le serveur. Par conséquent, l’installation ne peut pas ajouter les compteurs de performances pour les bibliothèques de compteurs de performance.
  • L’installation de .net Framework 3.0 est endommagé.
  • Manquants ou en double nom principal de Service (SPN).


Résolution


Pour résoudre ce problème procédez de l’une des méthodes suivantes.
  • Régénérez les bibliothèques de compteurs de performance.
  • Configurer les SPN HTTP approprié pour NETBIOS, des en-têtes d’hôte ou nom de domaine complet. Configurer le SPN MSSQLSvc approprié pour NETBIOS et le nom de domaine complet. Supprimer les doublons HTTP ou des SPN MSSQLSvc.


Pour plus d’informations sur la façon de reconstruire les bibliothèques de compteur de performance, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

300956 comment faire pour recréer manuellement les valeurs de bibliothèque de compteur de performance

  • Ré-installez .net Framework 3.0. Vous pouvez le trouver sur le DVD sous Redist\i386\dotNetFX.