Le vérificateur de fichiers système (SFC) signale de façon incorrecte Windows Defender fichiers de module PowerShell comme endommagés

Cet article décrit un problème où l’vérificateur de fichiers système signale de manière incorrecte Windows Defender fichiers de module PowerShell comme endommagés.

S’applique à : Windows Client
Numéro de la base de connaissances d’origine : 4513240

Symptômes

L’outil SFC (System File Checker) signale les fichiers qui se trouvent dans le dossier %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender comme endommagés ou endommagés. Lorsque ce problème se produit, vous voyez des entrées d’erreur qui ressemblent à ce qui suit :

Les hachages pour le membre de fichier ne correspondent pas.

Cause

Il s’agit d’un problème connu dans Windows 10, version 1607 et versions ultérieures, et Windows Defender version 4.18.1906.3 et versions ultérieures jusqu’à la version 4.8.1908.

Les fichiers du module PowerShell Windows Defender qui se trouvent dans %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender sont fournis dans le cadre de l’image Windows. Ces fichiers sont signés par catalogue. Toutefois, le composant de facilité de gestion de Windows Defender dispose d’un nouveau canal de mise à jour hors bande (OOB). Ce canal remplace les fichiers d’origine par des versions mises à jour signées à l’aide d’un certificat Microsoft approuvé par le système d’exploitation Windows. En raison de cette modification, SFC signale les fichiers mis à jour comme « Les hachages pour le membre de fichier ne correspondent pas ».

Les versions ultérieures de Windows utiliseront les fichiers mis à jour dans l’image Windows. Une fois cette modification implémentée, SFC ne signale plus les fichiers.

Résolution

Ce problème est résolu dans la mise à jour de la version 4.8.1908 de Windows Defender. Une fois cette mise à jour appliquée, les fichiers PowerShell qui font partie de l’image Windows ne sont pas modifiés et l’outil SFC ne les signale plus. Les ordinateurs connectés à Internet qui s’abonnent au canal Windows Update téléchargent et installent automatiquement cette mise à jour.

Pour réparer les fichiers image Windows sur les ordinateurs qui ont été affectés par ce problème, utilisez l’outil DISM. Pour ce faire, ouvrez une fenêtre d’invite de commandes sur l’ordinateur affecté et exécutez les commandes suivantes :

dism /online /cleanup-image /restorehealth
sfc /scannow

Si ces commandes échouent et génèrent un message d’erreur qui ressemble à « Fichier introuvable », assurez-vous que le fichier Install.wim est accessible, puis exécutez les commandes suivantes :

DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
sfc /scannow

Pour plus d’informations sur les commandes de réparation, consultez Réparer une image Windows.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.