PPT2000 : Dépannage de présentations endommagées sous Windows

Pour vous procurer une version Microsoft PowerPoint 2002 de cet article, reportez-vous à l'article 291911 .

Pour vous procurer une version Microsoft PowerPoint 97 de cet article, reportez-vous à l'article 189549 .

Symptômes

Si le programme se comporte de manière inattendue lorsque vous travaillez sur un fichier Microsoft PowerPoint, cela peut indiquer que votre présentation est endommagée ou altérée. Une présentation endommagée peut présenter les symptômes suivants :
  • Erreurs de page non valide, de protection générale ou d'instruction illégale
  • Lorsque vous essayez d'ouvrir une présentation, l'un des messages d'erreur énumérés ci-dessous s'affiche :
    Ceci n'est pas une présentation PowerPoint
    - ou -
    Impossible d'ouvrir les fichiers de type nom_de_fichier.ppt
    - ou -
    Votre système manque de mémoire virtuelle. Pour que Windows fonctionne correctement, augmentez la taille de votre fichier de pagination de mémoire virtuelle.
    - ou -
    Fichier incomplet.
  • Erreurs de mémoire insuffisante ou erreurs de ressources du système insuffisantes
Si ces erreurs n'apparaissent que lorsque vous travaillez sur une présentation spécifique, celle-ci est peut-être altérée. Cet article décrit plusieurs méthodes courantes pour essayer de récupérer une présentation endommagée. Rappelez-vous que les méthodes proposées ne garantissent pas que vous pourrez récupérer le fichier endommagé. Dans certains cas, selon le type d'altération, vous ne pourrez pas récupérer les données et vous devrez recréer la présentation endommagée.


REMARQUE : parfois, ces symptômes peuvent se manifester pour d'autres raisons.

Résolution

S'il s'avère que votre présentation est endommagée, appliquez les méthodes suivantes pour essayer de récupérer le fichier. Les méthodes répertoriées dans cet article se répartissent dans les catégories suivantes :
  • Dépannage général
  • Vous n'arrivez pas à ouvrir une présentation
  • Vous arrivez à ouvrir une présentation endommagée
Commencez par suivre les procédures décrites à la section "Dépannage général".


Dépannage général

REMARQUE : dans la mesure où il existe plusieurs versions de Windows, les étapes suivantes peuvent varier en fonction de votre ordinateur. Si tel est le cas, consultez la documentation de votre produit pour effectuer ces étapes.

Bien que certaines de ces étapes de dépannage puissent être utilisées sous Microsoft Windows NT, la plupart d'entre elles visent Microsoft Windows 95 et Microsoft Windows 98.


Redémarrez Windows 95 ou 98 en mode sans échec. Pour cela, procédez comme suit :
  1. Redémarrez votre ordinateur. Lorsque le message Démarrage de Windows 9x s'affiche, appuyez sur F8, puis, dans le menu Démarrer, sélectionnez Ligne de commande uniquement. REMARQUE : si Windows démarre, modifiez le fichier Autoexec.bat en supprimant ou en désactivant la ligne win et répétez l'étape 1.
  2. Démarrez Windows 9x avec un nombre minimal de pilotes. Pour ce faire, tapez la ligne suivante :
    win /d:m
    REMARQUE : si Windows 9x requiert des composants réseau pour démarrer, tapez plutôt la ligne suivante : win /d:n
Le fait que vous puissiez ouvrir votre présentation après avoir démarré Windows en mode sans échec indique qu'un conflit système vous empêchait de le faire.

Vous n'arrivez pas à ouvrir une présentation

Si vous ne pouvez toujours pas ouvrir votre présentation, essayez l'une des méthodes ci-dessous.

Méthode 1 : faites glisser la présentation vers le fichier du programme PowerPoint

  1. Déterminez l'emplacement du programme PowerPoint sur votre ordinateur. L'emplacement par défaut de PowerPoint est le suivant :
    C:\Program Files\Microsoft Office\Office
  2. Faites glisser la présentation PowerPoint endommagée sur l'icône du programme PowerPoint

Méthode 2 : double-cliquez sur la présentation PowerPoint dans l'Explorateur Windows

Essayez d'ouvrir le fichier en double-cliquant sur la présentation PowerPoint dans l'Explorateur Windows.

Méthode 3 : essayez d'insérer des diapositives dans une nouvelle présentation

Pour insérer des diapositives dans une nouvelle présentation, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Nouveau.
  2. Cliquez sur Nouvelle présentation, puis sur OK.
  3. Si la boîte de dialogue Nouvelle diapositive s'affiche, cliquez sur OK.


    La sélection que vous effectuez dans cette boîte de dialogue n'a pas d'importance. Vous pouvez supprimer cette diapositive lorsque vous avez recréé votre présentation.
  4. Dans le menu Insertion, cliquez sur Diapositives à partir d'un fichier, puis cliquez sur l'onglet Rechercher la présentation.
  5. Cliquez sur Parcourir. Sélectionnez la présentation endommagée et cliquez sur Ouvrir. La boîte de dialogue Recherche de diapositive s'affiche.
  6. Cliquez sur Tout insérer.


    Si cette opération réussit, toutes les diapositives de la présentation endommagée sont insérées dans la nouvelle présentation, à l'exception du masque des diapositives.
  7. Enregistrez la présentation.


    Si l'aspect de la présentation laisse toujours à désirer, essayez d'appliquer la présentation endommagée comme modèle. Pour cela, procédez comme suit :


    1. Effectuez une copie de sauvegarde de votre présentation.
    2. Dans le menu Format, cliquez sur Appliquer un modèle de conception.
    3. Sélectionnez la présentation endommagée et cliquez sur Appliquer.
    Le masque des diapositives de la présentation endommagée remplace le nouveau masque des diapositives.


    REMARQUE : si le programme se comporte alors de manière inattendue, cela peut indiquer que le modèle a endommagé la présentation. Si c'est le cas, utilisez votre copie de sauvegarde et recréez le masque des diapositives.

Méthode 4 : essayez d'ouvrir la version du fichier temporaire de la présentation

Lorsque vous modifiez une présentation PowerPoint, le programme crée une copie temporaire du fichier, intitulée PPT ####.tmp (où #### correspond à un nombre aléatoire à quatre chiffres). Ce fichier peut se trouver dans le même dossier que la présentation ou dans votre dossier de fichiers temporaires. Après avoir attribué à ce fichier l'extension .ppt, vous pourrez peut-être l'ouvrir dans PowerPoint.
  1. Examinez le dossier à partir duquel la présentation a été ouverte et cherchez un fichier avec le nom PPT ####.tmp.


    S'il n'est pas présent à cet emplacement, vous devez lancer une recherche. Sinon, ignorez les étapes 2 à 4.
  2. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur
    Fichiers ou dossiers
    .


    Dans Microsoft Windows 2000 ou Windows Millennium Edition, cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
  3. Dans la zone Nommé ou la zone
    Rechercher les fichiers ou les dossiers nommés
    , tapez PPT*.tmp.
  4. Dans la zone
    Rechercher dans
    , cliquez sur Poste de travail, puis sur Rechercher maintenant.
  5. Si vous trouvez le fichier, procédez comme suit :
    1. Cliquez avec le bouton droit sur le fichier, puis cliquez sur Renommer dans le menu contextuel.
    2. Remplacez l'extension .tmp de l'ancien fichier par .ppt. Le nom du fichier doit alors ressembler à ceci : PPT ####.ppt
    3. Essayez d'ouvrir le fichier dans PowerPoint.
Si plusieurs fichiers ont été modifiés la dernière fois que vous avez enregistré votre présentation, vous devrez peut-être ouvrir chaque fichier pour déterminer si l'un d'entre eux est effectivement une copie de la présentation.

Méthode 5 : essayez d'ouvrir la présentation dans la visionneuse PowerPoint

Si vous arrivez à ouvrir la présentation dans la visionneuse PowerPoint, cela peut indiquer que l'installation de PowerPoint est endommagée ou que la présentation contient des objets endommagés.

Méthode 6 : déplacez le fichier sur un autre ordinateur

Dans certains cas, le fait de copier le fichier PowerPoint sur un autre ordinateur permet d'ouvrir la présentation. Si vous n'arrivez pas à ouvrir le fichier, examinez chaque diapositive pour déterminer s'il existe des espaces réservés vides. Si c'est le cas, supprimez-les. Enregistrez à nouveau la présentation, puis replacez-la sur l'ordinateur d'origine.

Méthode 7 : déplacez le fichier sur un autre disque

Il est possible que Windows ne puisse pas lire le fichier à l'emplacement auquel il a été enregistré. Copiez le fichier sur un autre disque. Vous pouvez, par exemple, copier le fichier d'une disquette vers le disque dur.


REMARQUE : il est possible que vous n'arriviez pas à copier le fichier à partir du disque sur lequel il a été enregistré parce qu'il possède des liaisons croisées avec d'autres fichiers ou dossiers ou parce qu'il est situé sur un secteur endommagé du disque. Essayez la méthode 7.

Méthode 8 : exécutez ScanDisk

Exécutez ScanDisk pour réparer toutes les erreurs du lecteur. Faites réparer tous les fichiers à liaisons croisées et convertir les fragments perdus en fichiers.


REMARQUE : même si ScanDisk peut déterminer que votre fichier possède des liaisons croisées et le réparer, cela ne garantit pas que PowerPoint sera capable de lire le fichier.

Méthode 9 : copiez le fichier sur un ordinateur Macintosh

Copiez le fichier sur un ordinateur Macintosh et ouvrez-le dans PowerPoint pour Macintosh.


REMARQUE : cette procédure peut exiger l'installation d'un convertisseur PowerPoint 97 pour PowerPoint 4.0 pour Macintosh.

Vous arrivez à ouvrir une présentation endommagée

Méthode 1 : essayez d'appliquer la présentation endommagée comme modèle

Insérez les diapositives dans une nouvelle présentation, puis appliquez la présentation endommagée comme modèle pour préserver le masque. Pour cela, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Nouveau.
  2. Cliquez sur Nouvelle présentation, puis sur OK.
  3. Si la boîte de dialogue Nouvelle diapositive s'affiche, cliquez sur OK.


    La sélection que vous effectuez dans cette boîte de dialogue n'a pas d'importance. Vous pouvez supprimer cette diapositive lorsque vous avez recréé votre présentation.
  4. Dans le menu Insertion, cliquez sur Diapositives à partir d'un fichier, puis cliquez sur l'onglet Rechercher la présentation.
  5. Cliquez sur Parcourir, sélectionnez la présentation endommagée, puis cliquez sur Ouvrir. La boîte de dialogue Recherche de diapositive s'affiche.
  6. Cliquez sur Tout insérer.


    Si cette opération réussit, toutes les diapositives de la présentation endommagée sont insérées dans la nouvelle présentation, à l'exception du masque des diapositives.
  7. Enregistrez la présentation. Si l'aspect de la présentation ne correspond pas à vos attentes, essayez d'appliquer la présentation endommagée comme modèle. Pour cela, procédez comme suit :


    1. Effectuez une copie de sauvegarde de votre présentation.
    2. Dans le menu Format, cliquez sur Appliquer un modèle de conception.
    3. Sélectionnez la présentation endommagée et cliquez sur Appliquer.
    Le masque des diapositives de la présentation endommagée remplace le nouveau masque des diapositives.


    REMARQUE : si le programme se comporte alors de manière inattendue, cela peut indiquer que le modèle a endommagé la présentation. Si c'est le cas, utilisez votre copie de sauvegarde et recréez le masque des diapositives.

Méthode 2 : collez les diapositives du fichier endommagé dans un nouveau fichier

Par un copier-coller, déplacez les diapositives de la présentation endommagée vers une nouvelle présentation. Pour cela, procédez comme suit :
  1. Ouvrez la présentation endommagée.
  2. Dans le menu Fichier, cliquez sur Nouveau.
  3. Si la boîte de dialogue Nouvelle diapositive s'affiche, cliquez sur OK.
  4. Dans le menu Affichage, cliquez sur Trieuse de diapositives. Si des messages d'erreur apparaissent lorsque vous changez d'affichage, essayez plutôt de passer en mode Plan.
  5. Cliquez sur la diapositive à copier.
  6. Dans le menu Edition, cliquez sur Copier. Pour copier plusieurs diapositives à la fois, maintenez la touche MAJ enfoncée et cliquez sur toutes les diapositives que vous voulez copier.
  7. Passez à la nouvelle présentation. Dans le menu Fenêtre, cliquez sur l'option correspondant à la nouvelle présentation.
  8. Dans le menu Affichage, cliquez sur Trieuse de diapositives.
  9. Dans le menu Edition, cliquez sur Coller.
  10. Répétez les étapes 5 à 9 jusqu'à ce que la présentation soit entièrement transférée.
REMARQUE : dans certains cas, une seule diapositive endommagée peut générer un problème pour toute la présentation. Si vous remarquez que la présentation se comporte étrangement après y avoir copié une diapositive, cela indique que la diapositive en question est probablement endommagée. Recréez la diapositive ou copiez des parties de la diapositive dans une nouvelle diapositive.

Méthode 3 : enregistrez la présentation au format RTF (Rich Text Format)

Si la présentation est complètement endommagée, l'enregistrer au format RTF peut constituer la seule possibilité de récupérer le fichier. Cette méthode, lorsqu'elle réussit, ne récupère que le texte affiché en mode Plan. Pour cela, procédez comme suit :
  1. Ouvrez la présentation.
  2. Dans le menu Fichier, cliquez sur Enregistrer sous.
  3. Dans la liste Type du fichier, sélectionnez Plan/RTF (*.rtf).
  4. Dans la zone Nom du fichier, tapez le nom de votre choix, sélectionnez l'emplacement d'enregistrement du fichier, puis cliquez sur Enregistrer.
  5. Fermez le fichier.
REMARQUE : pour continuer à travailler après avoir ouvert le fichier RTF, cliquez sur Ouvrir dans le menu Fichier et, dans la liste Types de fichiers, sélectionnez Tous les plans ou Tous les fichiers. Si vous sélectionnez l'option Présentations, les fichiers RTF n'apparaissent pas.

Plus d'informations

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
156126 Dépannage de Windows 95 à l'aide du mode sans échec


164519 OFF97 : Dépannage des erreurs du module Office Kernel32.dll sous Windows 95


88082 PPT : Erreur lors de l'ouverture d'une présentation non traduite
Propriétés

ID d'article : 207377 - Dernière mise à jour : 9 août 2006 - Révision : 1

Commentaires