WD2000 : Les textes fusionnés s'impriment dans une police différente lors d'une fusion-publipostage

Symptômes

Lorsque vous effectuez une fusion-publipostage, il se peut que les informations fusionnées s'impriment dans une police différente. Ce problème survient lorsque le style Normal par défaut diffère de la police appliquée au document principal de fusion.

Par exemple, si vous avez choisi Courier comme police par défaut du style Normal mais décidez de formater le document principal en Arial, le texte s'imprime en Arial, mais les champs fusionnés s'impriment en Courier.

Contournement

Pour contourner ce problème, suivez la procédure appropriée à votre situation.

Méthode 1 : Ajoutez le commutateur Charformat

Modifiez le champ de fusion et ajoutez-y le commutateur Charformat. Pour modifier le champ de fusion, procédez comme suit :
  1. Placez le point d'insertion dans le champ de fusion. Par exemple, cliquez à l'intérieur d'un champ comme :
    «Prénom»
  2. Appuyez sur MAj+F9 pour afficher le code de champ. Par exemple, votre champ de fusion devrait maintenant ressembler à ceci :
    {MERGEFIELD Prénom}
  3. Placez le point d'insertion à gauche de l'accolade fermante (}).
  4. Ajoutez le commutateur Charformat de sorte que le champ de fusion ressemble à cet exemple :

    {MERGEFIELD Prénom \* Charformat}
    REMARQUE : Si le mot " MERGEFORMAT " apparaît dans ce champ, supprimez-le et remplacez-le par le mot Charformat.
  5. Sélectionnez le premier caractère suivant l'accolade ouvrante.

    Par exemple, sélectionnez le " M " du mot MERGEFIELD comme dans cet exemple :
    {MERGEFIELD Prénom \* Charformat}
    Vérifiez que ce caractère est formaté selon la police et le corps souhaités. Si tel n'est pas le cas, modifiez la mise en forme.
  6. Appuyez sur MAJ+F9 pour afficher le résultat du code de champ.
Le code de champ ne semble pas avoir changé d'aspect, mais, une fois la fusion effectuée, il s'imprime dans la police correcte.

Méthode 2 : Modifiez le style Normal

Vous pouvez appliquer au style Normal intégré la police de votre choix. Pour modifier le style Normal, procédez comme suit :
  1. Ouvrez le document principal de fusion.
  2. Dans le menu Format, choisissez Style.
  3. Dans la boîte de dialogue Style, sélectionnez Normal dans la liste Styles, puis cliquez sur Modifier.
  4. Dans la boîte de dialogue Modifier le style, cliquez sur Format, puis sur Police.

    REMARQUE : Si vous souhaitez que ces modifications s'appliquent de façon permanente et à tous les nouveaux documents, activez l'option Ajouter au modèle.
  5. Dans l'onglet Police, style et attributs, spécifiez la police à utiliser pour la fusion, puis cliquez sur OK pour fermer la boîte de dialogue Police.

    REMARQUE : Effectuez les autres réglages utiles dans l'onglet Police, style et attributs.
  6. Cliquez sur OK pour fermer la boîte de dialogue Modifier le style, puis cliquez sur Fermer pour fermer la boîte de dialogue Style.

Méthode 3 : Fusionnez vers un nouveau document et rectifiez la mise en forme

Pour fusionner vers un nouveau document et apporter vos modifications à la mise en forme, procédez comme suit :
  1. Effectuez la fusion vers un nouveau document.
  2. Dans le document fusionné, choisissez la commande Sélectionner tout du menu Edition.
  3. Dans le menu Format, cliquez sur Police.
  4. Dans l'onglet Police, sélectionnez la police à utiliser dans le document fusionné, puis cliquez sur OK.

    REMARQUE : Effectuez les autres réglages utiles dans l'onglet Police, style et attributs.
Lorsque vous imprimez le document fusionné, l'intégralité du texte sort dans la police choisie.
Propriétés

ID d'article : 212349 - Dernière mise à jour : 4 nov. 2000 - Révision : 1

Commentaires