WD2000 : Une nouvelle session de Word apparaît à l'exécution de chaque document.

Symptômes

Lorsque vous créez ou ouvrez un document supplémentaire, une autre session de Word s'ouvre automatiquement.


REMARQUE : avec les versions précédentes de Word, un seul bouton Word apparaissait dans la barre des tâches de Windows même lorsque plusieurs documents étaient ouverts. Cependant, avec Word 2000, un bouton spécifique apparaît dans la barre des tâches de Windows pour chaque document ouvert.

Cause

Word 2000 utilise l'interface SDI (Single Document Interface) d'après laquelle chaque document occupe sa propre fenêtre (il en est de même dans Microsoft Outlook où chaque message occupe sa propre fenêtre). Ce comportement diffère de celui des versions antérieures de Word qui utilisent l'interface MDI (Multiple Document Interface) selon laquelle chaque document constitue une fenêtre séparée à l'intérieur de la fenêtre du programme Word.


Avec l'interface SDI, une seule session du programme Word (Winword.exe) est exécutée. Pour confirmer cela, appliquez l'une des méthodes suivantes pour afficher la liste des tâches de Windows :
  • Sous Microsoft Windows 95, Microsoft Windows 98 et Microsoft Windows NT 4.0, appuyez sur CTRL+ALT+SUPPR.


    - ou -
  • Sous Microsoft Windows XP ou Microsoft Windows 2000, appuyez sur CTRL+ALT+SUPPR ou cliquez avec le bouton droit sur une zone vide de la barre des tâches de Windows, puis cliquez sur Gestionnaire des tâches.
REMARQUE : sous Microsoft Windows NT 4.0, Microsoft Windows XP et Microsoft Windows 2000, lorsque vous affichez la liste des tâches, chaque instance d'un document ouvert s'affiche comme une tâche séparée sous l'onglet Applications. Cependant, lorsque vous cliquez sur l'onglet Processus, une seule session de Winword.exe en cours d'exécution s'affiche à l'écran.


Sous Microsoft Windows 95 et Microsoft Windows 98, la boîte de dialogue de fermeture de programme affiche une seule instance de Microsoft Word lorsque vous appuyez sur CTRL+ALT+SUPPR.

Plus d'informations

Dans la mesure où Microsoft Word 2000 utilise réellement la technologie SDI et ne prend plus en charge l'interface MDI, l'interface SDI ne peut pas être désactivée dans Microsoft Word 2000.


REMARQUE : il est possible de démarrer une deuxième session de Microsoft Word lors de l'utilisation d'un commutateur de ligne de commande.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

210565 WD2000 : Commutateurs (de ligne de commande) de démarrage de Word et leur rôle
REMARQUE : Lors de l'utilisation de la commande d'environnement dans une macro Visual Basic pour Applications, une deuxième session de Microsoft Word n'est pas démarrée.
Pour plus d'informations sur le mode d'utilisation de la commande d'environnement pour démarrer une deuxième session de Microsoft Word, cliquez sur le numéro de l'article suivant dans la Base de connaissances Microsoft :

209910 WD2000 : La commande d'environnement ne démarre pas une deuxième instance
D'autres applications Microsoft Office 2000, telles que Microsoft Excel, peuvent prendre en charge l'interface MDI et, par conséquent, l'interface SDI peut être désactivée dans ces applications.


Pour désactiver l'interface SDI dans Microsoft Excel 2000, Microsoft PowerPoint 2000 et Microsoft Access 2000, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options.
  2. Cliquez sur l'onglet Affichage, puis désactivez la case à cocher Fenêtres dans la barre des tâches.
  3. Cliquez sur OK.
L'interface SDI offre les avantages suivants :


Navigation améliorée

Certains utilisateurs trouvaient que le menu Fenêtre des versions antérieures de Word n'était pas intuitif. Des documents restaient "égarés" derrière d'autres documents ouverts et la gestion des fenêtres de documents n'était pas simple. Le fait que chaque document dispose d'une fenêtre séparée et d'une icône dans la barre des tâches de Windows facilite la navigation.


Amélioration du fonctionnement avec WordMail

L'interface SDI facilite et simplifie l'envoi des messages directement à partir de Word.


Pour plus d'informations sur l'interface SDI et sur Word 2000, cliquez sur les numéros des articles suivants dans la Base de connaissances Microsoft :

220288 WD2000 : Le fait de réorganiser toutes les fenêtres ferme l'affichage Plein écran
199666 WD2000 : Le Gestionnaire des tâches de Windows NT affiche tous les documents SDI
211385 WD2000 : Les commandes Rechercher et Remplacer n'utilisent pas les boutons de la barre d'outils de mise en forme
224717 WD2000 : La sélection d'un lien hypertexte ouvre le fichier dans une nouvelle fenêtre
238392 WD2000 : La barre d'outils personnalisée disparaît après fusion et publipostage
232465 WD2000 : Conversion des macros de Microsoft Word 97 en macros Microsoft Word 2000
Microsoft est à l'écoute de vos suggestions ou commentaires à propos des modifications apportées à la conception générale et aux fonctionnalités de ses produits. Pour plus d'informations sur le moyen d'envoyer vos suggestions, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
114491 Procédure pour contacter le programme Microsoft Wish
Propriétés

ID d'article : 230684 - Dernière mise à jour : 28 nov. 2005 - Révision : 1

Commentaires