PROCÉDURE : Désinstaller manuellement Visual Studio avec MSDN Library

IMPORTANT : Cet article contient des informations portant sur la modification du registre. Avant de modifier le registre, assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la procédure à suivre, consultez la rubrique d'aide " Restaurer le registre " dans Regedit.exe ou la rubrique " Restaurer une clé de registre " dans Regedt32.exe.

Résumé

Cet article décrit la procédure à suivre pour supprimer manuellement Visual Studio 6.0 et MSDN Library, ainsi que toute autre collection d'aide HTML installée sur le système. Lorsque vous désinstallez manuellement Visual Studio, vous devez désinstaller également MSDN Library.


La procédure suivante est également nécessaire si vous voulez changer l'emplacement du produit installé. Cela est dû aux entrées de registre qui sont conservées même si vous supprimez le produit à l'aide de l'utilitaire Ajout/Suppression de programmes du Panneau de configuration.


REMARQUE : Cette méthode ne doit être utilisée qu'en dernier ressort. Si cela est possible, supprimez Visual Studio 6.0 et MSDN ibrary à l'aide de l'utilitaire Ajout/Suppression de programmes du Panneau de configuration.

Plus d'informations

AVERTISSEMENT : Cette procédure supprimera tous les programmes Visual Studio et de langage antérieur du système. Cela inclut les sous-composants Visual Studio, sans s'y limiter. Les installations Microsoft Visual Basic, Visual C++, Visual J++ et Visual InterDev et toutes les personnalisations respectives seront perdues.


AVERTISSEMENT : Cette procédure supprimera toutes les collections d'aide HTML du système. Cela inclut les installations MSDN Library et la documentation du Kit de développement de plate-forme. Toutes les personnalisations effectuées pour ces collections seront perdues.


AVERTISSEMENT : Toute utilisation incorrecte de l'Éditeur du registre peut être à l'origine de problèmes graves pouvant nécessiter la réinstallation de votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.


Pour plus d'informations sur la procédure à suivre pour modifier le registre, consultez la rubrique d'aide Modification des clés et des valeurs dans l'Éditeur du registre (Regedit.exe) ou les rubriques Ajout et suppression d'informations dans le registre et Modification des données de registre dans Regedt32.exe. Pensez à sauvegarder le registre avant de le modifier. Si vous travaillez sous Windows NT ou Windows 2000, nous vous conseillons de mettre à jour votre disquette de réparation d'urgence.



Avant de commencer :
  • Si votre ordinateur utilise Windows NT, utilisez les autorisations d'administrateur.
  • Fermez toutes les applications en cours d'exécution.

Si le système d'exploitation est Windows 2000, modifiez en premier lieu les paramètres pour afficher tous les fichiers et dossiers cachés du système :
  1. Ouvrez l'Explorateur Windows.
  2. Dans le menu Outils, sélectionnez Options des dossiers.
  3. Cliquez sur l'onglet Affichage.
  4. Dans Paramètres avancés, activez Afficher les fichiers et dossiers cachés.

Si le système d'exploitation est Windows 95, Windows 98 ou Windows NT 4.0, commencez par modifier les paramètres de manière à afficher les fichiers et dossiers cachés du système :
  1. Ouvrez l'Explorateur Windows.
  2. Dans le menu Affichage, sélectionnez Options des dossiers.
  3. Cliquez sur l'onglet Affichage.
  4. Dans Paramètres avancés, sélectionnez Afficher les fichiers et dossiers cachés.

La procédure suivante supprimera complètement tous les composants Visual Studio et MSDN Library du système.

REMARQUE : Si un échec survient dans une étape, passez à l'étape suivante :
  1. Utilisez l'utilitaire Ajout/Suppression de programmes du Panneau de configuration pour supprimer les installations Visual Studio répertoriées.
  2. Utilisez Ajout/Suppression de programmes pour supprimer tout autre programme de langage de programmation, tel que Visual Basic, Visual C++, Visual J++ et Visual InterDev, ainsi que toutes les versions personnalisées correspondantes.
  3. Utilisez Ajout/Suppression de programmes du Panneau de configuration pour supprimer toutes les installations MSDN Library répertoriées.
  4. Utilisez Ajout/Suppression de programmes pour désinstaller toute autre collection d'aide HTML, telle que la documentation du Kit de développement de plate-forme.
  5. Dans le menu Démarrer, pointez sur Rechercher (Windows 95, Windows 98, Windows NT ou Windows 2000) et cliquez sur Fichiers ou dossiers.
  6. Recherchez et supprimez toutes les occurrences des fichiers suivants sur vos disques durs locaux :
    *.CHK

    *.TMP

    HH.EXE

    HH.DAT

    HHCOLREG.DAT

    VIEWS.PRF (fichiers utilisateur)

    CMDUI.PRF (fichiers utilisateur)

    TOOLBOX.TBD (fichiers utilisateur)

    HHCTRL.OCX *** ne pas supprimer sur les ordinateurs Windows 2000***

    ITSS.DLL *** ne pas supprimer sur les ordinateurs Windows 2000 ***

    ITIRCL.DLL *** ne pas supprimer sur les ordinateurs Windows 2000 ***

    REMARQUE : Certains fichiers répertoriés peuvent s'avérer introuvables dans votre système. Ignorez ces fichiers et continuez.
  7. Supprimez les dossiers d'installation de tous les produits Visual Studio. Notez les emplacements par défaut ci-dessous ; les emplacements réels peuvent différer sur votre système si vous avez effectué une installation personnalisée :
    \Program Files\Microsoft Visual Studio

    \Program Files\Common Files\Microsoft Shared\MSDesigners98

    \Program Files\Common Files\Microsoft Shared\MSDN

    \Program Files\Common Files\Microsoft Shared\VS98

    \Program Files\Common Files\Microsoft Shared\Wizards98

  8. Supprimez les dossiers d'installation de tous les composants MSDN Library (ils ont peut-être été supprimés à l'étape précédente s'ils sont installés aux emplacements par défaut). Les dossiers par défaut se présentent de la façon suivante :
    Program Files\Microsoft Visual Studio\MSDN98 (pour MSDN Library pour Visual Studio 6.0)
    Program Files\Microsoft Visual Studio\MSDN (pour les versions MSDN Quarterly Library)
  9. Utilisez Regedit.exe pour supprimer les clés de registre suivantes, si elles existent :
    HKEY_LOCAL_MACHINE\Software\Microsoft\DevStudio
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSVSDG
    HKEY_LOCAL_MACHINE\Software\Microsoft\HTML Help Collections
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Basic (versions)
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Component Manager
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Modeler
    HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio
    HKEY_CURRENT_USER\Software\Microsoft\DevStudio
    HKEY_CURRENT_USER\Software\Microsoft\MSVSDG
    HKEY_CURRENT_USER\Software\Microsoft\Visual Basic
    HKEY_CURRENT_USER\Software\Microsoft\Visual Modeler
    HKEY_CURRENT_USER\Software\Microsoft\VisualFoxPro
    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio
  10. AVERTISSEMENT : Ne supprimez pas la clé " Uninstall " ; supprimez uniquement les clés MSDN et Visual Studio répertoriées au niveau inférieur.

    Utilisez Regedit.exe pour supprimer toute instance de clé pour Visual Studio ou MSDN Library sous la clé suivante :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall 
  11. Videz la Corbeille.
  12. Redémarrez le système et désactivez tous les logiciels antivirus.
  13. Mettez à jour le système d'aide HTML en exécutant la mise à jour de l'aide HTML, disponible sur le site Web Microsoft à l'adresse suivante :
  14. Réinstallez Visual Studio et MSDN Library.
  15. Appliquez à nouveau l'actuel Service Pack de Visual Studio.
  16. Testez le produit.
AVERTISSEMENT : Sous Windows 2000, cette procédure peut générer des problèmes avec les outils d'administration (Microsoft Management Console [MMC], les services, l'Observateur d'événements, etc.). Les fichiers d'aide de ces outils peuvent ne pas fonctionner. Pour corriger ce problème, vous devez procéder comme suit sous Windows 2000 :
  1. Recherchez le chemin d'accès des profils utilisateur. Par défaut, il s'agit de C:\Documents and Settings. Pour une mise à niveau, ils peuvent se trouver dans <répertoire_Windows>\Profiles.
  2. Pour chaque utilisateur, allez dans <répertoire_profils_utilisateur>\Local Settings\Temp.
  3. Supprimez tous les fichiers de collection (.col) dans ce répertoire.

Références

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
240350 PROCÉDURE : Désinstaller manuellement MSDN Library
201420 PROCÉDURE : Désinstaller et mettre à jour manuellement l'aide HTML
216109 PROCÉDURE : Résoudre les problèmes d'exécution, d'installation et de désinstallation dans MSDN Library

Propriétés

ID d'article : 248697 - Dernière mise à jour : 16 août 2005 - Révision : 1

Commentaires