Message d’erreur dans des emplacements différents dans Microsoft Dynamics SL : « Message système 5045 »


Symptômes


Examinons les scénarios suivants dans des emplacements différents dans Microsoft Dynamics SL.
  • Vous essayez d’ouvrir une session sur Microsoft Dynamics SL. Voir la Cause 1, 2 ou 3.
  • Ou bien, vous effectuez une action qui crée un journal des événements Microsoft Dynamics SL. Voir toutes les causes.
  • Ou bien, cliquez sur Démarrer dans la fenêtre Base de données le contrôle de l’intégrité physique (95.500.00) . Voir la Cause 5.
Dans ces scénarios, le message d’erreur suivant s’affiche :

Message système 5045 - erreur de fichier que vous essayez d’ouvrir le fichier d’état de processus

Cause


Cause 1 :

L’ID d’utilisateur Windows possède des autorisations insuffisantes pour l’opération. Reportez-vous à la résolution 1.

Cause 2 :

Le lecteur logique mappé à l’installation de Microsoft Dynamics SL est incorrect. Reportez-vous à la section Résolution 2.

Cause 3 :

Le fichier Solomon.ini sur l’ordinateur de la station de travail est endommagé. Reportez-vous à la résolution 3.

Cause 4 :

Les fichiers du journal des événements sont endommagés. Consultez Résolution 4.

Cause 5 :

La table PSTATUS est endommagée. Consultez Résolution de 5.

Résolution


Résolution 1 :

Attribuez les autorisations appropriées pour les utilisateurs de Microsoft Dynamics SL.
  1. Contactez l’administrateur réseau pour vérifier que l’ID d’utilisateur Windows dispose des autorisations suffisantes.
  2. Assurez-vous que tous les utilisateurs de Microsoft Dynamics SL ont un contrôle total sur le répertoire où vous avez installé Microsoft Dynamics SL. L’emplacement par défaut de l’installation est la suivante :
    • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \Program Files\Microsoft Dynamics\SL\Applications
    • Microsoft Dynamics SL 6.5 et les versions antérieures : lettre_lecteur: \Program Files\Solomon\

Résolution 2 :

Partager et mapper le lecteur à la correctement. L’emplacement par défaut de l’installation de Microsoft Dynamics SL est la suivante :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \Program Files\Microsoft Dynamics\SL\Applications
  • Microsoft Dynamics SL 6.5 et les versions antérieures : lettre_lecteur: \Program Files\Solomon
Dans ce cas, les lecteurs à partir de stations de travail doivent être mappés à la racine du volume ou à l’un des emplacements suivants, selon votre version :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \Program Files\Microsoft Dynamics SL\
  • Microsoft Dynamics SL 6.5 et les versions antérieures : lettre_lecteur: \Program Files\
Cela signifie que la racine du volume ou un des emplacements décrits précédemment doit être partagé. À partir de stations de travail, les propriétés de l’icône pour le programme principal doivent être :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \SL\Applications\MSDynamicsSL.exe ou DriveLetter:\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 ou une version antérieure : lettre_lecteur: \Program Files\Solomon\Parent.exe ou DriveLetter:\Solomon\Parent.exe
Remarque Les propriétés de l’icône ne doivent pas être un des emplacements suivants (ce qui indique une racine de la carte) :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 et les versions antérieures : lettre_lecteur: \Parent.exe
Les propriétés de l’icône ne doivent pas être un des emplacements suivants (qui indique un chemin d’accès UNC) :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : \\nom_serveur\nom_partage\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 et les versions antérieures : \\nom_serveur\nom_partage\Solomon\Parent.exe
Les chemins UNC ne sont pas pris en charge dans Microsoft Dynamics SL ou Microsoft Business Solutions – Solomon.

Résolution 3 :

Renommez tous les fichiers Solomon.ini sur l’ordinateur de la station de travail en Solomon.old. Pour plus d’informations sur la modification du fichier Solomon.ini, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2005087 de dépannage permettant de trouver le fichier Solomon.ini dans Microsoft Dynamics SL


Résolution 4 :

Supprimez tous les fichiers de journal des événements dans les emplacements suivants :
  • Microsoft Dynamics SL 7.0 et versions ultérieures : lettre_lecteur: \Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
  • Microsoft Dynamics SL 6.5 et les versions antérieures : lettre_lecteur: \Program Files\Solomon\Eventlog\

Résolution 5 :

Supprimer les enregistrements endommagés dans la table PSTATUS.

Remarque Avant de suivre les instructions fournies dans cet article, assurez-vous que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème survient.
À l’aide de SQL Server Management Studio ou l’Analyseur de requêtes SQL, d’exécuter l’instruction suivante par rapport à la base de données de l’application Microsoft Dynamics SL ou Microsoft Business Solutions – base de données des applications de Solomon :
Delete from PSTATUS