Message d’erreur « erreur 633-le modem (ou un autre périphérique de connexion) est déjà utilisé » lorsque vous essayez d’établir une connexion VPN dans Windows Server 2003


Important Cet article contient des informations sur la modification du Registre. Avant de modifier le registre, assurez-vous de le sauvegarder et assurez-vous de bien comprendre comment restaurer le registre en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour consulter l’article de la base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows

Symptômes


Lorsque vous essayez d’utiliser une connexion de réseau privé virtuel (VPN) sur un ordinateur exécutant Microsoft Windows Server 2003, le message d’erreur suivant peut apparaître :
Erreur 633-le modem (ou un autre périphérique de connexion) est déjà en cours d’utilisation ou n’est pas configuré correctement.

Cause


Ce problème peut se produire si le port TCP utilisé par la connexion VPN est déjà utilisé par un autre programme. La connexion VPN utilise le port TCP 1723 pour établir une connexion. Si un autre programme utilise déjà ce port, vous ne pouvez pas établir de connexion VPN.

Solution de contournement


Avertissement Si vous utilisez l’éditeur du registre de manière incorrecte, vous pouvez être à l’origine de problèmes importants qui peuvent nécessiter la réinstallation de votre système d’exploitation. Microsoft ne peut pas garantir que vous pouvez résoudre les problèmes résultant de l’utilisation incorrecte de l’éditeur du Registre. Utilisez l’éditeur du Registre à vos propres risques. Pour contourner ce problème, appliquez l'une des méthodes suivantes :
  • Réservez explicitement le port TCP qui est utilisé pour la connexion VPN. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, sur exécuter, tapez regedit. exe dans la zone ouvrir , puis cliquez sur OK.
    2. Dans l’éditeur du Registre, recherchez la sous-clé de Registre suivante et cliquez dessus :
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    3. Dans le menu modifier , pointez sur nouveau, puis cliquez sur valeur de plusieurs chaînes.
    4. Renommez la valeur multichaîne « ReservedPorts », puis double-cliquez sur ReservedPorts.
    5. Dans la zone données de la valeur , tapez 1723-1723, puis cliquez sur OK.
    6. Quittez l’Éditeur du Registre.
  • Utilisez la commande netstat pour rechercher le programme qui utilise le port 1723. Ensuite, terminez le processus pour ce programme. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, sur exécuter, tapez cmd. exe dans la zone ouvrir , puis cliquez sur OK.
    2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      netstat-AON
    3. Dans la sortie qui s’affiche, identifiez l’ID de processus du programme, le cas échéant, qui utilise le port TCP 1723.
    4. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      taskkill/PID PID /f
      Remarque La commande taskkill arrête le processus qui correspond au numéro d’ID de processus. L’option /f est utilisée pour forcer le processus.
    5. À l’invite de commandes, tapez Exit, puis appuyez sur entrée pour quitter l’invite de commandes.
  • Redémarrez votre ordinateur. Le programme qui utilise le port TCP 1723 doit donc utiliser un port différent.