Message d’erreur lorsque vous exécutez un rapport personnalisé de Crystal Reports dans Microsoft Dynamics SL : « erreur du moteur d’impression de Crystal : 709, la table est introuvable. »


Symptômes


Considérez le scénario suivant :
  • Vous exécutez Microsoft Dynamics SL 7.0 ou Microsoft Dynamics SL 2011.
  • Vous utilisez un rapport personnalisé de Crystal Reports.
  • Vous ouvrez une session en utilisant l’authentification Windows.
Dans ce cas de figure, le message d’erreur suivant s’affiche :
Application d’auxiliaire de rapports Crystal pour Solomon IV
Obtenir les requêtes SQL échec de rapport : C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT
Erreur du moteur d’impression de Crystal : 709 - Erreur dans le fichier C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT :

La table est introuvable.

Cause


Cause 1

Cette erreur se produit car les conditions suivantes sont remplies :
  • Le rapport Crystal Reports utilise une ou plusieurs tables personnalisées ou des affichages personnalisés.
  • L’utilisateur E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server ou le rôle d’application MSDSL SQL Server n’a pas les autorisations requises pour le tableau personnalisé ou à la vue personnalisée. Reportez-vous à la section 1 de résolution dans la section « Résolution ».

Cause 2

Une connexion ODBC Open Database Connectivity () est correctement configurée pour utiliser l’authentification Windows au lieu de l’authentification SQL Server. Lorsque vous exécutez un rapport Crystal Reports sur un nouveau poste de travail, une connexion ODBC est créée pour la base de données du système de Microsoft Dynamics SL et pour la base de données de l’application Microsoft Dynamics SL. Cette connexion doit être configurée pour utiliser l’authentification SQL Server, même si vous utilisez l’authentification Windows pour vous connecter à Microsoft Dynamics SL. Reportez-vous à la section Résolution 2 dans la section « Résolution ».

Résolution


Résolution 1

Affecter les droits appropriés sur la table personnalisée ou à la vue personnalisée. Pour ce faire, procédez comme suit :
  1. Démarrez Microsoft SQL Server Management Studio.
  2. Développez bases de données, développez la base de données Dynamics SL et puis développez Tables ou vues.
  3. Recherchez le tableau personnalisé ou l’affichage personnalisé dans la liste.
  4. Cliquez sur le tableau personnalisé ou l’affichage personnalisé. Puis, cliquez sur Propriétés.
  5. Dans le volet Sélectionner une Page , cliquez sur autorisations.
  6. Cliquez sur Ajouter, tapez MSDSL, puis cliquez sur OK.
  7. Pour Sélectionner les autorisations, cliquez pour sélectionner la case à cocher Autoriser .
  8. Cliquez sur Ajouter.
  9. Cliquez sur Parcourir. Puis, activez la case à cocher en regard de l’utilisateur E7F575915A2E4897A517779C0DD7CE .
  10. Cliquez deux fois sur OK.
  11. Pour l' autorisation de contrôle, activez la case à cocher Autoriser .

Résolution 2

Pour résoudre ce problème, supprimez les connexions ODBC et permettent de recréer les connexions Microsoft Dynamics SL. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez sur paramètres, puis cliquez sur Panneau de configuration.
  2. Cliquez sur Outils d’administration.
  3. Cliquez sur Sources de données (ODBC).
  4. Sous l’onglet DSN utilisateur , supprimez toutes les entrées de la base de données du système de Microsoft Dynamics SL et de la base de données de l’application Microsoft Dynamics SL.
  5. Sous l’onglet DSN système , supprimez les entrées de la base de données du système de Microsoft Dynamics SL et de la base de données de l’application Microsoft Dynamics SL.
  6. Une nouvelle session pour Microsoft Dynamics SL, puis essayez à nouveau d’utiliser le rapport. Les entrées de sources de données utilisateur doivent être recréées automatiquement.