Événement d’erreur lorsque vous essayez de démarrer le Service Microsoft Dynamics CRM E-mail Router dans Microsoft Dynamics CRM : « le service E-mail Router ne peut pas exécuter le thread principal d’arrière-plan du service »

S’applique à : Microsoft Dynamics CRM 2011Dynamics CRM 4.0

Symptômes


Lorsque vous essayez de démarrer le Service Microsoft Dynamics CRM E-mail Router dans Microsoft Dynamics CRM, l’événement erreur suivant est enregistré dans le journal d’Application :

Cause


Ce problème se produit car le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est endommagé.

Résolution



Ce problème a été résolu dans la mise à jour de correctif cumulatif 13 de Dynamics CRM 4.0. Consultez http://support.microsoft.com/kb/2308072 Ko pour plus d’informations. Ce problème a également été résolu dans Microsoft Dynamics CRM 2011.

Si vous n’êtes pas sur la mise à jour de correctif cumulatif 13, pour résoudre ce problème, procédez comme suit :
  1. Supprimez le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml.


    Remarques
    • Par défaut, le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est dans le dossier suivant :
      C:\Program Files\Microsoft CRM Email\Service.
    • Par défaut, le dossier est un dossier masqué. Pour afficher ce dossier, vous devez modifier les paramètres de l’Explorateur Windows pour afficher les fichiers masqués et les dossiers masqués.
  2. Redémarrez le Service Microsoft Dynamics CRM E-mail Router.

    Le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est recréé.

Si les utilisateurs de Microsoft Dynamics CRM sont définies pour utiliser l’E-mail Router et pas un lettres de transfert pour les messages entrants, il est possible de revenir à Microsoft Dynamics CRM après l’implémentation de cette solution de messages supprimés. Si un message électronique n’a pas été supprimé à partir de la boîte aux lettres de l’utilisateur, le routeur de messagerie pourrait trouver l’e-mail de l’utilisateur dans leur boîte de réception, pas trouver dans Microsoft Dynamics CRM et créer de nouveau le message électronique dans Microsoft Dynamics CRM. Pour éviter cela, les e-mails devraient également être supprimés à partir de la boîte aux lettres de l’utilisateur avec Microsoft Dynamics CRM.

Pour éviter cette situation, régulièrement d’effectuer une sauvegarde des fichiers suivants et de les stocker sur le bureau du même serveur.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml


Si le Gestionnaire de Configuration de Microsoft Dynamics CRM E-mail Router ne parvient pas au démarrage ou le service Microsoft Dynamics CRM E-mail Router ne démarre pas, remplacez les 2 fichiers ci-dessus dans C:\Program Files\Microsoft CRM Email\Service. Redémarrez le service Microsoft Dynamics CRM E-mail Router, puis lancez le Gestionnaire de Configuration de Microsoft Dynamics CRM E-mail Router. Si la sauvegarde de ces fichiers est plus récente, elle aura la configuration complète de l’E-mail Router.

Références


2012555 le Gestionnaire de configuration E-mail d’erreur n’a pas pu lire les informations de configuration se produit lorsque vous lancez le Gestionnaire de Configuration de Microsoft Dynamics CRM E-mail Router