Sur un ordinateur basé sur Windows Server 2003 R2 ou Windows Server 2008 qui héberge les partages NFS, les demandes d’e/s excessives peuvent provoquer une condition TCPZeroWindow et la connexion NFS ne redémarre pas comme prévu

S’applique à : Windows Server 2008 StandardWindows Server 2008 EnterpriseWindows Server 2008 Datacenter

Symptômes


Vous avez un ordinateur basé sur Windows Server 2003 R2 ou Windows Server 2008 avec Microsoft Services pour Network File System (MSNFS) installé et qui exporte des partages NFS pour les clients NFS. Lorsque les demandes d’e/s excessives sont générées par les clients NFS sur les partages NFS, vous pouvez rencontrer les problèmes suivants :
  • Si vous utilisez la capture réseau, vous pouvez constater que la taille de la fenêtre pour une connexion TCP est réduite à 0, ce qui s’appelle une condition TCPZeroWindow.
  • Si vous essayez d’accéder aux partages NFS, vous pouvez trouver des erreurs e/s pour la connexion correspondante semblable à la suivante :
    Erreur d’entrée/sortie
  • La connexion NFS ne redémarre pas comme prévu. Finalement, toutes les connexions de NFS pour le serveur accéder au même état.

Cause


Ce problème se produit car le pilote de représentation externe des données appel de procédure à distance (Rpcxdr.sys) ne peut pas redémarrer correctement les connexions TCP lorsqu’il y a de nombreuses demandes d’e/s.

Résolution


Informations sur le correctif Windows Server 2003

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Aucune condition préalable.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif préalablement publié.

Informations concernant le Registre

Pour utiliser ce correctif logiciel, vous n'avez aucune modification à apporter au Registre.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.

Windows Server 2003, versions basées sur les x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateformeSP requisDossier
Rpcxdr.sys5.2.3790.323569,63225-Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.323569,63225 - Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.323569,63225 - Oct-200813:37x86SP1SP1QFE
Rpcxdr.sys5.2.3790.439869,63225 - Oct-200819:13x86SP2SP2QFE
Rpcxdr.sys5.2.3790.439869,63225 - Oct-200819:13x86SP2SP2QFE
Rpcxdr.sys5.2.3790.439869,63225- Oct-200819:13x86SP2SP2QFE
Windows Server 2003, versions basées sur les x64
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateformeSP requisDossier
Rpcxdr.sys5.2.3790.3235106,49627-Oct-200806:31x64SP1SP1QFE
Rpcxdr.sys5.2.3790.4398106,49627 -Oct-200806:44x64SP2SP2QFE

Informations sur le correctif pour Windows Server 2008

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

D'importants correctifs de Windows Vista et Windows Server 2008 sont inclus dans les mêmes packages. Toutefois, un seul de ces produits peut être répertorié dans la page demande de correctif « ». Pour demander le package de correctif qui s’applique à Windows Vista et Windows Server 2008, sélectionnez simplement le produit figurant sur la page.

Conditions préalables

Aucune condition préalable.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif préalablement publié.

Informations concernant le Registre

Pour utiliser ce correctif logiciel, vous n'avez aucune modification à apporter au Registre.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.

Windows Server 2008, versions basées sur les x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Rpcxdr.mofNe s'applique pas4,42418-Dec-200721:26Ne s'applique pas
Rpcxdr.sys6.0.6001.2233676,80022-Dec-200801:47x86
Windows Server 2008, versions basées sur les x64
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Rpcxdr.mofNe s'applique pas4,42418-Dec-200721:26Ne s'applique pas
Rpcxdr.sys6.0.6001.2233689,60022-Dec-200802:14x64
Windows Server 2008, les versions basés sur IA-64
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Rpcxdr.mofNe s'applique pas4,42418-Dec-200721:26Ne s'applique pas
Rpcxdr.sys6.0.6001.22336229,88822-Dec-200801:54IA-64

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


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Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft