Il peut être utile de disposer d’un compte du nombre d’enregistrements contenus dans un rapport. Dans les rapports groupés ou de synthèse, vous pouvez afficher le nombre d’enregistrements présents dans chaque groupe. Vous pouvez également ajouter un numéro de ligne à chaque enregistrement pour faciliter la référence à chacun d’eux. Cet article explique, étape par étape, comment ajouter des nombres et des numéros de ligne à votre rapport.
Que voulez-vous faire ?
- Compter le nombre d’enregistrements dans un rapport ou un groupe
- Ajouter un numéro de ligne pour chaque enregistrement d’un état ou d’un groupe
Compter le nombre d’enregistrements dans un rapport ou un groupe
Le mode Page constitue le moyen le plus rapide d’ajouter des nombres à votre rapport.
Compter des enregistrements en mode Page
Dans le volet de navigation, cliquez avec le bouton droit sur l’état, puis cliquez sur Mode Page dans le menu contextuel.
Cliquez sur un champ à compter. Pour vous assurer que tous les enregistrements sont comptés, cliquez sur un champ dont vous savez qu’il ne contient pas de valeurs Null, comme un champ Réf.
Sous l’onglet Créer, dans le groupe Regroupement et totaux, cliquez sur Totaux.
Effectuez l’une des opérations suivantes :
Pour compter tous les enregistrements du rapport, que le champ sélectionné contienne ou non une valeur, cliquez sur Compter les enregistrements.
Pour compter uniquement les enregistrements pour lesquels le champ sélectionné contient une valeur, cliquez sur Compter les valeurs.
Remarque
L’option Valeurs d’inventaire n’est pas disponible pour les champs des types de données suivants :
- Texte long (mémo)
- Objet OLE
- Lien hypertexte
- Pièce jointe
Access ajoute une zone de texte à la section Pied d’état et affecte sa propriété Source de contrôle à une expression qui exécute la fonction Compte . S’il existe des niveaux de regroupement dans votre rapport, Access ajoute également une zone de texte à chaque pied de groupe qui effectue le même calcul.
Remarque
Si vous utilisez le mode Page pour créer un dénombrement sur un champ spécifique, Access génère une expression qui compte uniquement les enregistrements dans lesquels le champ n’est pas Null. Par exemple, si le rapport contient 10 enregistrements et que vous ajoutez le nombre à un champ qui contient trois valeurs Null, la zone de texte Compte affiche 7 (les nombres enregistrés contenant des valeurs non Null). Vous pouvez éviter cette situation en ajoutant des comptes uniquement aux champs qui n’autorisent pas les valeurs Null (tels que les champs d’ID). Vous pouvez également modifier la source de contrôle de la zone de texte afin qu’elle compte toujours tous les enregistrements, qu’ils contiennent des valeurs Null ou non. Pour ce faire :
Sélectionnez la zone de texte qui affiche le nombre. Si la feuille de propriétés n’est pas affichée, appuyez sur F4.
Cliquez sur l’onglet Données.
Dans la zone de propriété Source contrôle, supprimez l’expression et tapez =Count(*).
Enregistrez le rapport et basculez vers l’affichage Rapport pour afficher les résultats.
Compter des enregistrements en mode Création
Dans le volet de navigation, cliquez avec le bouton droit sur le rapport et cliquez sur Mode Création dans le menu contextuel.
Sous l’onglet Création, dans le groupe Contrôles, cliquez sur Zone de texte.
Effectuez l’une des opérations suivantes :
- Pour ajouter un nombre de tous les enregistrements de l’état, cliquez sur la section En-tête d’état ou Pied d’état à l’emplacement où vous souhaitez placer la zone de texte.
- Pour ajouter un nombre de tous les enregistrements dans chaque groupe d’un rapport groupé, cliquez sur la section En-tête de groupe ou Pied de groupe à l’emplacement où vous souhaitez placer la zone de texte.
Sélectionnez la zone de texte et appuyez sur F4 pour afficher la feuille de propriétés.
Cliquez sur l’onglet Données.
Dans la zone de propriété Source contrôle, tapez =Count(*).
La fonction Compte utilisée dans cette expression permet de compter tous les enregistrements de l’état ou du groupe, même si certains champs de certains enregistrements sont Null. Pour compter les enregistrements uniquement dans lesquels un champ spécifique n’est pas Null (par exemple, NomFournisseur), utilisez plutôt l’expression suivante : =CDbl(Nz(Count([NomFournisseur]),0)).
Haut de la page
Ajouter un numéro de ligne pour chaque enregistrement d’un état ou d’un groupe
Vous pouvez numéroter des éléments dans votre rapport. Par exemple, dans un rapport Ventes par produit, vous souhaiterez peut-être que « 1 » précède le premier élément d’un groupe de produits, « 2 » précède le deuxième élément, etc. Lorsque le groupe de produits suivant commence, le décompte recommence et « 1 » précède le premier élément.
Vous pouvez numéroter les éléments de votre état à l’aide d’un contrôle calculé et en définissant sa propriété Somme cumulée .
- Dans le volet de navigation, cliquez avec le bouton droit sur l’état, puis cliquez sur Mode Création dans le menu contextuel.
- Sous l’onglet Création, dans le groupe Contrôles, cliquez sur Zone de texte.
- Dans la section Détails du rapport, faites glisser le pointeur pour créer la zone de texte, en vous assurant qu’elle est suffisamment large pour accueillir le plus grand numéro d’élément.
Par exemple, si vous avez probablement une centaine de commandes, vous aurez besoin d’espace pour au moins trois caractères (100). Si une étiquette apparaît en regard de la zone de texte, supprimez-la en cliquant dessus et en appuyant sur SUPPR. Si vous placez la zone de texte près de la marge gauche, l’étiquette peut être masquée sous la zone de texte. À l’aide de la poignée de déplacement située dans le coin supérieur gauche de la zone de texte, faites glisser la zone de texte vers la droite pour voir l’étiquette. Vous pouvez ensuite cliquer sur l’étiquette, puis appuyer sur SUPPR. - Sélectionnez la zone de texte. Si la feuille de propriétés n’est pas affichée, appuyez sur F4.
- Cliquez sur l’onglet Tous . Dans la zone de propriété Nom , tapez un nom tel que txtItemNumber.
- Cliquez sur l’onglet Données.
- Dans la zone de propriété Somme cumulée , sélectionnez Au-dessus du groupe.
- Dans la zone de propriété Source du contrôle , tapez =1.
- Cliquez sur l’onglet Format.
- Dans la zone de propriété Format , tapez #. (signe dièse suivi d’un point).
Cela met en forme le numéro de ligne avec un point après le numéro. - Enregistrez le rapport et basculez vers l’affichage Rapport pour afficher les résultats.
Haut de la page