Cet article décrit le processus de base du démarrage d’Access et de la création d’une base de données qui sera utilisée sur des ordinateurs de bureau, et non sur le web. Il explique comment créer une base de données de bureau à l’aide d’un modèle et comment créer une base de données à partir de zéro en créant vos propres tables, formulaires, états et autres objets de base de données. Il explique également certaines techniques que vous pouvez utiliser pour obtenir des données existantes dans votre nouvelle base de données.
Contenu de cet article
- Présentation
- Créer une base de données à l’aide d’un modèle
- Créer une base de données sans utiliser de modèle
- Copier des données d’une autre source dans une table Access
- Importer, ajouter ou lier des données d’une autre source
- Ajouter un composant d’application
- Ouvrir une base de données Access existante
Présentation
Lorsque vous démarrez Access pour la première fois, ou si vous fermez une base de données sans fermer Access, le mode Microsoft Office Backstage s’affiche.
Le mode Backstage est un point de départ à partir duquel vous pouvez créer une base de données, ouvrir une base de données existante, afficher le contenu proposé à partir de Office.com c’est-à-dire tout ce que vous pouvez faire avec Access dans un fichier de base de données ou en dehors d’une base de données, par opposition à une base de données située dans une base de données.
Création d’une base de données
Lorsque vous ouvrez Access, le mode Backstage affiche l’onglet Nouveau . L’onglet Nouveau offre plusieurs méthodes pour créer une base de données :
- Une base de données vide Vous pouvez repartir de zéro si vous le souhaitez. Cette option est idéale si vous avez des exigences de conception très spécifiques ou si vous disposez de données existantes que vous devez prendre en charge ou incorporer.
- Un modèle installé avec Access Envisagez d’utiliser un modèle si vous démarrez un nouveau projet et que vous souhaitez prendre de l’avance. Access est fourni avec plusieurs modèles installés par défaut.
- Modèle de Office.com Outre les modèles fournis avec Access, vous pouvez trouver de nombreux autres modèles sur Office.com. Vous n’avez même pas besoin d’ouvrir un navigateur, les modèles sont disponibles dans l’onglet Nouveau .
Ajout à une base de données
Une fois que vous travaillez dans une base de données, vous pouvez ajouter des champs, des tables ou des parties d’application.
Les composants d’application sont une fonctionnalité qui vous permet d’utiliser plusieurs objets de base de données connexes comme s’il s’agissait d’un seul. Par exemple, une partie d’application peut être constituée d’une table et d’un formulaire basé sur la table. Vous pouvez ajouter la table et le formulaire en même temps en utilisant la partie application.
Vous pouvez également créer des requêtes, des formulaires, des états, des macros - tous les objets de base de données avec lesquels vous avez l’habitude de travailler.
Créer une base de données à l’aide d’un modèle
Access propose de nombreux modèles que vous pouvez utiliser tels quels ou comme point de départ. Un modèle est une base de données prête à l’emploi qui contient toutes les tables, requêtes, formulaires, macros et états nécessaires à l’exécution d’une tâche spécifique. Par exemple, il existe des modèles que vous pouvez utiliser pour suivre les problèmes, gérer les contacts ou conserver un registre des dépenses. Certains modèles contiennent quelques exemples d’enregistrements pour illustrer leur utilisation.
Si l’un de ces modèles correspond à vos besoins, son utilisation est généralement le moyen le plus rapide de démarrer une base de données. Toutefois, si vous avez des données dans un autre programme que vous voulez importer dans Access, vous pouvez décider qu’il est préférable de créer une base de données sans utiliser de modèle. Les modèles ont une structure de données déjà définie et l’adaptation de vos données existantes à la structure du modèle peut nécessiter beaucoup de travail.
- Si vous avez une base de données ouverte, cliquez sur Fermer, dans l’onglet Fichier. Le mode Backstage affiche l’onglet Nouveau .
- Plusieurs ensembles de modèles sont disponibles dans l’onglet Nouveau , dont certains sont intégrés à Access. Vous pouvez télécharger des modèles supplémentaires à partir de Office.com. Pour plus d’informations, consultez la section suivante de cet article.
- Sélectionnez le modèle que vous souhaitez utiliser.
- Access suggère un nom de fichier pour votre base de données dans la zone Nom de fichier. Vous pouvez modifier le nom de fichier si vous le souhaitez. Pour enregistrer la base de données dans un dossier différent de celui affiché sous la zone Nom de fichier, cliquez sur
, accédez au dossier dans lequel vous souhaitez l’enregistrer, puis cliquez sur OK. Vous pouvez également créer et lier votre base de données à un site SharePoint. - Cliquez sur Créer.
Access crée une base de données à partir du modèle que vous avez choisi, puis ouvre la base de données. Pour de nombreux modèles, un formulaire s’affiche dans lequel vous pouvez commencer à saisir des données. Si votre modèle contient des exemples de données, vous pouvez supprimer chaque enregistrement en cliquant sur le sélecteur d’enregistrement (la zone ou la barre ombrée située juste à gauche de l’enregistrement), puis en procédant comme suit :
Dans l’onglet Accueil, dans le groupe Enregistrements, cliquez sur Supprimer.
- Pour commencer à saisir des données, cliquez dans la première cellule vide du formulaire, puis commencez à taper. Utilisez le volet de navigation pour rechercher d’autres formulaires ou rapports que vous pourriez vouloir utiliser. Certains modèles incluent un formulaire de navigation qui vous permet de vous déplacer entre les différents objets de base de données.
Pour plus d’informations sur l’utilisation de modèles, voir l’article Utiliser un modèle pour créer une base de données Access de bureau.
Haut de la page
Créer une base de données sans utiliser de modèle
Si vous n’êtes pas intéressé par l’utilisation d’un modèle, vous pouvez créer une base de données en construisant vos propres tables, formulaires, états et autres objets de base de données. Dans la plupart des cas, il s’agit de l’une des situations suivantes ou des deux :
- Saisir, coller ou importer des données dans la table qui est créée lors de la création d’une base de données, puis répéter le processus avec les nouvelles tables créées à l’aide de la commande Table de l’onglet Créer .
- Importer des données à partir d’autres sources et créer de nouvelles tables dans le processus.
Créer une base de données vide
- Sous l’onglet Fichier , cliquez sur Nouveau, puis sur Base de données vide.
- Entrez un nom de fichier dans la zone Nom de fichier . Pour modifier l’emplacement du fichier par défaut, cliquez sur Rechercher un emplacement pour placer votre base de données
(en regard de la zone Nom de fichier ), accédez au nouvel emplacement, puis cliquez sur OK. - Cliquez sur Créer.
Access crée la base de données avec une table vide nommée Table1, puis ouvre Table1 en mode Feuille de données. Le curseur est placé dans la première cellule vide de la colonne Cliquer pour ajouter . - Commencez à taper pour ajouter des données ou les coller à partir d’une autre source, comme décrit dans la section Copier des données d’une autre source dans une table Access.
La saisie de données en mode Feuille de données est conçue pour être très similaire au travail dans une feuille de calcul Excel. La structure du tableau est créée lorsque vous entrez des données. Lorsque vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit automatiquement le type de données de chaque champ, en fonction des données que vous entrez.
Si vous ne souhaitez pas saisir de données dans le tableau 1 pour l’instant, cliquez sur Fermer
. Si vous avez apporté des modifications à la table, Access vous invite à enregistrer ces modifications. Cliquez sur Oui pour enregistrer vos modifications, cliquez sur Non pour les ignorer ou cliquez sur Annuler pour laisser le tableau ouvert.
Conseil
Access recherche un fichier nommé Blank.accdb dans le dossier situé dans [lecteur d’installation] :\Program Files\MicrosoftOffice\Templates\1033\Access\. Si tel est le cas, Blank.accdb est le modèle pour toutes les nouvelles bases de données vides. Tout contenu qu’il contient est hérité par toutes les nouvelles bases de données vides. Il s’agit d’un bon moyen de distribuer du contenu par défaut, tel que des numéros de pièce ou des clauses d’exclusion de responsabilité et des stratégies de l’entreprise.
Important
Si vous fermez la table 1 sans l’enregistrer au moins une fois, Access supprime la table entière, même si vous y avez entré des données.
Ajouter un tableau
Vous pouvez ajouter de nouvelles tables à une base de données existante à l’aide des commandes du groupe Tables de l’onglet Créer .
Créer une table, en commençant par le mode Feuille de données En mode Feuille de données, vous pouvez entrer des données immédiatement et laisser Access créer la structure de la table en arrière-plan. Les noms de champ sont affectés numériquement (Champ1, Champ2, etc.) et Access définit automatiquement le type de données de chaque champ en fonction des données que vous entrez.
- Sous l’onglet Création, dans le groupe Tables, cliquez sur Table.
Access crée le tableau et sélectionne la première cellule vide dans la colonne Cliquer pour ajouter . - Sous l’onglet Champs de table , dans le groupe Ajouter & supprimer , cliquez sur le type de champ que vous souhaitez ajouter. Si vous ne voyez pas le type souhaité, cliquez sur Autres champs
. - Access affiche une liste des types de champs couramment utilisés. Cliquez sur le type de champ souhaité, et Access ajoute le nouveau champ à la feuille de données au point d’insertion.
Vous pouvez déplacer le champ en le faisant glisser. Lorsque vous faites glisser un champ dans une feuille de données, une barre d’insertion verticale s’affiche à l’emplacement où le champ sera placé. - Pour ajouter des données, commencez à taper dans la première cellule vide ou collez les données d’une autre source, comme décrit dans la section Copier des données d’une autre source dans une table Access.
- Pour renommer une colonne (champ), double-cliquez sur l’en-tête de colonne, puis tapez le nouveau nom.
Vous devez donner un nom significatif à chaque champ, afin de pouvoir identifier son contenu quand il apparaît dans le volet Liste de champs . - Pour déplacer une colonne, cliquez sur son en-tête pour sélectionner la colonne, puis faites glisser la colonne vers l’emplacement souhaité. Vous pouvez également sélectionner plusieurs colonnes contiguës, puis les faire glisser vers un nouvel emplacement en même temps. Pour sélectionner plusieurs colonnes contiguës, cliquez sur l’en-tête de la première colonne, puis cliquez sur l’en-tête de la dernière colonne tout en maintenant la touche Maj enfoncée.
Créer une table, en commençant par le mode Création En mode Création, vous créez d’abord la structure de la table. Vous pouvez ensuite passer en mode Feuille de données pour entrer des données, ou pour les entrer à l’aide d’une autre méthode (par exemple, coller ou importer).
Sous l’onglet Créer , dans le groupe Tables , cliquez sur Création de table.
Pour chaque champ de votre table, tapez un nom dans la colonne Nom du champ , puis sélectionnez un type de données dans la liste Type de données .
Si vous le souhaitez, vous pouvez entrer une description pour chaque champ dans la colonne Description . La description s’affiche ensuite dans la barre d’status lorsque le curseur se trouve dans ce champ en mode Feuille de données. La description est également utilisée comme texte de barre de status pour les contrôles d’un formulaire ou d’un état que vous créez en faisant glisser le champ à partir du volet Liste de champs, ainsi que pour tous les contrôles créés pour ce champ lorsque vous utilisez l’Assistant Formulaire ou l’Assistant État.
Après avoir ajouté tous vos champs, enregistrez la table :
- Sous l’onglet Fichier, cliquez sur Enregistrer.
Vous pouvez commencer à taper des données dans la table à tout moment en passant en mode Feuille de données et en cliquant dans la première cellule vide. Vous pouvez également coller des données d’une autre source, tel que décrit dans la section Copier des données d’une autre source dans une table Access.
Définir des propriétés de champ en mode Création Quelle que soit la façon dont vous avez créé votre table, il est judicieux d’examiner et de définir les propriétés de champ. Si certaines propriétés sont disponibles en mode Feuille de données, d’autres propriétés ne peuvent être définies qu’en mode Création. Pour basculer en mode Création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur Mode Création. Pour afficher les propriétés d’un champ, cliquez sur celui-ci dans la grille de création. Les propriétés sont affichées sous la grille de création, sous Propriétés du champ.
Pour afficher une description de chaque propriété de champ, cliquez sur la propriété et lisez la description dans la zone en regard de la liste des propriétés sous Propriétés de champ. Vous pouvez obtenir des informations plus détaillées en cliquant sur le bouton Aide.
Le tableau suivant décrit certaines des propriétés de champ qui sont couramment ajustées.
| Propriété | Description |
|---|---|
| Taille du champ | Pour les champs de texte, cette propriété définit le nombre maximal de caractères pouvant être stockés dans le champ. Le maximum est de 255. Pour les champs numériques, cette propriété définit le type de nombre qui sera stocké (entier long, double, etc.). Pour un stockage de données le plus efficace, il est recommandé d’allouer le moins d’espace nécessaire pour les données. Vous pouvez ajuster la valeur à la hausse ultérieurement, si vos besoins changent. |
| Mise en forme | Cette propriété définit la façon dont les données sont affichées. Cela n’affecte pas les données réelles car elles sont stockées dans le champ. Vous pouvez sélectionner un format prédéfini ou entrer un format personnalisé. |
| masque de saisie | Utilisez cette propriété pour spécifier un modèle pour toutes les données qui seront entrées dans ce champ. Cela permet de s’assurer que toutes les données sont entrées correctement et qu’elles contiennent le nombre de caractères requis. Pour obtenir de l’aide sur la création d’un masque de saisie, cliquez sur le situé à droite de la zone de propriétés. |
| Valeur par défaut | Utilisez cette propriété pour spécifier la valeur par défaut qui apparaîtra dans ce champ chaque fois qu’un nouvel enregistrement sera ajouté. Par exemple, si vous avez un champ Date/Heure dans lequel vous souhaitez toujours enregistrer la date à laquelle l’enregistrement a été ajouté, vous pouvez entrer « Date() » (sans les guillemets) comme valeur par défaut. |
| Requis | Cette propriété définit si une valeur est requise dans ce champ. Si vous attribuez la valeur Oui à cette propriété, Access ne vous permet pas d’ajouter un nouvel enregistrement, sauf si une valeur est entrée pour ce champ. |
Haut de la page
Copier des données d’une autre source dans une table Access
Si vos données sont actuellement stockées dans un autre programme, tel que Excel, vous pouvez les copier et les coller dans une table Access. En général, cela fonctionne mieux si vos données sont déjà séparées en colonnes, comme dans une feuille de calcul Excel. Si vos données sont contenues dans une application traitement de texte, il est préférable de séparer les colonnes de données à l’aide d’onglets ou de les convertir en tableau dans une application traitement de texte avant de copier les données. Si vos données doivent être modifiées ou manipulées (par exemple, séparer les noms complets en prénoms et noms), faites-le avant de copier les données, en particulier si vous ne maîtrisez pas Access.
Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en fonction du type de données qu’il y trouve. Par exemple, si un champ collé ne contient que des valeurs de date, Access applique le type de données Date/Heure à ce champ. Si le champ collé ne contient que les mots « oui » et « non », Access applique le type de données Oui/Non au champ.
Access nomme les champs en fonction de ce qu’il trouve dans la première ligne de données collées. Si la première ligne de données collées est de type semblable aux lignes suivantes, Access détermine que la première ligne fait partie des données et affecte des noms génériques aux champs (F1, F2, etc.). Si la première ligne de données collées n’est pas semblable aux lignes suivantes, Access détermine que la première ligne est constituée de noms de champs. Access nomme les champs en conséquence et n’inclut pas la première ligne dans les données.
Si Access affecte des noms de champs génériques, vous devez les renommer dès que possible afin d’éviter toute confusion. Procédez comme suit :
- Appuyez sur Ctrl+S pour enregistrer la table.
- En mode Feuille de données, double-cliquez sur chaque en-tête de colonne, puis tapez un nom de champ descriptif pour chaque colonne.
- Enregistrez à nouveau la table.
Remarque
Vous pouvez également renommer les champs en passant en mode Création et en modifiant les noms des champs. Pour basculer en mode Création, cliquez avec le bouton droit sur la table dans le volet de navigation, puis cliquez sur Mode Création. Pour revenir au mode Feuille de données, double-cliquez sur la table dans le volet de navigation.
Haut de la page
Importer, ajouter ou lier des données d’une autre source
Vous pouvez avoir des données stockées dans un autre programme et vous voulez les importer dans une nouvelle table ou les ajouter à une table existante dans Access. Vous pouvez également travailler avec des personnes qui conservent leurs données dans d’autres programmes et que vous souhaitez utiliser dans Access en créant un lien vers celles-ci. Dans les deux cas, Access facilite l’utilisation de données provenant d’autres sources. Vous pouvez importer des données d’une feuille de calcul Excel, d’un tableau d’une autre base de données Access, d’une liste SharePoint ou de diverses autres sources. Le processus que vous utilisez diffère légèrement en fonction de votre source, mais la procédure suivante vous aidera à démarrer.
Dans Access, dans l’onglet Données externes , dans le groupe Importer & lien , sélectionnez Nouvelle source de données, puis sélectionnez la commande correspondant au type de fichier que vous importez.
Par exemple, si vous importez des données à partir d’une feuille de calcul Excel, cliquez sur Nouvelle source>de données à partir du fichier>Excel.Remarque
Si vous ne trouvez pas le type de format approprié dans le groupe Importer & Lien , vous devrez peut-être démarrer le programme dans lequel vous avez créé les données, puis utiliser ce programme pour enregistrer les données dans un format de fichier courant (par exemple, un fichier texte délimité) avant de pouvoir importer ces données dans Access.
Dans la boîte de dialogue Obtenir des données externes , cliquez sur Parcourir pour rechercher le fichier de données source ou tapez le chemin complet du fichier de données source dans la zone Nom de fichier.
Cliquez sur l’option de votre choix (tous les programmes vous permettent d’importer, et d’autres d’ajouter ou de lier) sous Spécifier comment et où vous voulez stocker les données dans la base de données active. Vous pouvez créer une table qui utilise les données importées ou (avec certains programmes) vous pouvez ajouter les données à une table existante ou créer une table liée qui maintient un lien avec les données du programme source.
Si un Assistant démarre, suivez les instructions fournies sur les pages suivantes de l’Assistant. Sur la dernière page de l’Assistant, cliquez sur Terminer.
Si vous importez des objets ou liez des tables à partir d’une base de données Access, la boîte de dialogue Importer des objets ou Lier des tables s’affiche. Choisissez les éléments souhaités, puis cliquez sur OK.
Le processus exact dépend de votre choix d’importer, d’ajouter ou de lier des données.Access vous invite à indiquer si vous souhaitez enregistrer les détails de l’opération d’importation que vous venez de terminer. Si vous pensez que vous allez effectuer à nouveau la même opération d’importation à l’avenir, cliquez sur Enregistrer les étapes d’importation, puis entrez les détails. Vous pouvez ensuite répéter facilement l’opération à l’avenir en cliquant sur Importations
enregistrées dans le groupe Importer & lien sous l’onglet Données externes . Si vous ne souhaitez pas enregistrer les détails de l’opération, cliquez sur Fermer.
Si vous choisissez d’importer une table, Access importe les données dans une nouvelle table, puis affiche la table sous le groupe Tables dans le volet de navigation. Si vous choisissez d’ajouter des données à une table existante, les données sont ajoutées à cette table. Si vous choisissez de lier des données, Access crée une table liée sous le groupe Tables dans le volet de navigation.
Haut de la page
Ajouter un composant d’application
Vous pouvez utiliser un composant d’application pour ajouter des fonctionnalités à une base de données existante. Un composant d’application peut être aussi simple qu’un seul tableau, ou il peut comprendre plusieurs objets connexes, tels qu’un tableau et un formulaire lié.
Par exemple, la partie de l’application Commentaires se compose d’une table comportant un champ ID NuméroAuto, un champ Date et un champ Mémo. Vous pouvez l’ajouter à n’importe quelle base de données et l’utiliser en l’état, ou avec une personnalisation minimale.
- Ouvrez la base de données à laquelle vous souhaitez ajouter un composant d’application.
- Cliquez sur l’onglet Créer .
- Dans le groupe Modèles , cliquez sur Composants d’application. Une liste des pièces disponibles s’ouvre.
- Cliquez sur la partie application que vous souhaitez ajouter.
Haut de la page
Ouvrir une base de données Access existante
Sous l’onglet Fichier, cliquez sur Ouvrir.
Dans la boîte de dialogue Ouvrir , accédez à la base de données que vous souhaitez ouvrir.
Effectuez l’une des opérations suivantes :
- Double-cliquez sur la base de données pour l’ouvrir dans le mode par défaut spécifié dans la boîte de dialogue Options Access ou le mode défini par une stratégie d’administration.
- Cliquez sur Ouvrir pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur de sorte que vous et d’autres utilisateurs puissiez lire et écrire dans la base de données.
- Cliquez sur la flèche en regard du bouton Ouvrir , puis cliquez sur Ouvrir en lecture seule pour ouvrir la base de données et la soumettre en lecture seule afin de pouvoir l’afficher mais pas la modifier. Les autres utilisateurs peuvent toujours lire et écrire dans la base de données.
- Cliquez sur la flèche en regard du bouton Ouvrir , puis sur Ouvrir en exclusif pour ouvrir la base de données à l’aide de l’accès exclusif. Lorsqu’une base de données est ouverte avec un accès exclusif, toute autre personne qui essaie d’ouvrir la base de données reçoit un message « fichier en cours d’utilisation ».
- Cliquez sur la flèche en regard du bouton Ouvrir , puis sur Ouvrir en lecture seule exclusive pour ouvrir la base de données et l’accéder en lecture seule. D’autres utilisateurs peuvent toujours ouvrir la base de données, mais ils sont limités au mode lecture seule.
Remarque
Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe, tel que dBASE, MicrosoftExchange ou Excel. Vous pouvez également ouvrir directement n’importe quelle source de données ODBC, telle que MicrosoftSQL Server. Access crée automatiquement une base de données Access dans le même dossier que le fichier de données et ajoute des liens vers chaque table de la base de données externe.
Conseils
- Pour ouvrir l’une des dernières bases de données ouvertes, dans l’onglet Fichier , cliquez sur Récent, puis sur le nom de fichier de cette base de données. Access ouvre la base de données avec les mêmes paramètres d’options que la dernière fois que vous l’avez ouverte. Si la liste des derniers fichiers utilisés n’est pas affichée, cliquez sur l’onglet Fichier, cliquez sur Options. Dans la boîte de dialogue Options Access , cliquez sur Paramètres client. Sous Afficher, entrez le nombre de documents à afficher dans la liste Documents récents, jusqu’à un maximum de 50.
Vous pouvez également afficher les bases de données récentes dans la barre de navigation du mode Backstage, pour un accès en deux clics : 1) l’onglet Fichier , 2) la base de données récente que vous souhaitez ouvrir. Dans la partie inférieure de l’onglet Récent, activez la case à cocher Accéder rapidement à ce nombre de bases de données récentes case activée, puis ajustez le nombre de bases de données correspondant à l’affichage. - Si vous ouvrez une base de données en cliquant sur la commande Ouvrir de l’onglet Fichier , vous pouvez afficher la liste des raccourcis vers les bases de données précédemment ouvertes en cliquant sur Mes documents récents dans la boîte de dialogue Ouvrir .
Haut de la page
