Un mappage XML et les informations de sa source de données sont enregistrés avec le classeur, et non avec une feuille de calcul spécifique. Un utilisateur malveillant pourrait afficher ces informations cartographiques potentiellement sensibles à l’aide d’une macro Visual Basic pour Applications (VBA). Si vous enregistrez votre classeur sous la forme d’un fichier au format Excel Open XML prenant en charge les macros, vous pouvez afficher ces informations cartographiques à l’aide du Bloc-notes ou d’un autre programme d’édition de texte.
Remarque
Les fonctionnalités de mappage XML sont uniquement disponibles dans Excel pour Windows Desktop. Elles ne sont pas disponibles dans Excel pour Mac ou Excel sur le Web. Les cartes XML sont une fonctionnalité héritée. Pour de nombreux scénarios d’importation et de transformation XML, envisagez d’utiliser Power Query à la place.
Supprimer la définition de source de données du mappage XML du classeur
Si vous souhaitez continuer à utiliser les informations de mappage mais supprimer les informations de source de données potentiellement sensibles, supprimez la définition de source de données du schéma XML du classeur. Dans ce cas, vous pouvez toujours exporter les données XML.
Cette procédure supprime définitivement la définition de source de données actuelle du mappage XML.
Sélectionnez une cellule mappée pour sélectionner la carte XML souhaitée.
Si l’onglet Développeur n’est pas disponible, procédez comme suit pour l’afficher :
- Sous l’onglet Fichier , sélectionnez Options>Personnaliser le ruban.
- Activez la case à case activée Développeur.
Dans l’onglet Développeur , sélectionnez Propriétés de la carte.
Dans la boîte de dialogue Propriétés du mappage XML, sous Source de données, désactivez la case Enregistrer la définition de source de données dans le classeur case activée.
Cette option est sélectionnée par défaut. La suppression de cette option ne supprime aucune donnée de la feuille de calcul.
Important
La définition de source de données contient des informations de connexion sur les données XML importées. La suppression de ces informations empêche les autres utilisateurs de les afficher, mais vous pouvez toujours exporter les données mappées vers un fichier XML. Si vous réimportez le fichier de données XML, la définition de la source de données est à nouveau enregistrée avec le fichier.
Supprimer un mappage XML d’un classeur
Si vous supprimez une feuille de calcul avant de supprimer un mappage XML, les informations de mappage, y compris les détails de la source de données et éventuellement d’autres informations sensibles, restent dans le classeur. Pour supprimer les informations sensibles, supprimez le mappage XML avant de supprimer la feuille de calcul pour supprimer définitivement les informations de mappage du classeur.
Si l’onglet Développeur n’est pas disponible, procédez comme suit pour l’afficher :
- Sous l’onglet Fichier , sélectionnez Options>Personnaliser le ruban.
- Activez la case à case activée Développeur.
Sous l’onglet Développeur , dans le groupe XML , sélectionnez Source.
Dans le volet Office Source XML , sélectionnez Cartes XML.
La boîte de dialogue Cartes XML s’affiche .
Sélectionnez la carte XML à supprimer.
Sélectionnez Supprimer, puis OK.
Remarque
La suppression d’un mappage XML supprime uniquement le mappage XML. Elle ne supprime pas les données auxquelles le mappage XML est actuellement mappé.
Vous avez besoin d’une aide supplémentaire ?
Vous pouvez toujours poser des questions à un expert de la Communauté technique Excel ou obtenir de l’aide dans les Communautés.