HOW TO: Create Two Pie Charts in One in Excel 2000

For a Microsoft Excel 95 and earlier version of this article, see 151355 .

Summary

This step-by-step article shows you how to create two pie charts on one chart sheet in Excel 2000.

Pie charts show the relationship or proportions of the parts to the whole. This chart type is useful for emphasizing a significant element. Normally, a pie chart contains one data series. If you select more than one data series when you create a pie chart, only one data series is displayed. In Microsoft Excel 2000, it is possible to specify a two-series pie chart by defining the chart as a combination chart. By defining the chart as a combination chart, two separate charts are created and each chart can be formatted separately. This article describes how to format both the main and the overlay charts as pie charts.

By defining the chart as a combination chart and formatting both the main and overlay charts as pie charts, Excel plots one chart over the other one so that only one chart is displayed.

To work around this behavior, add a temporary value to both series before plotting the charts, and then explode the slice of the pie that represents the temporary value. By exploding the slice, you reduce the size of the entire pie and expose the bottom chart.

Create Two Pie Charts in One

To create two pie charts on one chart sheet, follow these steps:
  1. Start Excel, open a new workbook, and then create the following worksheet:

    A1: B1: US C1: Asia
    A2: Electronics B2: .28 C2: .30
    A3: Automotive B3: .16 C3: .24
    A4: Software B4: .11 C4: .09
    A5: Textiles B5: .185 C5: .16
    A6: Service B6: .08 C6: .083
    A7: Other B7: .185 C7: .127
  2. Type the following data into the worksheet to create temporary values in cells B8 and C8:

    A8: Temp B8: .90 C8: .90
    NOTE: The temporary values should either be very large or very small values, so that they are easily identified on the chart.
  3. Select cells A1:C8.
  4. On the Insert menu, click Chart.
  5. On the Custom Types tab, under Chart type, select Column-Area.
  6. Click Next three times.
  7. In step 4 of the Chart Wizard, click As new sheet, and then click Finish.
  8. Click the Asia series.
  9. On the Chart menu, click Chart Type.
  10. Under Chart type, click Pie, and then click OK.
  11. Click the US series.
  12. On the Chart menu, click Chart Type.
  13. Under Chart type, click Pie, and then click OK.
  14. Select the largest slice of pie.
  15. Drag the selected slice of pie to the left until it is separated from the rest of the pie slices.

    NOTE: The other slices of the pie chart should not separate from each other.
  16. Switch back to the worksheet, and then select cells A8:C8.
  17. On the Edit menu, point to Clear, and then click All.
  18. Switch to the chart.

    The chart should display a small pie chart on top of a larger pie chart. The top chart, or inner pie chart, represents the values in cells C2:C7. The bottom chart, or outer pie chart, represents the values in cells B2:B7.
  19. Select the legend.
  20. On the Edit menu, point to Clear, and then click All.
  21. To add data labels to the inner pie slices, follow these steps:
    1. Click the inner pie.
    2. On the Format menu, click Selected Data Series.
    3. On the Data Labels tab, under Data labels, click Show label and percent, and then click OK.

      NOTE: To clarify which pie section the label belongs to, you can drag the label to the pie section that it belongs to, or if you drag it outside of the chart area, a connecting line identifies the pie section.
  22. To add data labels on the outer pie slices, follow these steps:
    1. Click the outer pie.
    2. On the Format menu, click Selected Data Series.
    3. On the Data Labels tab, under Data labels, click Show label and percent, and then click OK.

      NOTE: To clarify which pie section the label belongs to, you can drag the label to the pie section that it belongs to, or if you drag it outside of the chart area, a connecting line identifies the pie section.

References

For more information about how to create charts, click Microsoft Excel Help on the Help menu, type create a chart in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

Propriétés

ID d'article : 213928 - Dernière mise à jour : 29 avr. 2008 - Révision : 1

Commentaires