Message d'erreur 112 « le programme d'installation ne peut pas décompresser et copier tous les fichiers de programme »

S’applique à : Windows

Symptômes


Lorsque vous installez un programme localement, ou à partir du site Web Microsoft Windows Update, le message d’erreur suivant s’affiche :
Le programme d’installation ne peut pas décompresser et de copier tous les fichiers de programme nécessaires pour procéder à l’installation. Contactez votre fournisseur de logiciels. erreur 112

Cause


Vous recevez ce message d’erreur en raison de la corruption des fichiers ou pas assez d’espace dans le dossier Windows\Temp.

Résolution


Pour résoudre ce problème, vous pouvez supprimer le contenu du dossier Windows\Temp à partir d’une invite de commande, ou vous pouvez augmenter la quantité d’espace disque disponible sur le lecteur dans lequel se trouve le dossier Temp.

Méthode 1

Pour supprimer le contenu du dossier Temp à partir d’une invite de commande, procédez comme suit :
  1. Cliquez sur Démarrer, sur Arrêter, puis cliquez sur Redémarrer en mode MS-DOS.
  2. À l’invite de commandes, tapez cd\et appuyez sur la touche ENTRÉE.
  3. Tapez la commande suivante
    CD x: \windir\temp
    x est le nom du lecteur sur lequel Windows est installé, puis appuyez sur ENTRÉE.
  4. Tapez la commande suivante
    DEL *. *
    et appuyez sur ENTRÉE.
  5. Tapez exitet appuyez sur ENTRÉE pour revenir à Windows.

Méthode 2

Pour plus d’informations sur l’espace libre sur le disque dur, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
186099 description de l’outil Nettoyage de disque trop

Statut


Ce comportement est inhérent au produit.

Informations supplémentaires


Pour plus d’informations sur la procédure pour déterminer le dossier Windows est installé, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
305792 comment déterminer quel dossier Windows est installé dans