Message d’erreur « Vous n’avez pas l’autorisation d’exécuter l’écran « Comptes de trésorerie » » si vous descendez dans la zone « N° de compte de caisse » dans le rapport 12463, rapport 14902 ou 14903 dans la version russe de Microsoft Dynamics NAV 2009 Service Pack 1


Cet article s’applique à Microsoft Dynamics NAV pour le paramètres régionaux de langue russe (ru).

Symptômes


Supposons que vous utilisez une licence client dans la version russe de Microsoft Dynamics NAV 2009 Service Pack 1 (SP1). Vous exécutez le rapport 12463, rapport de 14902 ou 14903. Dans ce cas, quand vous explorez dans la zone N° de compte de caisse , le message d’erreur suivant s’affiche :
Vous n’avez pas l’autorisation pour exécuter le formulaire « Comptes de caisse ».

Cause


Ce problème se produit car l’écran comptes de disponibilités (35600) est utilisé inattendue dans la propriété LookupFormID pour la case N° de compte de trésorerie .

Résolution


Informations sur le correctif

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Il s’applique uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ce problème, nous vous recommandons d’attendre le prochain service pack Microsoft Dynamics NAV 2009 ou la prochaine version de Microsoft Dynamics NAV qui comprendra ce correctif.

Remarque Dans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.


Informations sur l’installation

Microsoft fournit des exemples de programmation à titre d'illustration uniquement, sans garantie expresse ou implicite. Ceci inclut, mais n'est pas limité à, les garanties implicites de qualité marchande ou d'adéquation à un usage particulier. Cet article suppose que vous êtes familiarisé avec le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les ingénieurs du support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne modifieront pas ces exemples pour fournir des fonctionnalités supplémentaires ou créer des procédures répondant à vos besoins spécifiques.

Remarque Avant d’installer ce correctif, vérifiez que tous les utilisateurs du client Microsoft Navision sont enregistrés sur le système. Cela inclut les utilisateurs du client Microsoft Navision Application Services (NAS). Vous devez être le seul utilisateur client connecté lors de l’implémentation de ce correctif.

Pour appliquer ce correctif, vous devez posséder une licence développeur.

Il est recommandé que le compte d’utilisateur dans la fenêtre Logins Windows ou dans la fenêtre Logins base de données est affecté à l’ID de rôle « SUPER ». Si le compte d’utilisateur ne peut pas être affecté à l’ID de rôle « SUPER », vous devez vérifier que le compte d’utilisateur dispose des autorisations suivantes :
  • L’autorisation de modification pour l’objet que vous allez modifier.
  • L’autorisation d’exécution pour l’objet ID objet système 5210 et pour l’objet ID objet système 9015 .


Remarque Vous n’êtes pas obligé de disposer des droits pour les banques de données excepté si vous devez réparer des données.

Modifications du code

Remarque Toujours tester le code des correctifs dans un environnement contrôlé, avant d'appliquer les correctifs à vos ordinateurs de production.
Pour résoudre ce problème, procédez comme suit :
  1. Modifiez le code dans l’état 12463 comme suit :
    Code existant
    ...      { 1210011;TextBox   ;3410 ;0    ;1700 ;440  ;CaptionML=ENU=Cash Account No.;
    SourceExpr=BankAccount;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Cash Accounts }
    ...

    Code de remplacement
    ...      { 1210011;TextBox   ;3410 ;0    ;1700 ;440  ;CaptionML=ENU=Cash Account No.;
    SourceExpr=BankAccount;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Bank Account List }
    ...

  2. Modifiez le code dans l’état 14902 comme suit :
    Code existant
    ...      { 1210012;TextBox   ;3410 ;0    ;1760 ;440  ;CaptionML=[ENU=Cash Account No.;
    SourceExpr=BankAccountFilter;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Cash Accounts }
    ...

    Code de remplacement
    ...      { 1210012;TextBox   ;3410 ;0    ;1760 ;440  ;CaptionML=[ENU=Cash Account No.;
    SourceExpr=BankAccountFilter;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Bank Account List }
    ...

  3. Modifiez le code dans l’état 14903 comme suit :
    Code existant
    ...      { 1210002;TextBox   ;2860 ;0    ;2420 ;440  ;
    CaptionML=[ENU=Cash Account No.;
    SourceExpr=BankAccountFilter;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Cash Accounts }
    ...

    Code de remplacement
    ...      { 1210002;TextBox   ;2860 ;0    ;2420 ;440  ;
    CaptionML=[ENU=Cash Account No.;
    SourceExpr=BankAccountFilter;
    TableRelation="Bank Account" WHERE (Account Type=CONST(Cash Account));
    LookupFormID=Bank Account List }
    ...

Conditions préalables

Vous devez disposer de la version russe de Microsoft Dynamics NAV 2009 Service Pack 1 pour appliquer ce correctif.

Informations sur la suppression

Vous ne pouvez pas supprimer ce correctif.

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Remarque Il s’agit d’un article de « Dernière minute » créé directement à partir de l’organisation de support technique de Microsoft. Les informations contenues dans ce document sont fournies en l'état, en réponse à des problèmes nouveaux. En raison de la rapidité de leur mise à disposition, les documents peuvent contenir des erreurs typographiques et peuvent être révisés à tout moment sans préavis. Consultez les Conditions d’utilisation pour d’autres considérations.