KB2679368 - Package de mise à jour cumulative 1 pour SQL Server 2012

S’applique à
SQL Server 2012 Business Intelligence SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

INTRODUCTION

Cet article décrit le package de mise à jour cumulative 1 pour Microsoft SQL Server 2012. Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2012.

Remarque Le numéro de build de ce package de mise à jour cumulative est 11.0.2316.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels contenus dans ce package de mise à jour cumulative sont inclus dans SQL Server 2012 Service Pack 1 (SP1).
  • Les correctifs logiciels de SQL Server 2012 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

Informations supplémentaires

Procédure pour obtenir la mise à jour cumulative 1 pour SQL Server 2012

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ces problèmes, il est recommandé d’attendre la prochaine version du Service Pack SQL Server 2012 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels inclus dans ce package de mise à jour cumulative

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
899274 2562753 CORRECTIF : Performances ralenties lorsqu’une requête MDX utilise des opérateurs unaires sur les membres de la hiérarchie parent/enfant dans SSAS 2008 R2 ou dans SSAS 2012 si vous définissez un calcul d’étendue sur ces membres et si la requête accède à plusieurs dates dans une dimension temporelle
887635 2574714 CORRECTIF : résultats incorrects lorsqu’une requête MDX s’exécute sur une base de données SSAS 2008 ou SSAS 2012 si vous définissez la propriété RealTimeOlap sur True
892370 2588047 CORRECTIF : la requête MDX renvoie incorrectement une valeur NULL dans SSAS 2008 R2 ou SSAS 2012 si un cube lié contient une dimension plusieurs-à-plusieurs et un groupe de mesures de nombre distinct
892362 2590200 CORRECTIF : Erreur « Les résultats de l’instruction actuelle ne peuvent pas être stockés sur le serveur » lorsque les commandes UpdateCells effectuent simultanément de nombreuses opérations d’écriture différée dans SSAS 2008 R2 ou SSAS 2012
885538 2590839 CORRECTIF : pics de processeur faibles à un intervalle défini, même en l’absence d’activité utilisateur dans SQL Server 2008 R2 ou dans SQL Server 2012
896319 2591902 CORRECTIF : perte de données XML lorsqu’une réplication de fusion rencontre une erreur de violation de clé étrangère dans SQL Server 2005, SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
893296 2603910 CORRECTIF : la sauvegarde échoue dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012 si vous activez le suivi des modifications sur la base de données
885533 2605756 CORRECTIF : erreur interne lors de l’exécution d’une requête MDX qui utilise la fonction Descendants après la mise à niveau de SSAS 2005 vers SSAS 2008, SSAS 2008 R2 ou SSAS 2012
899270 2606211 CORRECTIF : erreur lorsqu’une requête MDX complexe a la clause NONEMPTY dans SSAS 2008 R2 ou dans SSAS 2012 si la clause WHERE a un ensemble nommé
895589 2606883 CORRECTIF : performances ralenties lorsqu’un déclencheur AFTER s’exécute sur une table partitionnée dans SQL Server 2008 R2 ou dans SQL Server 2012
896325 2606918 CORRECTIF : valeur NULL dans la colonne Rétention de la table sysmergepublications et effets sur le processus de nettoyage des métadonnées lorsque vous configurez un environnement de réplication de fusion dans une topologie de republication dans SQL Server 2008 R2 ou dans SQL Server 2012
895595 2616481 CORRECTIF : Le rapport SSRS 2008 R2 ou le rapport SSRS 2012 n’a pas de menu Exporter dans Internet Explorer 9.0 si vous utilisez la page de visualisation prête à l’emploi dans le composant WebPart SharePoint Report Viewer
896327 2616718 CORRECTIF : Performances médiocres lorsque vous synchronisez les données d’un serveur de publication SQL Server 2008 R2 ou SQL Server 2012 vers un abonné SQL Server compact 3.5
896330 2622668 CORRECTION : Message d’erreur lors de la suppression de certains enregistrements dans une table sur un serveur de publication si le nom de schéma de la table n’est pas « [dbo] »
899281 2626637 CORRECTIF : l’instruction DRILLTHROUGH ne fonctionne pas si elle est exécutée sur certains membres d’attribut dont les valeurs contiennent un ou plusieurs guillemets doubles dans SSAS 2008 R2 ou dans SSAS 2012
892372 2629168 CORRECTIF : erreur interne lors de la mise à jour d’un jeu de cellules renvoyé après l’exécution d’une requête sur une perspective dans SSAS 2008 R2 ou SSAS 2012
885539 2636425 CORRECTIF : résultat incorrect lorsque vous mettez à jour plusieurs feuilles de calcul Excel 2010 qui utilisent PowerPivot pour Excel 2010 en même temps dans SQL Server 2008 R2 ou dans SQL Server 2012
884204 2637802 CORRECTIF : Les pages d’un rapport SSRS 2008 R2 ou SSRS 2012 sont envoyées de manière incorrecte si vous utilisez la méthode ReportExecutionService.Render pour afficher le rapport au format image ou au format EMF
895728 2638448 CORRECTIF : violation d’accès lors de la compilation ou de la recompilation d’une requête dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
881813 2638932 CORRECTIF : erreur lors de l’exécution de la commande ProcessUpdate sur un cube qui possède des partitions qui utilisent des conceptions d’agrégation dans SSAS 2008 ou SSAS 2008 R2
896336 2644396 CORRECTIF : les modifications de réplication de fusion sont manquantes sur un abonné SQL Server Compact lorsqu’il s’abonne à une partition dans SQL Server 2008 R2 ou dans SQL Server 2012
895600 2647120 CORRECTIF : Des numéros de page incorrects s’affichent lors de l’exportation d’un rapport SSRS 2008 R2 au format PDF
891519 2648158 CORRECTIF : Message d’erreur « Le processus n’a pas pu s’exécuter » lorsque vous définissez une valeur non nulle dans le paramètre MaxCmdsInTran de l’agent de lecture du journal dans SQL Server 2008 R2 ou dans SQL Server 2012
895618 2649359 CORRECTIF : Une violation d’accès se produit dans l’erreur « sqlservr ! CSbMsgDispatcher ::CSbReceivedDialog ::AppendMsg" dans SQL Server 2008 R2 ou dans SQL Server 2012
885844 2695802 CORRECTIF : VersionMember_ID colonne n’existe pas dans les affichages d’abonnement de SQL Server 2012 MDS
885534 2649913 CORRECTIF : les performances peuvent diminuer lors de l’exécution d’une requête qui utilise la procédure stockée sp_cursoropen après la mise à niveau de SQL Server 2005 vers SQL Server 2008 ou vers SQL Server 2008 R2 ou vers SQL Server 2012
877206 2652024 CORRECTIF : le message d’erreur « ConfigServiceConfigurationAlreadyExists » s’affiche lorsque vous essayez d’ouvrir une base de connaissances dans Data Quality Client dans SQL Server 2012
896199 2652582 CORRECTIF : Message d’erreur « Spécification d’autorisation non valide » lorsque vous exécutez l’Assistant Déploiement d’Analysis Services SQL Server 2008 R2 à l’aide du mode d’authentification SQL Server
893278 2653893 CORRECTIF : la restauration d’une base de données dans SQL Server 2008 R2, SQL Server 2008 ou SQL 2012 est très longue.
885542 2655789 CORRECTIF : L’agent de lecture du journal de réplication échoue avec les messages d’erreur « 18773 » et « 18805 » si vous définissez l’option de table « types de valeur Arge hors ligne » sur ACTIVÉ pour la table d’articles de publication
885544 2658214 CORRECTIF : Performances insuffisantes lors de l’exécution d’une requête qui contient des prédicats AND corrélés dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
881809 2658234 CORRECTIF : mises à jour inutiles pour un abonné après sa réinitialisation si un nouvel article est ajouté à une publication dans SQL Server 2008 ou dans SQL Server 2012
885548 2661225 CORRECTIF : impossible de se connecter à une source de données lorsque vous utilisez le fournisseur SQL Server Analysis Services 10.0 OLE DB si vous activez l’option « Détecter automatiquement les paramètres » dans l’onglet Connexions d’Internet Explorer
885549 2662301 CORRECTIF : une baisse des performances se produit dans SQL Server 2008 R2 ou dans SQL Server 2012 si une utilisation élevée du processeur est observée avec une contention sur le verrouillage tournant QUERY_EXEC_STATS
885550 2669148 CORRECTIF : Une exception peut se produire lorsque vous exécutez une requête parallèle qui contient une fonction UDA CLR dans SQL Server 2008 R2 ou dans SQL Server 2012
871311 2669955 CORRECTIF : Performances ralenties lorsque vous utilisez DQS pour effectuer un nettoyage des données sur une source de données volumineuse dans SQL Server 2012
887936 2672531 CORRECTION : erreur « non-yielding on Scheduler » si vous utilisez Service Broker pour exécuter une requête distribuée dans SQL Server 2012
884202 2673056 CORRECTIF : L’ouverture du Gestionnaire de configuration SQL Server est longue si de nombreuses instances de SQL Server 2008 R2 ou de SQL Server 2012 sont installées
874242 2674817 CORRECTIF : la fonctionnalité Data Quality Services n’est pas prise en charge sur un cluster de basculement AlwaysOn SQL Server 2012 instance
866374 2678370 CORRECTIF : erreur 17310 lors de l’exécution d’une opération déclenchant un événement d’audit défini dans une spécification d’audit dans SQL Server 2012
875390 2683293 CORRECTIF : Message d’erreur « Échec de la désérialisation : la valeur demandée «< ServerEdition> » n’a pas été trouvée » lorsque vous utilisez AMO pour vous connecter à SQL Server 2012 Analysis Services
887776 2683467 CORRECTIF : Master Data Services n’est pas pris en charge sur une installation en cluster de SQL Server 2012
872113 2683514 CORRECTIF : Message d’erreur « Une erreur de base de données s’est produite » dans SQL Server 2012 lorsque vous créez une règle métier dans laquelle le nom d’un attribut contient un espace
872110 2683516 CORRECTIF : une erreur SystemOutOfMemory se produit lorsque vous utilisez MDSModelDeploy.exe pour déployer un package de déploiement de modèle qui contient plus de 100 000 lignes dans SQL Server 2012
887665 2685308 CORRECTIF : SSAS utilise uniquement 20 cœurs dans SQL Server 2012 Business Intelligence
891933 2686690 CORRECTIF : la validation du disque en cluster prend beaucoup de temps de manière inattendue s’il y a plus de 20 disques ou volumes sous une seule lettre de lecteur lors de l’installation du cluster de basculement SQL Server 2012
893874 2688692 CORRECTIF : code d’erreur 17883 lors de l’exécution du programme d’installation de SQL Server 2012 et de l’activation de la configuration FileStream
893881 2688697 CORRECTIF : erreur de mémoire insuffisante lors de l’exécution de SQL Server 2012 sur un ordinateur utilisant NUMA
893908 2688721 CORRECTIF : Message d’erreur si vous utilisez plus de 30 pools de ressources de gouverneur de ressources définis par l’utilisateur pour une instance de SQL Server 2012 : « Écouteur IOCP non productif »
893913 2688722 CORRECTIF : une exception de débordement se produit lorsque vous exécutez un SQL Server 2012 dans une machine virtuelle si l’état de la machine virtuelle est enregistré pendant une longue période
894427 2688967 CORRECTIF : la barre de progression se bloque pendant une longue période lorsque vous installez ou désinstallez un correctif logiciel pour SQL Server 2012
893254 2693568 CORRECTIF : erreur de mémoire insuffisante lors de l’exécution d’une requête DAX sur un modèle tabulaire dans SQL Server 2012 Analysis Services
894853 2689367 CORRECTIF : Les bases de données secondaires sont dans un état « inconnu » si vous joignez le réplica secondaire dans les groupes de disponibilité deux fois dans SQL Server 2012
894307 2688964 CORRECTIF : Message d’erreur lors de l’utilisation du support d’installation de SQL Server 2012 pour mettre à niveau, réparer ou désinstaller des fonctionnalités : « L’état de votre installation de SQL Server n’a pas changé après l’exécution du programme d’installation »

894249

2688946 CORRECTIF : Message d’erreur lors de l’installation de SQL Server 2012 : « Les identités des manifestes sont identiques, mais leur contenu est différent »
896026 2685132 CORRECTIF : le travail de restauration de copie des journaux de transaction restaure une sauvegarde de journal des transactions endommagée dans une base de données secondaire lorsque vous exécutez une tâche de sauvegarde de copie des journaux de transaction sur une instance de SQL Server 2008 R2 ou une instance de SQL Server 2012
897990 2692145 CORRECTIF : la base de données peut ne pas être chiffrée lorsque vous activez le chiffrement dans SQL Server 2012
868373 2685303 CORRECTIF : L’actualisation des données ne s’exécute qu’une seule fois de façon inattendue lorsque vous configurez la planification de l’actualisation des données de PowerPivot pour SharePoint dans SSAS 2012
885541 2672888 CORRECTIF : les paramètres de hiérarchie d’attributs de base sont perdus si vous rouvrez un rôle dans un projet SSAS 2008 R2 dans BIDS
887930 2671058 CORRECTIF : Message d’erreur lors de l’exécution d’une requête MDX sur un cube dans SSAS 2012 si la requête MDX a une clause de sous-sélection qui fait référence à des mesures calculées
887922 2652738 CORRECTIF : message d’erreur « Erreur du système de fichiers » lors du traitement d’une grande dimension dans SQL Server 2008 R2 Analysis Services
899285 2637503 CORRECTIF : le moteur de stockage lit deux fois la même dimension de date lorsque vous exécutez une requête MDX qui utilise un calcul YTD dans SSAS 2008 R2 ou dans SSAS 2012
868741 2518306 CORRECTIF : la requête MDX renvoie des résultats incorrects dans SSAS 2008, SSAS 2008 R2 ou SSAS 2012 si le cache de données n’est pas rempli
885552 2675232 CORRECTIF : SSAS 2008 R2 cesse de répondre lorsque vous exécutez une requête MDX qui utilise des partitions ROLAP
880000 2567304 CORRECTIF : le texte est tronqué dans le fichier journal de sortie DTExec.exe lorsque WshShell.Exec est appelé si le flux StdOut est redirigé
871960; 894895 2800256 CORRECTIF : la session « System_health » diagnostics tâche de collecte fige Microsoft SQL Server 2012

            
          

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller ce package de mise à jour cumulative

Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes
      l’objet.

    Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.

  2. Recherchez l’entrée installée par ce package de mise à jour cumulative.

  3. Cliquez avec le bouton droit sur l’entrée, puis sélectionnez Désinstaller pour supprimer le package de mise à jour cumulative.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft