Message d’erreur incorrect pour les fichiers .adml manquants

Cet article fournit une solution à un problème où des messages d’erreur incorrects sont retournés lorsque des fichiers .adml sont manquants.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 2688272

Symptômes

Symptômes sr :

En-US Domain Controller tente de créer un rapport de paramètres pour un objet de stratégie de groupe. Le rapport est créé avec le message :

Impossible de trouver un fichier de ressources approprié pour le fichier \\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx (erreur = 2) : le système ne trouve pas le fichier spécifié.
Les fichiers .admx signalés comme manquants sont présents dans le dossier spécifié.

Symptômes de reproduction :

Le changement de nom du dossier qui contient les fichiers .adml appropriés renvoie l’erreur :

Impossible de trouver un fichier de ressources approprié pour le fichier \\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx (erreur = 3) : le système ne trouve pas le chemin spécifié.
Cette erreur se produit également lorsque le dossier EN-US n’existe pas et est manquant.

La modification des objets de stratégie de groupe affectés devient impossible, les rapports sont inexacts. Le problème ne se produit pas de la même façon lorsque d’autres fichiers et dossiers de langue sont manquants, car EN-US est la langue de secours et il est chargé à la place quand une autre langue est manquante.

Cause

Pour générer des rapports ou modifier l’objet de stratégie de groupe, le fichier .admx doit être chargé, ainsi que le fichier de langage .adml approprié. Selon l’utilisateur de langue native qui demande l’opération de modification/création de rapports, le fichier .adml est recherché dans le dossier de langue approprié (en pour en, de pour de, etc.). Si, par exemple, l’utilisateur interrogeant veut l’anglais et que le magasin central d’objets de stratégie de groupe dispose uniquement des fichiers .adml allemands installés, une telle erreur se produit.

Le rapport d’erreurs est incorrect, car il fait référence au fichier .admx comme manquant, alors que ce fichier est présent à l’emplacement spécifié.

Résolution

Le fait de rendre les fichiers .adml disponibles pour la langue demandée dans le dossier approprié résout le problème. Voir How to create the Central Store for stratégie de groupe Administrative Template files in Windows Vista.

Collecte de données

Si vous avez besoin d’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour stratégie de groupe problèmes.