KB2723749 - Package de mise à jour cumulative 3 pour SQL Server 2012

S’applique à
SQL Server 2012 Business Intelligence SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

INTRODUCTION

Cet article décrit le package de mise à jour cumulative 3 pour Microsoft SQL Server 2012. Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2012.

Remarque Le numéro de build de ce package de mise à jour cumulative est 11.0.2332.0.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels de SQL Server 2012 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.

  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

  • Lorsque vous installez le package de mise à jour cumulative 3 pour SQL Server 2012, l’instruction suivante sur la page « Mise à jour SQL Server 2012 » est incorrecte :

    « Cette installation fournit les mises à jour pour la préversion technologique de la communauté de SQL Server 2012 (CTP d’août) ».

    Cette déclaration doit se lire comme suit :

    « Cette installation fournit des mises à jour pour SQL Server 2012 »

    Notez que Microsoft a confirmé qu’il s’agit d’un problème avec le package d’installation.

Informations supplémentaires

Procédure pour obtenir la mise à jour cumulative 3 pour SQL Server 2012

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ces problèmes, il est recommandé d’attendre la prochaine version du Service Pack SQL Server 2012 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support

Correctifs logiciels inclus dans ce package de mise à jour cumulative

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server dans la liste suivante, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
930647 2445812 CORRECTIF : une colonne qui utilise le type de données DATETIME ne se réplique pas sur un abonné Oracle à l’aide d’une réplication transactionnelle dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
1017674 2644794 CORRECTIF : erreur d’assertion fFalse lorsque vous essayez de convertir la valeur d’une colonne XML en une variable XML dans SQL Server 2008, dans SQL Server 2008 R2 ou dans SQL Server 2012
1017683 2645648 CORRECTIF : Échec de la procédure d’exportation lors de l’exportation d’un rapport SSRS 2008 R2 64 bits ou d’un rapport SSRS 2008 qui contient plusieurs niveaux d’une correspondance de document au format PDF
898888 2651629 CORRECTIF : message d’erreur lors de l’utilisation de DTA pour accorder une ou plusieurs requêtes à une base de données qui contient de nombreux objets dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
969186 2667037 CORRECTIF : Erreur « Le format chaîne de connexion n’est pas valide » lorsque vous essayez de créer un plan de maintenance pour un serveur SQL Server 2008 R2 ou SQL Server 2012
984792 2667742 CORRECTIF : erreur « mémoire insuffisante » lorsque vous utilisez ODBC avec SQL Server 2012
934432 2671078 CORRECTIF : Message d’erreur « Tentative de définition de la valeur d’une colonne non NULL » lors de l’utilisation d’une instruction MERGE dans SQL Server 2008, dans SQL Server 2008 R2 ou dans SQL Server 2012
934424 2680799 CORRECTIF : Message d’erreur lors de l’exécution d’un remplissage complet d’un index de recherche en texte intégral à l’aide d’analyseurs lexicaux pour la langue chinoise dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
969190 2697983 CORRECTIF : une valeur incorrecte est stockée dans la colonne TIME_ZONE de la table BACKUPSET dans SQL Server 2008 R2 ou dans SQL Server 2012
933038 2698639 CORRECTIF : les performances d’une instruction SELECT contenant un opérateur LIKE et une clause ESCAPE sont faibles dans SQL Server 2008 R2 ou SQL Server 2012
969192 2699013 CORRECTIF : SQL Server 2012, SQL Server 2008 R2 ou SQL Server 2008 cesse de répondre et une erreur « Planificateur non productif » est consignée
927689 2703193 CORRECTIF : résultats incorrects lors de l’exécution d’une requête parallèle qui utilise un index columnstore dans SQL Server 2012
969198 2706601 CORRECTIF : les groupes de séries d’un rapport sont manquants lorsque vous rendez le rapport dans SQL Server 2008 Reporting Services ou dans les versions ultérieures de Reporting Services
969200 2707015 CORRECTIF : erreur rsInternalError lors de l’exportation d’un rapport qui contient un contrôle Tablix dans SSRS 2008 R2 ou dans SSRS 2012
969202 2708027 CORRECTIF : Message d’erreur « Une erreur s’est produite lors du traitement du rapport » lorsque vous essayez d’afficher un aperçu d’un rapport SSRS 2008 R2 ou SSRS 2012 après avoir défini le classement du jeu de données sur le grec ou le Greek_100
969204 2708726 CORRECTIF : les fichiers Analyseur de performances .dll du dossier system32 ne sont pas mis à jour après l’application des mises à jour à SQL Server 2008 R2 ou à SQL Server 2012
931285 2708786 CORRECTIF : violation d’accès lorsque vous essayez de créer un index columnstore pour une table dans SQL Server 2012
931959 2709075 Erreur « Une erreur grave s’est produite sur la commande actuelle » lorsque vous exécutez une requête en texte intégral avec le prédicat CONTAINS dans SQL Server 2012
1017677 2713151 CORRECTIF : violation d’accès lors de l’utilisation de Assistant Paramétrage du moteur de base de données pour ajuster un tableau dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012 si vous activez la case case activée « Inclure les index filtrés »
937512 2713827 CORRECTIF : erreur « Dataflow - » lorsque vous essayez d’ouvrir un package SSIS dans SSIS 2012
969210 2714634 CORRECTIF : SQL Server 2008 R2 ou SQL Server 2012 prend beaucoup de temps pour générer des scripts pour une table partitionnée qui utilise la fonctionnalité de compression de données
937451 2714937 CORRECTIF : Message d’erreur « Aucun objet n’existe avec un ID de traçabilité » lors de l’exécution d’un package SSIS 2012
969214 2715289 CORRECTIF : résultats incorrects lorsque vous convertissez une colonne datetimeoffset en une colonne smalldatetime dans SQL Server 2008 R2 ou dans SQL Server 2012 lorsqu’il existe un index sur la colonne datetimeoffset
969212 2715312 CORRECTIF : Erreurs survenant lorsque vous exécutez une requête qui utilise la clause XML FOR en mode PATH dans SQL Server 2008 R2 ou dans SQL Server 2012
958508 2718920 CORRECTIF : SQL Server Agent enregistre les journaux détaillés dans le journal des applications lorsque vous démarrez un cluster de basculement SQL Server 2012 instance
976894 2725256 CORRECTIF : erreur « Échec de l’envoi de courrier » lorsque vous créez un abonnement pour remettre un rapport RDL dont le nom de fichier contient des caractères non latins dans SSRS 2012
969463, 971495 2725950 CORRECTIF : Performances ralenties ou blocage lorsque vous restaurez une base de données et exécutez des instructions en même temps dans SQL Server 2012
973290 2727221 CORRECTIF : Vous ne pouvez pas installer un instance de cluster SQL Server 2012 sur un système d’exploitation Server Core qui contient un instance de cluster existant.
1017695 2727322 CORRECTIF : Des résultats incorrects sont renvoyés lorsque vous exécutez une requête qui utilise le parallélisme dans le plan d’exécution de la requête dans SQL Server 2008, SQL Server 2008 R2 ou SQL Server 2012
973758 2727824 Message d’erreur « Aucune interface de ce type n’est prise en charge » lorsque vous ajoutez un projet à un contrôle de code source dans SQL Server Management Studio 2012
983099 2731402 CORRECTIF : priorité d’e-mail incorrecte si vous définissez la priorité d’abonnement aux e-mails SSRS sur Faible ou Normal dans SSRS 2012
950921 2733091 CORRECTIF : SQL Server est lent ou une erreur de mémoire insuffisante se produit lorsque vous exécutez une requête avec des instructions SI imbriquées sur des mesures DAX dans SQL Server 2012
1010354 2735763 CORRECTIF : l’exécution d’un package se termine de manière inattendue et le status est « Annulé » lorsque vous exécutez plusieurs packages SSIS 2012 en parallèle
968916 2737580 CORRECTIF : erreur interne lors de l’exécution de requêtes sur un modèle d’extraction non rectangulaire à l’aide de DMX ou MDX dans SQL Server 2012 Analysis Services
1011308 2740957 CORRECTION : erreur « pour la clause de mise à jour autorisée uniquement pour DECLARE CURSOR » lorsque vous exécutez des procédures stockées avec la syntaxe spécifique au curseur dans SQL Server 2012

          

Informations sur le package de mise à jour cumulative

Informations sur le redémarrage

  Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Comment désinstaller ce package de mise à jour cumulative

Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes
      l’objet.

    Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.

  2. Recherchez l’entrée installée par ce package de mise à jour cumulative.

  3. Cliquez avec le bouton droit sur l’entrée, puis sélectionnez Désinstaller pour supprimer le package de mise à jour cumulative.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Schéma d’appellation des packages de mise à jour logicielle de Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft