L’installation de Windows échoue avec une erreur : la clé de produit entrée ne correspond à aucune des images Windows disponibles pour l’installation. Entrer une autre clé de produit

Cet article décrit la clé de produit entrée ne correspond à aucune des images Windows disponibles pour l’installation. Entrez une autre erreur de clé de produit qui se produit lorsque vous installez Windows.

Produits concernés : Windows 10 (toutes les éditions), Windows Server 2019, Windows Server 2016, Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 2796988

Symptômes

Pendant l’installation de Windows, l’installation peut échouer après l’invite de sélections de langue et de clavier. En outre, le message d’erreur suivant peut s’afficher :

La clé de produit entrée ne correspond à aucune des images Windows disponibles pour l’installation. Entrez une autre clé de produit.

Cause

Ce problème peut se produire si la clé de produit fournie ne correspond pas au média utilisé pour installer Windows. La clé de produit fournie peut se trouver dans un fichier sans assistance, dans l’ei. Fichier CFG, dans le fichier PID.txt ou dans le microprogramme du BIOS. Les ordinateurs Windows fournis avec le système d’exploitation installé sont livrés avec la clé de produit dans le microprogramme. Si cette clé de produit ne correspond pas au média, le message d’erreur ci-dessus s’affiche.

Par exemple : L’installation de Windows Server sur un ordinateur provenant du fabricant avec Windows 10 installé est susceptible de provoquer ce problème.

Résolution

Pour résoudre ce problème, utilisez l’une des méthodes suivantes qui s’applique au scénario :

  1. S’il existe un fichier Sans assistance, un fichier Configuration d’édition (EI.cfg) ou le fichier d’ID de produit (PID.txt) sur le système, remplacez la clé de produit par la clé de produit appropriée pour le média que vous essayez d’installer.
  2. Si le système dispose d’une clé de produit dans la carte mère (O. A. 3.0 [OEM Activation] fournit une clé de produit OEM dans le microprogramme), vous devez utiliser un fichier Sans assistance, un fichier Configuration d’édition (EI.cfg) ou le fichier ID de produit (PID.txt).

Plus d’informations

Lors de l’installation de Windows, setup.exe utilise la logique de priorité suivante pour les clés de produit :

  1. Fichier de réponses (fichier sans assistance, EI.cfg ou PID.txt)
  2. Clé de produit OA 3.0 dans le BIOS/microprogramme
  3. Écran d’entrée de clé de produit

Si une clé est fournie, la clé est tentée d’être utilisée avec l’image disponible sur le support en cours d’installation. Si la clé de produit fournie ne correspond pas à l’étape 1 de la logique ci-dessus, une image dans le fichier WIM, l’installation échoue avec le message d’erreur mentionné dans la section Symptômes. Si aucune clé de produit n’est fournie à l’étape 1 et à l’étape 2, vous obtiendrez l’invite de clé de produit pendant l’installation.

Remarque

  • Le support de licence en volume fournit une clé de produit avec le média afin qu’il réussisse avec la logique de l’étape 1.
  • Vous ne devez pas voir ce problème avec le support de licence en volume, sauf si vous utilisez un fichier Sans assistance ou si vous avez modifié des fichiers sur le média pour modifier ou remplacer ei.cfg ou PID.txt.
  • Comment supprimer un PID.txt avec la clé de produit spécifiée : Fichiers de configuration et d’ID de produit de Windows Setup Edition (EI.cfg et PID.txt)

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.