Error message when you try to map a drive to a network share in Windows 7 or Windows Server 2008 R2

Symptoms

Consider the following scenario:
  • You use user credentials to map a drive to a network share on a client computer that is running Windows 7 or Windows Server 2008 R2.
  • You perform an action that causes a change notification I/O request packet (IRP) to be sent from the drive. For example, you open Windows Explorer and then click the mapped drive. 
  • You disconnect the mapped drive.
  • You try to map a drive to the network share by using different user credentials.  
In this scenario, you receive an error message that resembles the following:
Error 1219 ERROR_SESSION_CREDENTIAL_CONFLICT

Cause

This issue occurs because a cached handle is not closed. When you disconnect the mapped drive from the network share, a handle is cached. This is because the network share is a root of the share. Then, when the drive sends the change notification IRP and then cancels the change notification IRP, the cached handle is not closed. Therefore, the handle blocks the connection between the drive and network share for other users.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information
Propriétés

ID d'article : 2807716 - Dernière mise à jour : 13 mars 2013 - Révision : 1

Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 for Itanium-Based Systems, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2, Windows 7 Entreprise, Windows 7 Édition Familiale Basique, Windows 7 Édition Familiale Premium, Windows 7 Professionnel, Windows 7 Édition Starter, Windows 7 Édition Integrale

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