Les images liées ne sont pas affichés lorsqu’une présentation PowerPoint et images sont déplacés vers un nouveau lecteur


Symptômes


Une fois que vous déplacez à la fois une présentation Microsoft PowerPoint et les images qui sont liées à cette présentation à un nouveau lecteur ou emplacement de dossier, les images ne sont pas visibles. Au lieu de cela, les images sont affichées comme des espaces réservés, même si les images sont dans le même dossier sur le même lecteur que celui où se trouve la présentation.

Par exemple, vous créez une présentation qui contient de nombreuses images liées, et ensuite de l’écrire sur un disque compact enregistrable (CD-R). Lorsque vous ouvrez la présentation à partir du CD-R sur un autre ordinateur, les images ne sont pas affichés dans la présentation, même si elles se trouvent sur le CD-R.

Cause


Le dossier contenant les images a été déplacé. Microsoft Office PowerPoint 2007, PowerPoint 2003 et PowerPoint 2002, utilisent un chemin d’accès absolu pour localiser les images liées. Si la lettre de lecteur ou un chemin d’accès est modifiée, les images n’apparaissent pas. Cela peut se produire lorsqu’une présentation qui a été créée sur le lecteur C est écrite dans le répertoire racine d’un CD-R et puis ouvert à partir du lecteur de CD-ROM, généralement lecteur D. Étant donné que les chemins d’accès aux images liées commencent par C, les images ne sont pas disponibles lorsque la présentation est ouverte.

Solution de contournement


Pour contourner ce problème, utilisez une des méthodes suivantes.

Méthode 1 : Utiliser le « Package pour CD-ROM » ou « emporter »

Lorsque vous souhaitez exécuter une présentation sur un autre ordinateur, PowerPoint peut créer un package qui place tous les fichiers requis dans un seul dossier ou un CD-ROM. PowerPoint 2002 peut placer tous les fichiers requis dans un fichier archive unique ou sur plusieurs disques. Puis vous décompressez le Pack de PowerPoint 2002 et atteindre des fichiers sur le partage réseau ou ordinateur de destination et exécutez la présentation.

Lorsque vous compressez votre présentation, vous pouvez décider d’inclure tous les fichiers liés dans la présentation. Si vous le faites, PowerPoint le convertit les chemins d’accès absolus des liens image à celles relatives. Autrement dit, plutôt que le chemin d’accès est « Pictures\image001.jpg documents\Mes de C:\My », le chemin d’accès devient « image001.jpg ».

Emballage d’une présentation et les fichiers associés

PowerPoint 2007

Pour utiliser la fonctionnalité Package pour CD-ROM de PowerPoint 2007, procédez comme suit :
  1. Ouvrez la présentation que vous souhaitez créer un package pour CD-ROM.
  2. Cliquez sur le Bouton de Microsoft OfficeMicrosoft Office Button , pointez sur Publier, puis cliquez sur Package pour CD-ROM.
  3. Si vous êtes invité à confirmer la conversion des formats PowerPoint antérieurs, cliquez sur OK.
  4. Par défaut, tous les fichiers liés sont inclus dans le package de la présentation. Cliquez sur Copier dans un dossierou sur Copier sur le CD.

    Si vous avez cliqué sur Copier dans un dossier, procédez comme suit :
    1. Tapez un nom de dossier dans la zone Nom du dossier , puis cliquez sur Parcourir pour rechercher une destination pour ce dossier.
    2. Cliquez sur Sélectionner, puis cliquez sur OK.
    3. Cliquez sur Oui pour inclure les fichiers liés ainsi que la présentation.
    Si vous avez cliqué sur Copier sur le CD-ROM, vous devez disposer d’un CD inscriptible vierge prêt à insérer dans le lecteur de CD ou de DVD. Cliquez sur Réessayer. Lorsque PowerPoint a terminé de graver le CD, cliquez sur non lorsque vous êtes invité à graver un autre CD.
  5. Cliquez sur Fermer.
Pour démarrer la présentation, vous pouvez insérez le CD-ROM dans un ordinateur et puis double-cliquez sur l’icône de CD-ROM dans l’Explorateur Windows, ou vous pouvez localiser le dossier que vous avez créé à l’étape 4 et ouvrez la présentation dans PowerPoint 2007.

PowerPoint 2003

Pour utiliser la fonctionnalité Package pour CD-ROM de PowerPoint 2003, procédez comme suit :
  1. Ouvrez la présentation que vous souhaitez créer un package pour CD-ROM.
  2. Dans le menu fichier , cliquez sur Package pour CD-ROM .
  3. Par défaut, tous les fichiers liés sont inclus dans le package de la présentation. Cliquez sur Copier dans un dossierou sur Copier sur le CD.

    Si vous avez cliqué sur Copier dans un dossier, procédez comme suit :
    1. Tapez un nom de dossier dans la zone Nom du dossier , puis cliquez sur Parcourir pour rechercher une destination pour ce dossier.
    2. Cliquez sur Sélectionner, puis cliquez sur OK.
    3. Cliquez sur Oui pour inclure les fichiers liés ainsi que la présentation.
    Si vous avez cliqué sur Copier sur le CD-ROM, vous devez disposer d’un CD inscriptible vierge prêt à insérer dans le lecteur de CD ou de DVD. Cliquez sur Réessayer. Lorsque PowerPoint a terminé de graver le CD, cliquez sur non lorsque vous êtes invité à graver un autre CD.
  4. Cliquez sur Fermer.
Pour démarrer la présentation, vous pouvez insérez le CD-ROM dans un ordinateur et puis double-cliquez sur l’icône de CD-ROM dans l’Explorateur Windows, ou vous pouvez localiser le dossier que vous avez créé à l’étape 4 et ouvrez la présentation dans PowerPoint 2007.

PowerPoint 2002

Pour utiliser l’emporter sur une présentation à exécuter sur un autre ordinateur, procédez comme suit :

  1. Ouvrez la présentation que vous souhaitez compresser.
  2. Dans le menu fichier , cliquez sur à emporter.
  3. Suivez les instructions de l’Assistant Composition à emporter.

    Lorsque vous y êtes invité pour le lecteur de destination, cliquez sur Sélectionner la destination et accédez à un emplacement de fichier temporaire. C’est là que vous compressez votre présentation et ses fichiers associés. Cliquez sur suivant.
  4. Choisissez cette option Inclure les Fichiers liés. À ce stade, vous pouvez choisir d’incorporer les polices TrueType dans votre présentation. Cliquez sur suivant.
  5. N’incluez pas la visionneuse. Cliquez sur suivant, puis cliquez sur Terminer.
Vous pouvez ensuite copier le fichier compressé et le programme Pngsetup.exe à n’importe quel lecteur ou un partage réseau que vous choisissez.

Décompression d’une présentation PowerPoint 2002

Pour afficher votre présentation, vous devez accéder à l’emplacement que vous avez copié le fichier du pack d’et décompresser. Pour ce faire, procédez comme suit :

  1. Dans l’Explorateur Windows, naviguez jusqu'à l’emplacement de la présentation et puis double-cliquez sur Pngsetup.
  2. Permet d’entrer l’emplacement où vous souhaitez décompresser le fichier dans.
  3. Cliquez sur OK.
La présentation et les images liées de profils dans l’emplacement que vous avez choisi.

Pour définir le chemin d’accès relatif à l’aide de Code de Macro

Microsoft fournit des exemples de programmation à titre d'illustration uniquement, sans garantie expresse ou implicite. Ceci inclut, mais n'est pas limité à, les garanties implicites de qualité marchande ou d'adéquation à un usage particulier. Cet article suppose que vous êtes familiarisé avec le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les ingénieurs du support technique Microsoft peuvent aider à expliquer la fonctionnalité d'une procédure particulière. Toutefois, ils ne modifieront pas ces exemples pour fournir des fonctionnalités supplémentaires ou créer des procédures répondant à vos besoins spécifiques.
Remarque Les exemples de macro suivants ne fonctionnent que dans PowerPoint. Visual Basic pour Applications macros ne sont pas prises en charge par la visionneuse Microsoft PowerPoint. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

230746 PPT : Visionneuse : exécuter les Macros de présentation dans la visionneuse


Vous pouvez également utiliser une macro pour convertir des liens d’absolue à relative. Cela permettra de PowerPoint localiser les images en fonction de l’emplacement actuel de la présentation, tant que les images sont dans ce même répertoire.

Voici un exemple de code, indiquant une façon dans laquelle il peut être automatisée. Cet exemple de code suppose que la présentation et les images liées dans le même dossier. S’ils ne sont pas dans le même dossier, puis en exécutant ce code rompre le lien à l’image.

Exemple de Code

  1. Ouvrir l’éditeur Visual Basic :

    PowerPoint 2007
    1. Cliquez sur l’onglet affichage .
    2. Dans le groupe de Macros , cliquez sur Macros .
    3. Tapez RelPict dans la zone Nom de Macro, puis cliquez sur créer.
    PowerPoint 2003 et PowerPoint 2002
    1. Dans le menu Outils , pointez sur Macro, puis cliquez sur sécurité.
    2. Pour le niveau de sécurité, cliquez sur moyen . Cliquez sur OK.
    3. Dans le menu Outils , pointez sur Macro, puis cliquez sur Visual Basic Editor.
    4. Dans le menu Insertion, cliquez sur Module.
  2. Tapez le code suivant dans le module :
    Sub RelPict()
    Dim oSlide As Slide
    Dim oShape As Shape
    Dim lPos As Long
    Dim strLink As String
    '
    ' Loop through the presentation checking each shape
    ' on each slide to see if it is a linked picture.
    '
    For Each oSlide In ActivePresentation.Slides
    For Each oShape In oSlide.Shapes
    If oShape.Type = msoLinkedPicture Then
    With oShape.LinkFormat
    '
    ' Search from the right hand portion of the source
    ' filename and find the first backslash "\" character.
    '
    lPos = InStrRev(.SourceFullName, "\")
    '
    ' Check to see if the link has already been modified.
    '
    If lPos <> Null Then
    '
    ' Determine how long the filename is, by subtracting
    ' the position the "\" character was found at from
    ' the total length of the source file name.
    '
    lPos = Len(.SourceFullName) - lPos
    '
    ' Extract the filename from the source file name, then
    ' assign the filename to the source file name, turning
    ' it into a relative path.
    '
    strLink = Right(.SourceFullName, lPos)
    .SourceFullName = strLink
    End If
    End With
    End If
    Next oShape
    Next oSlide
    End Sub

État


Microsoft a confirmé qu'il s'agissait d'un bogue dans les produits Microsoft répertoriés dans la section « S'applique à ».