Comment faire pour résoudre les problèmes de documents endommagés dans Word pour Mac

Résumé

Cet article présente les procédures de dépannage que vous pouvez utiliser pour identifier les fichiers endommagés dans Microsoft Word pour Mac et, dans certains cas, récupérer ces fichiers.

Fichiers de document endommagé peuvent provoquer un comportement inhabituel des programmes. Ce problème se produit car le programme reçoit des informations incorrectes dans le fichier endommagé.

Plus d'informations

Comment faire pour identifier un fichier endommagé

Fichiers endommagés souvent qu’un comportement qui ne fait pas partie de la conception de programme--par exemple, repagination infinie, mise en page de document incorrect et de mise en forme, des caractères illisibles à l’écran, des messages d’erreur pendant le traitement, le système se bloque ou tombe en panne lorsque vous chargez ou affichez le fichier, ou tout autre comportement inhabituel non imputable au fonctionnement normal du programme. Ces comportements peuvent également résulter de documents endommagés. Pour éliminer les autres facteurs, suivez ces conseils de dépannage :

  • Recherchez un comportement similaire dans d’autres documents.
  • Recherchez un comportement similaire dans d’autres programmes.
  • Prendre le fichier en question sur un autre ordinateur et essayez de reproduire le comportement.
  • Utilisez un autre pilote d’imprimante et essayez de reproduire le comportement. Pour utiliser un autre pilote d’imprimante, procédez comme suit :

    1. Dans le menu Apple , sélectionnez sélecteur .
    2. Dans le sélecteur de champs, sélectionnez un autre pilote d’imprimante, puis fermez le sélecteur de champs.
    3. Dans Microsoft Word pour Mac, sélectionnez Mise en Page dans le menu fichier , pour vérifier que le pilote d’imprimante que vous avez sélectionnée dans le sélecteur est sélectionné dans Word pour Mac.
  • Renommez les modèles qui sont attachés au document, puis essaient de reproduire le comportement.
  • Redémarrez l’ordinateur, avec les extensions désactivées pour désactiver tous les programmes tiers qui sont en cours d’exécution (fin-and-stay-resident programmes TSR, gestionnaires de police, des économiseurs d’écran). Puis essayez de reproduire le comportement. Pour plus d’informations sur la façon de démarrer l’ordinateur avec des extensions de désactiver, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

    263159 comment résoudre les conflits d’extensions sur le Macintosh
Si le problème se produit uniquement avec un seul document après avoir effectué les étapes précédentes, votre document est probablement endommagé. Si le programme de manière inattendue avant la fermeture du fichier, et l’option de récupération automatique a été activée, un fichier de récupération automatique peut ont été créé. Vous pouvez utiliser ce fichier de récupération automatique pour récupérer le fichier en question.

La fonctionnalité de récupération automatique dans Word pour Mac tente de récupérer automatiquement un texte à partir d’un document qui était ouvert lorsque Word pour Mac ne répond plus. Lorsque vous redémarrez Word pour Mac après que qu’il cesse de répondre (se bloque), une boîte de dialogue s’affichera avec le message suivant :
Word a rencontré endommagé lors de l’ouverture de Nom de fichier. Partie de ce document peut être récupérée. Effectuer la récupération ?
Remarque: cette récupération peut prendre un certain temps, en fonction de la taille du document et le montant des dommages dans le document.

Une fois le document récupéré, utilisez immédiatement la commande Enregistrer sous dans le menu fichier pour enregistrer le document sous un nouveau nom de fichier. Cela garantit que le document d’origine seront disponible pour d’autres tentatives de récupération. Cette méthode de récupération automatique supprime tous les mise en forme, les graphiques et objets à partir du document.

Autres méthodes répertoriées plus loin dans cet article peuvent vous permettre de récupérer le plus de votre mise en forme d’origine du document endommagé.

Pour plus d’informations sur la fonctionnalité Récupération automatique, voir la rubrique « Empêcher la perte d’et récupérer perdu Documents Word » dans Word pour Mac vous aider.

Comment corriger un Document endommagé

Il existe plusieurs techniques que vous pouvez utiliser pour tenter de corriger un document endommagé. La méthode que vous utilisez dépend du type et la gravité des dommages et le type de comportement qui se présente. Bien que la plupart de ces méthodes réussissent généralement, pas tous les documents endommagés peuvent être récupérés. Conservation d’une copie de sauvegarde d’un document est le meilleur moyen de garantir la récupération.

Les procédures de dépannage suivantes sont divisées en deux sections : « Si le fichier peut être ouvert dans Word pour Mac » et « si le fichier ne peut pas être ouvert dans Word pour Mac ». Utilisez la section appropriée à votre situation.

Si le fichier peut être ouvert dans Word pour Mac

Si vous pouvez ouvrir le fichier dans Word pour Mac, utilisez une des méthodes suivantes.

Méthode 1 : Convertir le fichier dans un autre Format

Convertir le fichier dans un autre format, puis convertissez-le à nouveau dans son format natif.

Il s’agit de la méthode de récupération de document plus simple et la plus complète ; Essayez-la toujours en premier. Enregistrez le fichier au format RTF (RICH Text Format). Ce format conserve la mise en forme dans votre document Word pour Mac. Une fois que vous enregistrez le fichier au format RTF, rouvrez le fichier dans Word pour Mac et avant de la convertir à partir du format RTF. Si cette méthode réussit, le fichier endommagé est supprimé pendant la conversion.

Pour enregistrer le fichier au format RTF, procédez comme suit :

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.
  2. Cliquez sur le Format de la liste et sélectionnez Format RTF.
  3. Modifier le nom du document. (Cela est recommandé afin que vous pouvez continuer avec les autres étapes à l’aide du document d’origine non modifié).
  4. Cliquez sur Enregistrer.
Si le problème persiste une fois que vous enregistrez le fichier au format RTF, essayez d’enregistrer le fichier dans un des formats de fichier suivants :

  • Autres formats de traitement de texte
  • Texte uniquement
Remarque: l’enregistrement d’un fichier au format texte seulement fréquemment corrige le problème ; Toutefois, la toute mise en forme est perdue, y compris les codes de graphiques et de champ dans Word pour Mac. Cette méthode nécessite le reformatage de plus ; Par conséquent, utilisez-le uniquement après l’échouent d’autres formats de fichiers corriger le problème.


Pour plus d’informations sur la perte de Visual Basic pour Applications les code dans Word pour les documents Mac sont convertis dans d’autres formats de fichier, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

WD98 de 184153 en : Code VBA perdu après une conversion vers un autre Format de Document

Méthode 2 : Copier tout sauf la dernière marque de paragraphe dans un nouveau Document

Microsoft Word pour Mac associe un grand nombre de mise en forme à la dernière marque de paragraphe, en particulier la mise en forme de style et de section. Si vous copiez tout dans le fichier, à l’exception de la dernière marque de paragraphe dans un nouveau fichier, les dommages peuvent être conservés dans le document d’origine.

Pour copier tout sauf la dernière marque de paragraphe dans le document, procédez comme suit :

  1. Ouvrez le document qui présente un comportement anormal.
  2. Dans le menu Edition, cliquez sur Sélectionner tout.
  3. Le document sélectionné, appuyez sur commande + MAJ + gauche directionnelle. (Cela supprime uniquement la dernière marque de paragraphe de la sélection).
  4. Dans le menu Edition , cliquez sur Copier.
  5. Dans le menu fichier , sélectionnez Nouveau Document.
  6. Dans le nouveau document, sélectionnez Coller dans le menu Edition .

    Remarque: dans le nouveau document, vous devrez peut-être réappliquer la mise en forme de section ou de style.

Méthode 3 : Copier les parties intactes du fichier dans un nouveau fichier

Vous pouvez parfois déterminer l’emplacement des dommages dans votre fichier en consultant le fichier ou tester le fichier pour déterminer le moment où le problème se produit. Une autre façon de déterminer quelle zone du fichier est endommagé consiste à copier des soit une page à la fois ou une série de pages dans un nouveau fichier. Enregistrez le nouveau fichier et ensuite tester le comportement d’origine. Si le problème ne se produit pas, continuez à copier les pages, l’enregistrement et le test jusqu'à ce que le comportement d’origine se produit.

Si vous pouvez trouver quelle zone du fichier est endommagé, vous pouvez copier tout sauf la partie endommagée dans un nouveau fichier et puis procédez comme suit pour reconstruire votre document :

  1. Copiez les parties intactes de votre document et les coller dans un nouveau fichier (ne peut-être pas souhaité pour sélectionner la marque de paragraphe finale de cette sélection, car cette marque de paragraphe peut-être contenir des informations incorrectes).
  2. Enregistrer une copie du document endommagé au format texte seulement.
  3. Ouvrez le fichier en lecture seule.
  4. Copiez le texte de ce fichier, puis collez-le dans le fichier qui contient la partie intacte de votre fichier.
  5. Reformater les sections du document que vous avez collé à l’étape 4, puis enregistrez le document récupéré.

Si le fichier ne peut pas être ouvert dans Word pour Mac

Si vous ne peut pas ouvrir le fichier dans Word pour Mac, utilisez une des méthodes suivantes selon le cas.

Méthode 1 : Insérer le fichier dans un Document vierge

Si vous ne pouvez pas ouvrir un fichier pour copier tout le texte (sauf la dernière marque de paragraphe), vous pourrez peut-être insérer le fichier dans un nouveau document. Cela permet d’insérer une nouvelle marque de paragraphe finale au fichier que vous corrigez. Pour ce faire, procédez comme suit :

  1. Créer un nouveau document basé sur le modèle Normal.
  2. Dans le menu Insertion , cliquez sur fichier. Sélectionnez le document endommagé, puis cliquez sur OK.

Méthode 2 : Utiliser la commande Coller avec liaison pour ouvrir le Document avec un lien

Cette méthode utilise un document « factice » pour créer un lien, puis bascule le lien entre le document « factice » et le document endommagé.

Suivez ces étapes pour une opération de collage-lien permet d’ouvrir un document endommagé :

  1. Fermez tous les documents ouverts dans Word pour Mac, puis ouvrez un nouveau document vierge.
  2. Testde type.
  3. Sélectionnez le mot Test. Dans le menu Edition , cliquez sur Copier.
  4. Dans le menu fichier , cliquez sur Nouveau et ouvrez un nouveau document vierge.
  5. Dans le menu Edition , cliquez sur Collage spécial. Dans la boîte de dialogue Collage spécial , cliquez sur Coller avec liaison. Dans la zone en tant que , cliquez sur Texte mis en forme (RTF), puis cliquez sur OK.
  6. Dans le menu Edition , cliquez sur liens.
  7. Dans la boîte de dialogue liaisons , cliquez sur Modifier la Source. Dans la boîte de dialogue Ouvrir , recherchez et sélectionnez le document que vous souhaitez récupérer. Cliquez sur Ouvrir , puis sur OK.
  8. Lorsque le document s’ouvre, cliquez sur Enregistrer sous dans le menu fichier . Tapez un nouveau nom pour le document, puis cliquez sur Enregistrer.
  9. Le document étant ouvert, cliquez sur liaisons dans le menu Edition .
  10. Dans la boîte de dialogue liaisons , cliquez sur Rompre les liaisons. Dans la boîte de dialogue qui s’affiche, cliquez sur Oui pour rompre la liaison.
Remarque: une fois que le lien est rompu, vous devez enregistrer le document avant de fermer ou de le modifier.

Méthode 3 : Ouvrir le fichier à l’aide de « Récupération de texte de tout fichier »

En dernier recours, vous pouvez utiliser le convertisseur « Récupérer le texte de tout type de fichier » spécial pour ouvrir manuellement des documents endommagés. Ce convertisseur supprime tous les mise en forme, les graphiques et objets incorporés à partir du fichier et laisse uniquement du texte lisible (les caractères ASCII). En raison de la manière que Word pour les fichiers de document Mac sont organisés et enregistrés, le texte peut être disjoint ou dupliqué.

Même les fichiers les plus simples, il est nécessaire de reformatage considérable. Avec des fichiers plus petits, vous souhaiterez peut-être ouvrir un deuxième document nouveau et copier et de coller du texte du document récupéré dans le nouveau document, car il existe beaucoup de texte récupéré non.

Pour utiliser le convertisseur « Récupérer le texte de tout type de fichier » pour ouvrir un document, procédez comme suit :

  1. Dans le menu fichier , cliquez sur Ouvrir.
  2. Cliquez sur la liste Afficher , puis cliquez sur Récupération de texte de tout type de fichier.
  3. Recherchez le dossier qui contient le fichier endommagé, puis sélectionnez le fichier.
  4. Cliquez sur Ouvrir.
Remarque: le processus de récupération peut prendre un certain temps, en fonction de la taille du document et le type de dommage. Dès que la récupération est terminée, cliquez sur Ouvrir dans le menu fichier et puis modifiez les Types de fichiers Documents Word ou des Fichiers lisibles.

Conseil: enregistrer le fichier récupéré sous un nouveau nom, à ce stade. Cela vous empêche de remplacer accidentellement le document d’origine et garantit que le document original reste disponible pour d’autres tentatives de récupération.


Méthode 4 : Ouvrir une copie

Pour ouvrir une copie d’un document endommagé, procédez comme suit :
  1. Fermez tous les documents ouverts.
  2. Dans le menu fichier , cliquez sur Ouvrir .
  3. Sélectionnez Copier dans la liste Ouvrir .
  4. Sélectionnez le fichier endommagé.
  5. Cliquez sur Ouvrir.
Propriétés

ID d'article : 285393 - Dernière mise à jour : 26 janv. 2017 - Révision : 1

Commentaires