Erreur de connexion cliente des services Terminal Server 0xC000035B lorsque vous utilisez LmCompatibility

Cet article fournit une solution à une erreur 0xC000035B qui se produit lorsqu’une connexion cliente des services Terminal Server qui utilise le protocole RDP (Remote Desktop Protocol) 8.0 pour se connecter via un serveur de passerelle Bureau à distance Windows Server 2012.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 2903333

Symptômes

Une connexion cliente des services Terminal Server qui utilise le protocole RDP (Remote Desktop Protocol) 8.0 pour se connecter via un serveur de passerelle Bureau à distance Windows Server 2012 échoue et génère le message d’erreur suivant :

Cet ordinateur ne peut pas se connecter à l’ordinateur distant.

En outre, l’événement 4625 est enregistré dans la connexion de sécurité dans le serveur de passerelle et signale une erreur 0xC000035B.

Nom du journal : Sécurité
Source : Microsoft-Windows-Security-Auditing
Date : <DateTime>
ID d’événement : 4625
Catégorie de tâche : Ouverture de session
Niveau : Informations
Mots clés : Échec de l’audit
Utilisateur : N/A
Ordinateur : RDGW.CONTOSO.COM
Description :
Un compte n’a pas pu se connecter.

Objet:
ID de sécurité : SID NULL
Nom du compte : -
Domaine de compte : -
ID de connexion : 0x0
Type d’ouverture de session : 3
Compte pour lequel l’ouverture de session a échoué :
ID de sécurité : SID NULL
Nom du compte : Myuser
Domaine de compte : Contoso
Informations sur l’échec :
Raison de l’échec : une erreur s’est produite lors de l’ouverture de session.
État : 0xC000035B
Sous-état : 0x0

Cause

Ce problème se produit lorsque la valeur de Registre LmCompatibility est configurée pour forcer le système à utiliser NTLMv1. Une valeur LmCompatibility inférieure à 3 force le système à utiliser NTLMv1.

Par défaut, Windows Server 2012 applique les liaisons de canal dans RDP 8.0. Étant donné que ces liaisons ne sont pas envoyées lorsque NTLMv1 est utilisé, l’authentification échoue et génère le 0xC000035B « Les liaisons de canal SSPI (Security Support Provider Interface) fournies par le client étaient incorrectes ». Cela indique que les liaisons de canal ne sont pas valides.

Résolution

Importante

Suivez attentivement les étapes de cette section. Des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Vous risquez même de devoir réinstaller le système d’exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l’ensemble des risques liés à la modification du Registre. Avant de le modifier, consultez Comment sauvegarder et restaurer le Registre dans Windows en cas de problèmes.

Pour plus d’informations sur la modification du Registre, consultez la rubrique d’aide « Modification des clés et des valeurs » dans la Rédacteur du Registre.

Pour résoudre ce problème, appliquez l’une des méthodes suivantes :

Méthode 1

Ajustez la valeur de Registre LmCompatibility sur le client pour ne pas forcer NTLMv1 en lui affectant la valeur 3 ou supérieure. Pour plus d’informations sur la valeur de Registre LmCompatibility , consultez LmCompatibilityLevel.

Méthode 2

Définissez la valeur de Registre EnforceChannelBinding sur 0 (zéro) pour ignorer les liaisons de canal manquantes sur le serveur de passerelle. Pour ce faire, recherchez la sous-clé de Registre suivante et utilisez les spécifications données :

HKLM\Software\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core
Type : REG_DWORD
Nom : EnforceChannelBinding
Valeur : 0 (décimal)

Remarque

Par défaut, la valeur EnforceChannelBinding n’existe pas sur le serveur de passerelle. Vous devez créer cette valeur.